Bug 997200 - luks decryption screen fails to show up on boot frequently
luks decryption screen fails to show up on boot frequently
Status: RESOLVED DUPLICATE of bug 1020283
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
x86-64 Other
: P5 - None : Major (vote)
: ---
Assigned To: Cliff Zhao
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-05 00:35 UTC by JuPing Chan
Modified: 2017-02-03 05:55 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Output from journalctl --boot=-1 for most recent boot failure (181.16 KB, text/plain)
2016-09-05 00:35 UTC, JuPing Chan
Details
Example of successful boot log from journalctl (373.47 KB, text/plain)
2016-09-05 01:03 UTC, JuPing Chan
Details
New failure log from kernel 4.8 (1.12 MB, text/plain)
2016-11-24 17:37 UTC, JuPing Chan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JuPing Chan 2016-09-05 00:35:51 UTC
Created attachment 690797 [details]
Output from journalctl --boot=-1 for most recent boot failure

On occasion, the graphical page (presumably running Plymouth) for typing in my lvm-luks passphrase fails to appear on bootup, and a terminal interface pops up instead.

Since the past few snapshots, the situation has deteriorated and sometimes no passphrases can be entered, and the computer hangs on bootup. I can only log into Tumbleweed after rebooting the computer several times.

I have attached the journalctl output for the last known failure to boot with

journalctl --boot=-1
Comment 1 JuPing Chan 2016-09-05 01:03:19 UTC
Created attachment 690798 [details]
Example of successful boot log from journalctl

I am adding this additional log from the successful boot up in case it helps.
Comment 2 A.H.M. Donkers 2016-10-10 21:35:23 UTC
On my two monitor system (laptop with external monitor) the luks decryption window doesn't appear. When I disconnect the external monitor and reboot it does show.
Comment 3 JuPing Chan 2016-10-11 18:02:46 UTC
I just keep rebooting until the decryption screen reappears, because it should not be an inherent problem with the display itself, as the following error messages are displayed while the system hangs.

EDAC sbridge: ECC is disabled. Aborting
EDAC sbridge: Couldn't find mci handler
EDAC sbridge: Failed to register device with error -19.

Furthermore, I have an Ubuntu partition on the same system which loads without issue.
Comment 4 JuPing Chan 2016-11-24 17:37:22 UTC
Created attachment 703685 [details]
New failure log from kernel 4.8

I am adding another boot failure output because the problem appears to have gotten worse with the latest updates. I rebooted 12 times to no avail before booting into the previous kernel.

Is there a way to not load the GUI for the luks unlocking mechanism, so I can type it into the cli instead?
Comment 5 JuPing Chan 2017-01-31 03:41:54 UTC
Latest update seems to have forced installed plymouth after I installed it, and it seems to be working fine on my desktop. Unfortunately, the plymouth instance running on my laptop is now experiencing this problem of not providing an option to unlock.
Comment 6 JuPing Chan 2017-01-31 19:24:37 UTC
Potentially related to https://bugzilla.novell.com/show_bug.cgi?id=1020283
Comment 7 JuPing Chan 2017-02-03 05:55:28 UTC
This appears to be a duplicate of a bug that is more clearly identified and has more activity.

*** This bug has been marked as a duplicate of bug 1020283 ***