Bug 996928 - Steam Segmentation fault preventing launch on Tumbleweed and Leap 42.2
Steam Segmentation fault preventing launch on Tumbleweed and Leap 42.2
Status: RESOLVED DUPLICATE of bug 988273
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Other
Leap 42.2
64bit SUSE Other
: P5 - None : Normal (vote)
: ---
Assigned To: Dirk Stoecker
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-09-01 17:04 UTC by Pedro Rosado
Modified: 2016-09-04 10:42 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro Rosado 2016-09-01 17:04:45 UTC
Steam is giving me the same error that tumbleweed gave me while trying to run it. Works flawlessly on 42.1 not on TW and 42.2 This bug as been reported to github since it affects more users, and to the forums as well. 

    ** (steam:9499): WARNING **: Could not initialize NMClient /org/freedesktop/NetworkManager: The name org.freedesktop.NetworkManager was not provided by any .service files
    Installing breakpad exception handler for appid(steam)/version(1471977975)
    Generating new string page texture 2: 48x256, total string texture memory is 49,15 KB
    Generating new string page texture 3: 256x256, total string texture memory is 311,30 KB
    Installing breakpad exception handler for appid(steam)/version(1471977975)
    Installing breakpad exception handler for appid(steam)/version(1471977975)
    assert_20160831102737_1.dmp[9545]: Uploading dump (out-of-process)
    /tmp/dumps/assert_20160831102737_1.dmp
    /home/pedro/.local/share/Steam/steam.sh: line 713: 9499 Segmentation fault (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$STEAMEXEPATH" "$@"
    assert_20160831102737_1.dmp[9545]: Finished uploading minidump (out-of-process): success = yes
    assert_20160831102737_1.dmp[9545]: response: CrashID=bp-e7ccfe58-6a17-4a8a-94a0-f4bd22160831
    assert_20160831102737_1.dmp[9545]: file ''/tmp/dumps/assert_20160831102737_1.dmp'', upload yes: ''CrashID=bp-e7ccfe58-6a17-4a8a-94a0-f4bd22160831''



The github thread: https://github.com/ValveSoftware/ste...ment-238342440


This bug affects multiple users on tumbleweed and leap 42.2 as it's shown on the github page, and doesn't depend on hardware per se. 

Leap 42.2 shares the same kernel (4.4) as ubuntu, but the same issue isn't found on ubuntu. I tried this in two machines, both with an AMD gpu (one a desktop r7 and another with an r5 laptop). The issue appears in both on opensuse leap 42.2 beta and tumbeweed
Comment 1 Pedro Rosado 2016-09-03 16:38:42 UTC
For what I've been reading, this is the same as Bug 988273 - Steam segmentation fault in libcrypto 

https://github.com/ValveSoftware/steam-for-linux/issues/4583

Gonna mark as duplicate of bug 988273

*** This bug has been marked as a duplicate of bug 988273 ***
Comment 2 Matthias Mailänder 2016-09-04 10:42:46 UTC
https://build.opensuse.org/request/show/424685