Bug 985156 - GCC6: python3-cffi fails to build
GCC6: python3-cffi fails to build
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P2 - High : Major (vote)
: ---
Assigned To: Michal Vyskocil
E-mail List
:
Depends on:
Blocks: 984984
  Show dependency treegraph
 
Reported: 2016-06-16 13:37 UTC by Dominique Leuenberger
Modified: 2016-08-08 15:46 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2016-06-16 13:37:01 UTC
Since the update to GCC6, openSUSE:Factory/ python3-cffi fails to build
Comment 1 Dominique Leuenberger 2016-06-21 09:23:14 UTC
Increasing severity - this package has since been promoted to be a ring package (needed by python3-pyOpenSSL and breaks thus now all stagings.
Comment 2 Michal Vyskocil 2016-06-21 20:36:16 UTC
Added issue upstream:

https://bitbucket.org/cffi/cffi/issues/269/test_verify1py-fails-under-gcc6

The problem is that cffi generates zero shift for global constants, which gcc6 threats as an error. I was not able to understand the cffi code enough to solve it, so hope upstream will help.

I can - as a hotfix - patch this test out.
Comment 3 Michal Vyskocil 2016-06-22 09:51:53 UTC
OK, I've messed the cffi 1.6 in factory with 1.7 source code yesterday afternoon. That was a reason I was not able to find the responsible line. cffi 1.7 generates | 0, so shall not trigger the error.

I sent update to 1.7 via request 404003
Comment 4 Dominique Leuenberger 2016-08-08 15:46:13 UTC
Fixed by https://build.opensuse.org/request/show/404059