Bug 983823 - latexpand does not work anymore after Tumbleweed update
latexpand does not work anymore after Tumbleweed update
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Dr. Werner Fink
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-08 17:30 UTC by Ronan Chagas
Modified: 2017-01-20 13:02 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
werner: needinfo? (ronisbr)


Attachments
/usr/bin/latexpand (10.66 KB, text/plain)
2016-06-21 15:58 UTC, Dr. Werner Fink
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ronan Chagas 2016-06-08 17:30:50 UTC
Hi guys!

After a Tumbleweed snapshot (I am not sure which one), `latexpand` stopped working. If I try to execute this script I get:

$ /usr/binlatexpand
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/^[ \t]*\\end{ <-- HERE document}/ at /usr/bin/latexpand line 126.
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/^\s*\\usepackage{ <-- HERE ([^}]*)}\s*(%.*)?$/ at /usr/bin/latexpand line 206.
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/^(.*)\\bibliography{ <-- HERE ([^}]*)}(.*)$/ at /usr/bin/latexpand line 219.
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/^[ \t]*\\begin{ <-- HERE document}/ at /usr/bin/latexpand line 236.
Can't use global $_ in "my" at /usr/bin/latexpand line 136, near "($_"
Global symbol "$prefix" requires explicit package name (did you forget to declare "my $prefix"?) at /usr/bin/latexpand line 136.
Global symbol "$file" requires explicit package name (did you forget to declare "my $file"?) at /usr/bin/latexpand line 136.
Global symbol "$file" requires explicit package name (did you forget to declare "my $file"?) at /usr/bin/latexpand line 148.
Global symbol "$prefix" requires explicit package name (did you forget to declare "my $prefix"?) at /usr/bin/latexpand line 166.
Global symbol "$prefix" requires explicit package name (did you forget to declare "my $prefix"?) at /usr/bin/latexpand line 170.
Global symbol "$prefix" requires explicit package name (did you forget to declare "my $prefix"?) at /usr/bin/latexpand line 184.
Global symbol "$prefix" requires explicit package name (did you forget to declare "my $prefix"?) at /usr/bin/latexpand line 187.
Global symbol "$prefix" requires explicit package name (did you forget to declare "my $prefix"?) at /usr/bin/latexpand line 209.
Global symbol "$prefix" requires explicit package name (did you forget to declare "my $prefix"?) at /usr/bin/latexpand line 210.
Global symbol "$prefix" requires explicit package name (did you forget to declare "my $prefix"?) at /usr/bin/latexpand line 213.
Global symbol "$prefix" requires explicit package name (did you forget to declare "my $prefix"?) at /usr/bin/latexpand line 223.
Global symbol "$prefix" requires explicit package name (did you forget to declare "my $prefix"?) at /usr/bin/latexpand line 224.
Global symbol "$prefix" requires explicit package name (did you forget to declare "my $prefix"?) at /usr/bin/latexpand line 232.
Execution of /usr/bin/latexpand aborted due to compilation errors.

I could not find any workaround for this problem so far.
Comment 1 Dr. Werner Fink 2016-06-20 07:11:18 UTC
This seems to be a perl problem ... here on a Leap 42.1 I see

 werner/texlive> latexpand
 Use of my $_ is experimental at /usr/bin/latexpand line 136.

and with newer perl versions the { and } has to be escaped AFAIK
Comment 2 Dr. Werner Fink 2016-06-21 15:58:14 UTC
Created attachment 681551 [details]
/usr/bin/latexpand

Just a try if this works for you
Comment 3 Dr. Werner Fink 2016-06-21 16:00:23 UTC
Btw: this had never ever work with tumbleweed latest perl regardless of TeXLive version
Comment 4 Joey Dumont 2016-09-08 18:31:47 UTC
(In reply to Dr. Werner Fink from comment #2)
> Created attachment 681551 [details]
> /usr/bin/latexpand
> 
> Just a try if this works for you

I can confirm that this works for me, on Arch Linux.
Comment 5 Dr. Werner Fink 2017-01-20 12:06:09 UTC
fixed
Comment 6 Dr. Werner Fink 2017-01-20 12:08:21 UTC
indeed
Comment 7 Bernhard Wiedemann 2017-01-20 13:02:00 UTC
This is an autogenerated message for OBS integration:
This bug (983823) was mentioned in
https://build.opensuse.org/request/show/451589 42.3 / texlive-specs-a
https://build.opensuse.org/request/show/451590 42.3 / texlive-specs-b
https://build.opensuse.org/request/show/451591 42.3 / texlive-specs-c
https://build.opensuse.org/request/show/451592 42.3 / texlive-specs-d
https://build.opensuse.org/request/show/451593 42.3 / texlive-specs-e
https://build.opensuse.org/request/show/451594 42.3 / texlive-specs-f
https://build.opensuse.org/request/show/451595 42.3 / texlive-specs-g
https://build.opensuse.org/request/show/451596 42.3 / texlive-specs-h
https://build.opensuse.org/request/show/451597 42.3 / texlive-specs-i
https://build.opensuse.org/request/show/451598 42.3 / texlive-specs-j
https://build.opensuse.org/request/show/451599 42.3 / texlive-specs-k
https://build.opensuse.org/request/show/451600 42.3 / texlive-specs-m
https://build.opensuse.org/request/show/451602 42.3 / texlive-specs-n
https://build.opensuse.org/request/show/451603 42.3 / texlive-specs-o
https://build.opensuse.org/request/show/451604 42.3 / texlive-specs-p
https://build.opensuse.org/request/show/451605 42.3 / texlive-specs-q
https://build.opensuse.org/request/show/451607 42.3 / texlive-specs-r
https://build.opensuse.org/request/show/451609 42.3 / texlive-specs-s
https://build.opensuse.org/request/show/451616 42.3 / texlive-specs-t
https://build.opensuse.org/request/show/451617 42.3 / texlive-specs-u
https://build.opensuse.org/request/show/451618 42.3 / texlive-specs-v
https://build.opensuse.org/request/show/451619 42.3 / texlive-specs-w
https://build.opensuse.org/request/show/451620 42.3 / texlive-specs-x
https://build.opensuse.org/request/show/451621 42.3 / texlive-specs-y
https://build.opensuse.org/request/show/451622 42.3 / texlive-specs-z
https://build.opensuse.org/request/show/451623 42.3 / texlive-specs-l