Bug 983216 - (CVE-2016-5300) VUL-1: CVE-2016-5300: expat: Re: expat hash collision fix too predictable?
(CVE-2016-5300)
VUL-1: CVE-2016-5300: expat: Re: expat hash collision fix too predictable?
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/169793/
CVSSv2:SUSE:CVE-2016-5300:4.3:(AV:N/A...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-06 09:05 UTC by Marcus Meissner
Modified: 2018-09-28 14:43 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Meissner 2016-06-06 09:05:19 UTC
CVE-2016-5300

from mitre on oss-sec

    Please confirm that using CVE-2012-6702 for consequences of
    "unanticipated internal calls to srand" is what you intended.


Yes, we confirm that. (They are unanticipated both because of
thread-safety concerns, and because it's possible for an application
to have an important dependency on srand being called exactly once.)


    The hash DoS vulnerability CVE-2012-0876 was fixed to some extend in
    Expat 2.1.0, commit e3e81a6d
    ...
    The next release of Expat will not do internal calls to srand (or rand)
    any more but extract and use entropy from other sources.
    ...
    I suppose hash initialization with (too little /) second-based
    entropy still is part of the original CVE-2012-0876 (or the same again).


Use CVE-2016-5300 for the separate issue in which the original choices
of entropy source and RNG did not properly address the possibility of
a successful hash DoS attack. In other words, the code changes (in the
next release) to fix CVE-2016-5300 are needed because the original fix
for CVE-2012-0876 was insufficient. (We use separate CVE IDs when
follow-on work is needed to complete the solution to the same original
vulnerability finding.)


References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-5300
http://seclists.org/oss-sec/2016/q2/473
Comment 1 Marcus Meissner 2016-06-06 09:12:09 UTC
commit 6acb0a47372a9079cc6ff70c384f015a47f2c34a and following ... repalce rand/srand by some home grown randomness gathering
Comment 2 Swamp Workflow Management 2016-06-06 22:00:55 UTC
bugbot adjusting priority
Comment 4 Bernhard Wiedemann 2016-11-21 11:00:40 UTC
This is an autogenerated message for OBS integration:
This bug (983216) was mentioned in
https://build.opensuse.org/request/show/441164 Factory / expat
Comment 5 Tomáš Chvátal 2017-02-02 12:33:45 UTC
submissions done.
Comment 7 Swamp Workflow Management 2017-02-02 16:11:43 UTC
An update workflow for this issue was started.
This issue was rated as moderate.
Please submit fixed packages until 2017-02-16.
When done, reassign the bug to security-team@suse.de.
https://swamp.suse.de/webswamp/wf/63374
Comment 8 Swamp Workflow Management 2017-02-07 17:15:22 UTC
SUSE-SU-2017:0415-1: An update that solves two vulnerabilities and has one errata is now available.

Category: security (moderate)
Bug References: 1022037,983215,983216
CVE References: CVE-2012-6702,CVE-2016-5300
Sources used:
SUSE Studio Onsite 1.3 (src):    expat-2.0.1-88.41.1
SUSE Linux Enterprise Software Development Kit 11-SP4 (src):    expat-2.0.1-88.41.1
SUSE Linux Enterprise Server 11-SP4 (src):    expat-2.0.1-88.41.1
SUSE Linux Enterprise Debuginfo 11-SP4 (src):    expat-2.0.1-88.41.1
Comment 9 Swamp Workflow Management 2017-02-08 17:09:26 UTC
SUSE-SU-2017:0424-1: An update that fixes two vulnerabilities is now available.

Category: security (moderate)
Bug References: 983215,983216
CVE References: CVE-2012-6702,CVE-2016-5300
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP2 (src):    expat-2.1.0-20.2
SUSE Linux Enterprise Software Development Kit 12-SP1 (src):    expat-2.1.0-20.2
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (src):    expat-2.1.0-20.2
SUSE Linux Enterprise Server 12-SP2 (src):    expat-2.1.0-20.2
SUSE Linux Enterprise Server 12-SP1 (src):    expat-2.1.0-20.2
SUSE Linux Enterprise Desktop 12-SP2 (src):    expat-2.1.0-20.2
SUSE Linux Enterprise Desktop 12-SP1 (src):    expat-2.1.0-20.2
Comment 10 Swamp Workflow Management 2017-02-17 03:15:39 UTC
openSUSE-SU-2017:0483-1: An update that fixes two vulnerabilities is now available.

Category: security (moderate)
Bug References: 983215,983216
CVE References: CVE-2012-6702,CVE-2016-5300
Sources used:
openSUSE Leap 42.2 (src):    expat-2.1.0-19.1
openSUSE Leap 42.1 (src):    expat-2.1.0-20.1
Comment 11 Marcus Meissner 2017-03-02 14:06:54 UTC
released