Bug 966878 - way too low max proc setting
way too low max proc setting
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: systemd maintainers
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-16 13:46 UTC by Marcus Rückert
Modified: 2017-05-18 15:05 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
werner: needinfo? (mrueckert)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Rückert 2016-02-16 13:46:45 UTC
```
head /sys/fs/cgroup/pids/user.slice/user-$uid.slice/session-?.scope/pids.*
==> /sys/fs/cgroup/pids/user.slice/user-$uid.slice/session-1.scope/pids.current <==
16

==> /sys/fs/cgroup/pids/user.slice/user-$uid.slice/session-1.scope/pids.max <==
512

==> /sys/fs/cgroup/pids/user.slice/user-$uid.slice/session-2.scope/pids.current <==
499

==> /sys/fs/cgroup/pids/user.slice/user-$uid.slice/session-2.scope/pids.max <==
512
```

session 1: via text console login
session 2: via GDM

seems to be a bit low.
Comment 1 Marcus Rückert 2016-02-16 14:03:31 UTC
I do not see this behavior on my laptop. the difference is on my workstation I start tmux in the console session before my first login to the X session.

so the X session might inherit limits from the console session.

on the laptop pids.max reports "max".
Comment 2 Dr. Werner Fink 2016-02-16 14:46:34 UTC
(In reply to Marcus Rückert from comment #1)

The seems to be not a bug but a configuration problem. Why do you not configure your system for your needs?
Comment 3 Marcus Rückert 2016-02-16 14:55:05 UTC
I did not configure anything differently between the 2 machines. and according to dimstar the behavior seen on my laptop is the correct behavior.

both are up2date TW installations.

When i am not swamped, I will test what happens if i login to X on my workstation without a console session.
Comment 4 Franck Bui 2017-05-18 15:05:50 UTC
The default value for UserTasksMax in /etc/logind.conf has been bumped to a value > 10000 and this has been done for TW and any distro based on v228 too.

So I think this bug can be closed now.