Bug 961304 - libzypp has a resolution problem with packages containing appdata.xml
libzypp has a resolution problem with packages containing appdata.xml
Status: RESOLVED DUPLICATE of bug 952324
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: libzypp
Leap 42.1
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 07:00 UTC by Dave Plater
Modified: 2016-01-11 08:52 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Plater 2016-01-11 07:00:06 UTC
Since the beginning of my clean openSUSE:Leap:42.1 installation I've had a problem with zypper verify and yast2 installation or update not being able to resolve thunar and dolphin. I've been preparing the package multimedia:apps for factory and I noticed that after I resolved it's gnome schema problem with %glib2_gsettings_schema_post in the %post section of the spec file, buzztrax became part of the resolution problem. I then manually provided 
"appdata(buzztrax-edit.appdata.xml)" which is what libzypp was looking for and buzztrax was no longer part of the problem.

This is the zypper verify output note that nothing is ever removed and the error remains until the next verify:

# zypper verify
Loading repository data...
Reading installed packages...
2 Problems:
Problem: nothing provides appdata(Thunar.appdata.xml) needed by application:Thunar File Manager-.noarch
Problem: nothing provides appdata(org.kde.dolphin.appdata.xml) needed by application:Dolphin-.noarch

Problem: nothing provides appdata(Thunar.appdata.xml) needed by application:Thunar File Manager-.noarch
 Solution 1: deinstallation of application:Thunar File Manager-.noarch
 Solution 2: break application:Thunar File Manager-.noarch by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 1

Problem: nothing provides appdata(org.kde.dolphin.appdata.xml) needed by application:Dolphin-.noarch
 Solution 1: deinstallation of application:Dolphin-.noarch
 Solution 2: break application:Dolphin-.noarch by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 1
Resolving dependencies...

The following 2 applications are going to be REMOVED:
  Dolphin "Thunar File Manager"

No additional space will be used or freed after the operation.
Dependencies of all installed packages are satisfied.
Comment 1 Dave Plater 2016-01-11 07:13:52 UTC
I installed buzztrax from Packman which is a link to the multimedia:apps package and I haven't sent my spec file change to yet and this is the result of zypper verify. The buzztrax that zypper installs is from my local :rpm" repository and is the only buzztrax available which provides "appdata(buzztrax-edit.appdata.xml)". I don't uderstand the Unknown media type in type 'all/all' at the bottom, I just ignore it.:

# zypper verify
Loading repository data...
Reading installed packages...
3 Problems:
Problem: nothing provides appdata(Thunar.appdata.xml) needed by application:Thunar File Manager-.noarch
Problem: nothing provides appdata(org.kde.dolphin.appdata.xml) needed by application:Dolphin-.noarch
Problem: application:Buzztrax Music Editor-.noarch requires appdata(buzztrax-edit.appdata.xml), but this requirement cannot be provided

Problem: nothing provides appdata(Thunar.appdata.xml) needed by application:Thunar File Manager-.noarch
 Solution 1: deinstallation of application:Thunar File Manager-.noarch
 Solution 2: break application:Thunar File Manager-.noarch by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 1

Problem: nothing provides appdata(org.kde.dolphin.appdata.xml) needed by application:Dolphin-.noarch
 Solution 1: deinstallation of application:Dolphin-.noarch
 Solution 2: break application:Dolphin-.noarch by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 1

Problem: application:Buzztrax Music Editor-.noarch requires appdata(buzztrax-edit.appdata.xml), but this requirement cannot be provided
  uninstallable providers: buzztrax-0.10.2-0.x86_64[rpms]
 Solution 1: Following actions will be done:
  downgrade of buzztrax-0.10.2-5.1.x86_64 to buzztrax-0.10.2-0.x86_64
  install buzztrax-0.10.2-0.x86_64 (with vendor change)
    http://packman.links2linux.de  -->  
 Solution 2: deinstallation of application:Buzztrax Music Editor-.noarch
 Solution 3: break application:Buzztrax Music Editor-.noarch by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c): 1
Resolving dependencies...

The following 2 applications are going to be REMOVED:
  Dolphin "Thunar File Manager"

The following package is going to be downgraded:
  buzztrax

The following package is going to change vendor:
  buzztrax  http://packman.links2linux.de -> 


1 package to downgrade, 1 to change vendor.
Overall download size: 1.7 MiB. Already cached: 0 B. After the operation, additional 2.7 MiB will be used.
Some of the dependencies of installed packages are broken. In order to fix these dependencies, the following actions need to be taken:
Continue? [y/n/? shows all options] (y): 
Retrieving package buzztrax-0.10.2-0.x86_64                                                                                                                                                 (1/1),   1.7 MiB (  5.7 MiB unpacked)
Checking for file conflicts: ..............................................................................................................................................................................................[done]
(1/1) Installing: buzztrax-0.10.2-0 .......................................................................................................................................................................................[done]
Additional rpm output:
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Comment 2 Dave Plater 2016-01-11 07:33:23 UTC
Added xfce maintainers for thunar.
Comment 3 Dave Plater 2016-01-11 07:35:38 UTC
Added kde dolphin maintainer.
Comment 4 Michael Andres 2016-01-11 08:52:41 UTC
Same as #952324, #953070, ...

This should be fixed with libsolv-0.6.15.

*** This bug has been marked as a duplicate of bug 952324 ***