Bug 951153 - gitk German translations broken
gitk German translations broken
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Takashi Iwai
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 08:51 UTC by Pieter Hollants
Modified: 2017-03-21 17:09 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Fix patch (1.57 KB, patch)
2015-10-20 12:26 UTC, Takashi Iwai
Details | Diff
Patch to adapt msgid key changes in po files (21.05 KB, patch)
2015-10-20 12:27 UTC, Takashi Iwai
Details | Diff
Patch to add accelerators to Japanese locale (2.25 KB, patch)
2015-10-20 12:27 UTC, Takashi Iwai
Details | Diff
Patch to add accelerators to German locale (2.49 KB, patch)
2015-10-20 12:28 UTC, Takashi Iwai
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pieter Hollants 2015-10-20 08:51:13 UTC
With latest gitk on Tumbleweed:

pief@e7450:~> rpm -qf `which gitk`
gitk-2.6.0-1.1.x86_64
pief@e7450:~/some_git_repo> gitk --all
Error in startup script: bad menu entry index "Ansicht bearbeiten ..."
    while executing
".bar.view entryconf [mca "Edit view..."] -state normal"
    invoked from within
"if {$cmdline_files ne {} || $revtreeargs ne {} || $revtreeargscmd ne {}} {
    # create a view for the files/dirs specified on the command line
    se..."
    (file "/usr/bin/gitk" line 12442)

Workaround: LANG=C gitk --all

Cf. http://permalink.gmane.org/gmane.comp.version-control.git/278846
Cf. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=801784
Comment 1 Takashi Iwai 2015-10-20 10:27:45 UTC
The bug comes from the recent accelerator support:
commit d99b4b0de27a2bd654a40353b65883e368da6d06
Author: Giuseppe Bilotta <giuseppe.bilotta@gmail.com>
Date:   Wed Sep 9 15:20:53 2015 +0200

    gitk: Accelerators for the main menu
    
    This allows fast, keyboard-only usage of the menu (e.g. Alt+V, N to open a
    new view).
    
    Signed-off-by: Giuseppe Bilotta <giuseppe.bilotta@gmail.com>
    Signed-off-by: Paul Mackerras <paulus@samba.org>

This changes the string appearing the menu, and since --all or other option invokes with this explicit menu string, it doesn't match and aborts.

And, not only this, the whole translations for menu items are lost due to this change.

IMO, we should revert this as a quick fix until the upstream addresses it properly.
Comment 2 Andreas Stieger 2015-10-20 10:47:51 UTC
Cannot reproduce with 2.6.2 on openSUSE 13.2.

Reporter, to rule out this hasn't already been fixed upstream in 2.6.1 or 2.6.2, please verify with 2.6.2 from devel:tools:scm

https://build.opensuse.org/package/show/devel:tools:scm/git
https://software.opensuse.org/download.html?project=devel%3Atools%3Ascm&package=git
Comment 3 Andreas Stieger 2015-10-20 10:49:35 UTC
(In reply to Andreas Stieger from comment #2)
> Cannot reproduce with 2.6.2 on openSUSE 13.2.

Correction, reproduction:

$ LC_ALL="de_DE.UTF-8" gitk --all
Error in startup script: bad menu entry index "Ansicht bearbeiten ..."
    while executing
".bar.view entryconf [mca "Edit view..."] -state normal"
    invoked from within
"if {$cmdline_files ne {} || $revtreeargs ne {} || $revtreeargscmd ne {}} {
    # create a view for the files/dirs specified on the command line
    se..."
    (file "/usr/bin/gitk" line 12442)
Comment 4 Takashi Iwai 2015-10-20 12:25:51 UTC
Further looking at the code, the fix is easy, just adapt the two leftover strings to the new strings with ampersand.

But the translations are still missing, and this needs the changes in each *.po file.  Also, for adding the acceleration, the translation itself has to be updated, too.

I'm going to submit the patches to upstream.
Comment 5 Takashi Iwai 2015-10-20 12:26:39 UTC
Created attachment 652351 [details]
Fix patch
Comment 6 Takashi Iwai 2015-10-20 12:27:12 UTC
Created attachment 652352 [details]
Patch to adapt msgid key changes in po files
Comment 7 Takashi Iwai 2015-10-20 12:27:42 UTC
Created attachment 652353 [details]
Patch to add accelerators to Japanese locale
Comment 8 Takashi Iwai 2015-10-20 12:28:01 UTC
Created attachment 652354 [details]
Patch to add accelerators to German locale
Comment 9 Andreas Stieger 2015-10-24 00:48:18 UTC
Reporter, please verify this is fixed by those patches using the build from devel:tools:scm / git,
Comment 10 Andreas Stieger 2015-10-26 09:08:31 UTC
Fixed in devel:tools:scm / git
https://build.opensuse.org/request/show/340690
Closing.
Comment 11 Bernhard Wiedemann 2015-10-26 10:00:17 UTC
This is an autogenerated message for OBS integration:
This bug (951153) was mentioned in
https://build.opensuse.org/request/show/340925 Leap:42.1 / git
Comment 12 Swamp Workflow Management 2017-03-21 17:09:34 UTC
SUSE-RU-2017:0784-1: An update that has 8 recommended fixes can now be installed.

Category: recommended (low)
Bug References: 1011169,905707,939065,942297,951153,961112,961292,977477
CVE References: 
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP2 (src):    git-2.12.0-23.1
SUSE Linux Enterprise Software Development Kit 12-SP1 (src):    git-2.12.0-23.1
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (src):    git-2.12.0-23.1
SUSE Linux Enterprise Server 12-SP2 (src):    git-2.12.0-23.1
SUSE Linux Enterprise Server 12-SP1 (src):    git-2.12.0-23.1
OpenStack Cloud Magnum Orchestration 7 (src):    git-2.12.0-23.1