Bug 936206 - accounts-daemon segfault when inccorrect passwd provided
accounts-daemon segfault when inccorrect passwd provided
Status: RESOLVED WORKSFORME
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: GNOME
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-26 09:12 UTC by Martin Pluskal
Modified: 2020-06-25 18:36 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
backtrace (7.54 KB, text/plain)
2015-06-26 09:12 UTC, Martin Pluskal
Details
core (190.50 KB, application/x-xz)
2015-06-26 09:13 UTC, Martin Pluskal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Pluskal 2015-06-26 09:12:50 UTC
Created attachment 639342 [details]
backtrace

I have noticed segfault when logging in on current factory (over ssh, when entering wrong passwd):
#0  magazine_chain_pop_head (magazine_chunks=0x1f547c0) at gslice.c:539
#1  thread_memory_magazine1_alloc (tmem=<optimized out>, ix=1) at gslice.c:842
#2  g_slice_alloc (mem_size=mem_size@entry=24) at gslice.c:998
#3  0x00007fded1db6b76 in g_list_prepend (list=0x7fdec4001500, data=data@entry=0x1fd6a00) at glist.c:311
#4  0x000000000040f3f8 in wtmp_helper_entry_generator (users=0x1f726a0, state=0x7fff4e948258) at wtmp-helper.c:165
#5  0x0000000000408f6b in load_entries (daemon=daemon@entry=0x1f688c0, users=users@entry=0x1f726a0, entry_generator=0x40f300 <wtmp_helper_entry_generator>) at daemon.c:247
#6  0x000000000040913f in reload_users (daemon=daemon@entry=0x1f688c0) at daemon.c:317
#7  0x00000000004092d9 in reload_users_timeout (daemon=0x1f688c0, daemon@entry=<error reading variable: value has been optimized out>) at daemon.c:358
#8  0x00007fded1dbb583 in g_timeout_dispatch (source=0x1fb4600, callback=<optimized out>, user_data=<optimized out>) at gmain.c:4545
#9  0x00007fded1dbab55 in g_main_dispatch (context=0x1f5c8d0) at gmain.c:3122
#10 g_main_context_dispatch (context=context@entry=0x1f5c8d0) at gmain.c:3737
#11 0x00007fded1dbaec8 in g_main_context_iterate (context=0x1f5c8d0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3808
#12 0x00007fded1dbb18a in g_main_loop_run (loop=0x1f64640) at gmain.c:4002
#13 0x0000000000408020 in main (argc=1, argv=0x7fff4e948558) at main.c:219
Comment 1 Martin Pluskal 2015-06-26 09:13:08 UTC
Created attachment 639343 [details]
core
Comment 2 Dominique Leuenberger 2020-06-25 13:36:26 UTC
Can you still reproduce this? I somewhat assume this has vanished with one of the many upgrades around the various stacks since you filed this issue (sorry for ignoring the bug so long)
Comment 3 Martin Pluskal 2020-06-25 18:36:56 UTC
(In reply to Dominique Leuenberger from comment #2)
> Can you still reproduce this? I somewhat assume this has vanished with one
> of the many upgrades around the various stacks since you filed this issue
> (sorry for ignoring the bug so long)

I doubt, closing as WORKSFORME