Bug 929755 - shutter is missing perl(Gnome2) in Tumbleweed
shutter is missing perl(Gnome2) in Tumbleweed
Status: REOPENED
: 1167975 1171360 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
201503*
x86-64 SUSE Other
: P3 - Medium : Minor with 1 vote (vote)
: ---
Assigned To: Ray chen
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-05 17:53 UTC by Florian Koch
Modified: 2021-11-21 03:40 UTC (History)
10 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Koch 2015-05-05 17:53:54 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36
Build Identifier: 

flo@linux-mvsa:~> sudo zypper in shutter
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides perl(Gnome2) needed by shutter-0.93.1-1.1.noarch
 Solution 1: do not install shutter-0.93.1-1.1.noarch
 Solution 2: break shutter-0.93.1-1.1.noarch by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c): 


Reproducible: Always
Comment 1 Hermann Herz 2015-08-05 12:19:32 UTC
same here... can't install shutter
Comment 2 Ondřej Súkup 2015-10-25 19:26:03 UTC
shutter isn't part of Tumbleweed , from which repo is comming ?

btw. same problem is perl-Gnome2 , 

if You using X11:Utilities repository from OBS, you should may use openSUSE_Factory repo and you must also use devel:languages:perl repo for Factory or Tumbleweed
Comment 3 Jan T 2015-10-28 14:10:10 UTC
Correct me if I am wrong, but IMHO shutter *was* part of Tumbleweed (see http://software.opensuse.org/package/shutter - official release 0.90).

Why it has been removed?
Comment 4 Ondřej Súkup 2015-11-03 09:49:32 UTC
(In reply to Jan T from comment #3)
> Correct me if I am wrong, but IMHO shutter *was* part of Tumbleweed (see
> http://software.opensuse.org/package/shutter - official release 0.90).
> 
> Why it has been removed?

it was newer part of tumbleweed, In times before Tumbleweed was part of Factory development for openSUSE 13.2. and last official release of Shutter in openSUSE is 13.2.  

+ in openSUSE TW aren't depencies for shutter
Comment 5 Bogdano Arendartchuk 2019-11-15 13:13:42 UTC
Still valid:

> $ zypper info shutter
> Loading repository data...
> Reading installed packages...
> 
> 
> Information for package shutter:
> --------------------------------
> Repository     : Main Repository (OSS)
> [...]

> $ zypper lr -u | grep OSS
>  2 | download.opensuse.org-non-oss    | Main Repository (NON-OSS)                          | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/tumbleweed/repo/non-oss/
>  3 | download.opensuse.org-oss        | Main Repository (OSS)                              | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/tumbleweed/repo/oss/
>
Comment 6 ray herman 2020-01-29 11:26:33 UTC
Tumbleweed # VERSION="20200124"

Information for package shutter:
--------------------------------
Repository     : Main Repository (OSS)     
Name           : shutter                   
Version        : 0.94-1.9                  
Arch           : noarch                    
Vendor         : openSUSE                  
Installed Size : 13.5 MiB  

~> sudo zypper in shutter
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides perl(Gnome2) needed by shutter-0.94-1.9.noarch
 

Leap-15.1 and 15.2 provide perl-Gnome2 and install shutter.
perl-Gnome2 is missing from the Tumbleweed repository.
perl-Gnome2
If there really is no intention to supply perl-Gnome2 then shutter should also be removed from Tumbleweed.
Comment 7 ray herman 2020-01-29 11:56:10 UTC
This version of Shutter is about 18months old, with bugfix updates since.  Hardly in the spirit of Tumblweed.
Comment 8 Nux Ro 2020-02-10 10:35:14 UTC
Is it possible to get the perl(Gnome2) dependency sorted so that shutter actually functions?

This is the no. 1 screenshotting tool on Linux, it's a shame to miss out on it on OpenSuse Tumbleweed.
Comment 9 Jan T 2020-02-10 16:36:38 UTC
@Nux Ro: Since this error is almost 5 years old and still exists I recently switched to Flameshot:

https://software.opensuse.org/package/flameshot
Comment 10 Nux Ro 2020-02-11 10:44:51 UTC
(In reply to Jan T from comment #9)
> @Nux Ro: Since this error is almost 5 years old and still exists I recently
> switched to Flameshot:
> 
> https://software.opensuse.org/package/flameshot

Thanks Jan, looks very promising!
I had researched alternatives before moaning about Shutter, but did not find Flameshot.
Comment 11 Art Zh 2020-03-28 23:58:18 UTC
*** Bug 1167975 has been marked as a duplicate of this bug. ***
Comment 12 Andreas Stieger 2020-05-07 13:33:47 UTC
*** Bug 1171360 has been marked as a duplicate of this bug. ***