Bug 927018 - kernel-desktop-3.16.7-13.2 breaks module compatibility
kernel-desktop-3.16.7-13.2 breaks module compatibility
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Kernel
x86-64 openSUSE 13.2
: P5 - None : Major with 6 votes (vote)
: ---
Assigned To: E-mail List
E-mail List
Depends on:
  Show dependency treegraph
Reported: 2015-04-14 05:45 UTC by Andrei Borzenkov
Modified: 2015-05-21 14:02 UTC (History)
11 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Borzenkov 2015-04-14 05:45:17 UTC
After latest update nvidia driver compiled for earlier version no more loads. It did load for previous one.

[  792.370816] nvidia_uvm: disagrees about version of symbol module_layout
[  811.868133] nvidia: disagrees about version of symbol module_layout

It was OK for 3.16.7-7 (I'm writing this under this version):

bor@opensuse:~> LC_ALL=C ll /lib/modules/3.16.7-7-desktop/weak-updates/updates/
total 0
lrwxrwxrwx 1 root root 51 Apr 12 10:32 nvidia-uvm.ko -> /lib/modules/3.16.6-2-desktop/updates/nvidia-uvm.ko
lrwxrwxrwx 1 root root 47 Apr 12 10:33 nvidia.ko -> /lib/modules/3.16.6-2-desktop/updates/nvidia.ko
bor@opensuse:~> LC_ALL=C ll /lib/modules/3.16.7-13-desktop/
total 3516
lrwxrwxrwx  1 root root     43 Apr 14 07:58 build -> /usr/src/linux-3.16.7-13-obj/x86_64/desktop
drwxr-xr-x 13 root root   4096 Apr 14 07:56 kernel
-rw-r--r--  1 root root 863275 Apr 14 08:12 modules.alias
-rw-r--r--  1 root root 844573 Apr 14 08:12 modules.alias.bin
-rw-r--r--  1 root root   3932 Mar 20 23:29 modules.builtin
-rw-r--r--  1 root root   5424 Apr 14 08:12 modules.builtin.bin
-rw-r--r--  1 root root 320986 Apr 14 08:12 modules.dep
-rw-r--r--  1 root root 469753 Apr 14 08:12 modules.dep.bin
-rw-r--r--  1 root root    379 Apr 14 08:12 modules.devname
-rw-r--r--  1 root root 128186 Mar 20 23:29 modules.order
-rw-r--r--  1 root root    115 Apr 14 08:12 modules.softdep
-rw-r--r--  1 root root 411128 Apr 14 08:12 modules.symbols
-rw-r--r--  1 root root 514901 Apr 14 08:12 modules.symbols.bin
lrwxrwxrwx  1 root root     24 Apr 14 07:58 source -> /usr/src/linux-3.16.7-13
drwxr-xr-x  2 root root   4096 Apr 14 08:35 updates
drwxr-xr-x  2 root root   4096 Apr 14 07:56 vdso
Comment 1 Bob Williams 2015-04-14 06:35:05 UTC
I got the same result here following this security patch, and have had to revert to 3.16.7-7.
Running openSUSE 13.2 x86_64 with proprietary nVidia graphics drivers. The boot sequence runs OK until the moment when the login screen should appear, then drops back to a text console. No graphical login available.
Comment 2 Takashi Iwai 2015-04-14 09:11:52 UTC
This is likely the kABI breakage by the d_rcu union member reshuffling for CVE-2014-8559 fix.  SLE12 has a kABI fix patch and we need a similar fix for openSUSE 13.2, too.
Comment 3 Takashi Iwai 2015-04-14 09:15:15 UTC
Now I pushed a fix patch to 13.2 git branch, a modified patch from Miklos' original version for SLE12.

IMO, we should release the new update kernel again together with the fix for bug 925479.
Comment 5 Alexander König 2015-04-14 11:09:12 UTC
I had the same problem yesterday (13th April) after kernel update.

I could resolve it by refreshing all installed NVIDIA graphics drivers via YaST.
Comment 7 Marcus Meissner 2015-04-14 15:26:45 UTC
I removed the old kernel update from the update server until we release the new kernel.
Comment 8 Kilian Lackhove 2015-04-17 10:42:31 UTC
Marcus, do you think you could upload the old kernel with a newer revision so systems that already installed the erroneous 3.16.7-13.2 kernel can install a working kernel automatically?

Currently most of my systems have broken nvidia drivers until i downgrade their kernels manually, which is not feasible.
Comment 9 Marcus Meissner 2015-04-17 11:55:18 UTC
it is currently tested in this test repo:

Comment 10 Marcus Meissner 2015-04-17 11:55:40 UTC
(thats the newer fixed one)
Comment 11 Patric Schramm 2015-04-23 09:25:18 UTC
Todays update to 3.16.7-21-desktop on 13.2 still breaks nvidia driver. Had to

"zypper in -f nvidia-gfxG03-kmp-desktop" to get the driver into the newer kernel.
Comment 12 Marcus Meissner 2015-04-23 09:36:10 UTC
if you had the intermediate retracted kernel installed and your nvidia module updated for that, than that is expected.

if you had the previous good and the current update kernel breaks it, this would be unexpected.
Comment 13 Bob Williams 2015-04-23 11:01:41 UTC
I have just run the update starting from 3.16.7-7 and cannot get the nvidia graphics drivers to load. I have tried reinstalling the drivers and the nvidia-gfxG03-kmp-desktop, but nvidia graphics config only sees one monitor at a time. I previously had a side-by-side twinview setup.
I have uninstalled the new 3.16.7-21 kernel, reverting to the 3.16.7-7-desktop, but the graphic display is now as I describe above.
Comment 14 Alexander König 2015-04-25 13:13:10 UTC
Update to 3.16.7-21-desktop on 13.2 required refreshment of NVIDIA driver - I had the intermediate retracted kernel installed and my nvidia module refreshed for that
Comment 15 Alexander König 2015-04-25 14:42:58 UTC
On my daughter's computer, who had not 3.16.7-13-desktop installed in between, the installation of 3.16.7-21-desktop did not require a refreshment of the NVIDIA drivers.
Comment 16 Takashi Iwai 2015-05-21 13:16:15 UTC
The fixed kernel has been released, so let's close.

The refresh build would be needed only when you did refresh once with the bad kernel, i.e. to re-correct the badly build module again.