Bug 918638 - VirtualBox freezes with virtual hard disk on fuse filesystems (ntfs-3g e.g.) during file io
VirtualBox freezes with virtual hard disk on fuse filesystems (ntfs-3g e.g.) ...
Status: RESOLVED DUPLICATE of bug 918954
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Kernel
x86-64 openSUSE 13.2
: P5 - None : Major (vote)
: ---
Assigned To: E-mail List
E-mail List
Depends on:
  Show dependency treegraph
Reported: 2015-02-19 13:56 UTC by Wolfgang Bauer
Modified: 2015-03-04 11:43 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---

dmesg log entry of the crash (3.49 KB, text/plain)
2015-02-19 13:56 UTC, Wolfgang Bauer

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Bauer 2015-02-19 13:56:28 UTC
Created attachment 623868 [details]
dmesg log entry of the crash

I tried to install openSUSE 13.1 in VirtualBox on a 13.2 host (with the virtual harddisk located on an ntfs-3g partition), and VirtualBox just froze during installation. It hang, I couldn't quit VirtualBox, and I couldn't even access the ntfs partition any more (had to reboot).

I tried a few times, and this happened every time: most of the time it froze when installing some package (sometimes I even got a YaST error dialog before the freeze), a few times it hang during partitioning already.

Attached is the kernel log entry printed by dmesg.

Searching the Internet led me to this upstream kernel bug report:

This states that it is fixed in 3.17, and indeed after upgrading the kernel to the current 3.19.0 from Kernel:stable I didn't have a problem any more.

The upstream bug report mentions two commits that should fix this:

Would it be possible to backport those to 13.2's 3.16.7 kernel?
Comment 1 Wolfgang Bauer 2015-02-19 14:28:07 UTC
PS: this is the corresponding mailinglist thread on stable@vger.kernel.org:
Comment 2 Wolfgang Bauer 2015-03-04 11:43:54 UTC
Bug#918954 was about backporting exactly the same commits, and this has been done yesterday.

So I'm closing this one as duplicate.

Thank you!

*** This bug has been marked as a duplicate of bug 918954 ***