Bug 908194 - Apper displays 'unknown role' and 'unknown state' when performing tasks
Apper displays 'unknown role' and 'unknown state' when performing tasks
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: KDE Applications
13.2
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-03 14:47 UTC by Joschi Brauchle
Modified: 2015-04-07 12:13 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Apper Plasma Widget (74.35 KB, image/png)
2014-12-03 14:47 UTC, Joschi Brauchle
Details
Apper Software Management KCM Module (25.31 KB, image/png)
2014-12-03 14:48 UTC, Joschi Brauchle
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joschi Brauchle 2014-12-03 14:47:57 UTC
Created attachment 615765 [details]
Apper Plasma Widget

The Apper plasma updater widget displays the strings
'unknown state'
and
'unknown role type'
prominently while refreshing repositories in search for updates. See attached screenshot.

Also the Apper Software Center sometimes displays '0% unknown state' in its titlebar while doing nothing. See second screenshot.

This is KDE 4.14.3.
Comment 1 Joschi Brauchle 2014-12-03 14:48:42 UTC
Created attachment 615766 [details]
Apper Software Management KCM Module
Comment 2 John Andrew McInnes 2014-12-18 20:57:20 UTC
Same here. I'm also seeing this on Fedora 21.
Comment 3 John Andrew McInnes 2015-02-25 01:26:44 UTC
When your root privileged software installer is telling you *I am in an Unknown State with an Unknown Role*, you should be concerned. If only Me and the OP are experiencing this than maybe our machines have been compromised.

I am uping the severity of this bug. Sorry to get dramatic about it, but there has been no comment or acknoweledgement of this bug, since December 3. I'm assuming the worst.
Comment 4 Wolfgang Bauer 2015-02-25 11:16:22 UTC
(In reply to John Andrew McInnes from comment #3)
> I am uping the severity of this bug. Sorry to get dramatic about it, but
> there has been no comment or acknoweledgement of this bug, since December 3.
> I'm assuming the worst.

Sorry, but I don't see how this is "Major".
The update applet doesn't know which text to display because of changes in PackageKit-Qt. But that's only cosmetical.

Also, please don't touch the "Priority" field, unless you want to assign the bug to yourself. This field is for the developers/maintainers only, to prioritize the bugs they are working on.

I'm confirming the bug now though, I hope that makes you feel better... ;)

> When your root privileged software installer is telling you *I am in an
> Unknown State with an Unknown Role*, you should be concerned. If only Me and
> the OP are experiencing this than maybe our machines have been compromised.

Apper or the update applet are not "root privileged" at all.
If that status messages disturb you, disable the "Software Updater" applet in the system tray settings, and only use Apper (the application, which shows the correct status messages btw) or YaST/zypper to update your system.

You might also want to file a bug report at bugs.kde.org. This is in no way an openSUSE-specific issue.
Comment 5 John Andrew McInnes 2015-02-27 20:44:27 UTC
Ok good to know. Sorry I was thinking of Fedora (21 which has the same bug, it doesn't prompt you for a root password). 

I have reported the bug at https://bugs.kde.org/show_bug.cgi?id=344639
Comment 6 Michele Cherici 2015-03-18 09:25:55 UTC
(In reply to Wolfgang Bauer from comment #4)
> Sorry, but I don't see how this is "Major".
> The update applet doesn't know which text to display because of changes in
> PackageKit-Qt. But that's only cosmetical.

This is not a "cosmetical" bug, it's a big usability problem, when there is a Flash plugin update you have to accept the eula and then apper show the 'unknown state' message forever and you don't known what's happening.

I think it's related to bug 908730 and 899755
Comment 7 Wolfgang Bauer 2015-03-18 11:55:37 UTC
(In reply to Michele Cherici from comment #6)
> This is not a "cosmetical" bug, it's a big usability problem,

Big usability problem?
It's just an incorrect/missing status message.

> when there is
> a Flash plugin update you have to accept the eula and then apper show the
> 'unknown state' message forever and you don't known what's happening.

That seems to be a bug in PackageKit, it seems to hang after accepting the EULA.
I can reproduce it with "pkcon update".
If you interact with PackageKit in any way, it will continue.

> I think it's related to bug 908730 and 899755
No, it isn't.

Well, PackageKit hanging after the EULA acceptance is of course bug#908730, but that's totally unrelated to this one.

Anyway, fixed packages (regarding _this_ bug) are available here:
http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Extra/openSUSE_13.2/
Comment 8 Michele Cherici 2015-03-18 13:24:24 UTC
(In reply to Wolfgang Bauer from comment #7)
> (In reply to Michele Cherici from comment #6)
> > This is not a "cosmetical" bug, it's a big usability problem,
> 
> Big usability problem?
> It's just an incorrect/missing status message.
 
The "gig usability problem" was referred to the update problem with Flash EULA. 

> > when there is
> > a Flash plugin update you have to accept the eula and then apper show the
> > 'unknown state' message forever and you don't known what's happening.
> 
> That seems to be a bug in PackageKit, it seems to hang after accepting the
> EULA.
> I can reproduce it with "pkcon update".
> If you interact with PackageKit in any way, it will continue.
> 
> > I think it's related to bug 908730 and 899755
> No, it isn't.
> 
> Well, PackageKit hanging after the EULA acceptance is of course bug#908730,
> but that's totally unrelated to this one.

I supposed the bugs were related because I got the same 'unknown state' message.
Comment 9 Joschi Brauchle 2015-03-18 13:56:45 UTC
(In reply to Wolfgang Bauer from comment #7)
> Anyway, fixed packages (regarding _this_ bug) are available here:
> http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/
> Extra/openSUSE_13.2/

Hi Wolfgang, its good to hear someone is working on the fix. 

I agree that it is highly confusion the using to see those unknown state messages. A non-technical person might suspect something is wrong with the machine and it may possibly not get (security) updates.

So hopefully we will see your fixes in openSUSE 13.2 soon? 
Thanks!
Comment 10 Wolfgang Bauer 2015-03-18 14:17:54 UTC
(In reply to Michele Cherici from comment #8)
> (In reply to Wolfgang Bauer from comment #7)
> > (In reply to Michele Cherici from comment #6)
> > > This is not a "cosmetical" bug, it's a big usability problem,
> > 
> > Big usability problem?
> > It's just an incorrect/missing status message.
>  
> The "gig usability problem" was referred to the update problem with Flash
> EULA. 

But that is a completely different bug, and as mentioned it is in PackageKit itself AFAICT.

> I supposed the bugs were related because I got the same 'unknown state'
> message.

No. The update plasmoid just displays the text "Unknown State" whatever the state is.
But again, this is just a wrong text string. In detail: the translation of the state number into the text message is wrong/not working because of a limitation in Qt4 when calling C++ functions from a QML plasmoid using an Enum as parameter. PackageKit and Apper are perfectly aware of the current state though.

(In reply to Joschi Brauchle from comment #9)
> So hopefully we will see your fixes in openSUSE 13.2 soon? 

I think I'm going to submit it to KDE:Extra in the next days, yes. An offical update for 13.2 will take a bit longer though, as the maintenance process takes about a week from submission of the update to the release (for testing).

Btw, my apper packages also contain other fixes, for bug#901067 e.g.
Comment 11 Wolfgang Bauer 2015-03-28 21:29:09 UTC
The fixes have been accepted upstream meanwhile, they are in KDE:Extra, and an update to 13.2 is on the way.
Comment 12 Swamp Workflow Management 2015-04-07 09:05:14 UTC
openSUSE-RU-2015:0664-1: An update that has two recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 901067,908194
CVE References: 
Sources used:
openSUSE 13.2 (src):    apper-0.9.1-4.1
Comment 13 Wolfgang Bauer 2015-04-07 12:13:08 UTC
The updater plasmoid now should correctly show the current role/status.

The update is in Tumbleweed and has been released for 13.2, so let's close this.