Bug 906488 - (CVE-2014-8961) VUL-0: CVE-2014-8961: phpMyAdmin: Leakage of line count of an arbitrary file
(CVE-2014-8961)
VUL-0: CVE-2014-8961: phpMyAdmin: Leakage of line count of an arbitrary file
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
13.2
All openSUSE 13.2
: P4 - Low : Normal (vote)
: ---
Assigned To: Security Team bot
E-mail List
http://www.phpmyadmin.net/home_page/s...
:
Depends on:
Blocks: CVE-2014-9218 CVE-2014-9219
  Show dependency treegraph
 
Reported: 2014-11-20 21:23 UTC by Andreas Stieger
Modified: 2014-12-05 09:06 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Stieger 2014-11-20 21:23:46 UTC
http://www.phpmyadmin.net/home_page/security/PMASA-2014-16.php

Announcement-ID: PMASA-2014-16
Date: 2014-11-20
Summary: Leakage of line count of an arbitrary file.
Description: 
In the error reporting feature, a parameter specifying the file was not correctly validated, allowing the attacker to derive the line count of an arbitrary file.
Severity

We consider this vulnerability to be non critical.

Mitigation factor

This vulnerability can be triggered only by someone who is logged in to phpMyAdmin, as the usual token protection prevents non-logged-in users from accessing the required page.
Affected Versions

Versions 4.1.x (prior to 4.1.14.7) and 4.2.x (prior to 4.2.12) are affected.
Solution

Upgrade to phpMyAdmin 4.1.14.7 or newer, or 4.2.12 or newer, or apply the patch listed below.
References

Thanks to Johannes Dahse (https://twitter.com/FluxReiners) for reporting this vulnerability.

Assigned CVE ids: CVE-2014-8961

CWE ids: CWE-661 CWE-23
Patches

The following commits have been made to fix this issue:

    b99b6b6672ff2419f05b05740c80c7a23c1da994

The following commits have been made on the 4.1 branch to fix this issue:

    da44dd4fd7432b915203e3e723a4534a01c12cd9
Comment 1 Bernhard Wiedemann 2014-11-20 22:00:31 UTC
This is an autogenerated message for OBS integration:
This bug (906488) was mentioned in
https://build.opensuse.org/request/show/262534 Factory / phpMyAdmin
Comment 2 Andreas Stieger 2014-11-20 22:46:08 UTC
Please review maintenance request:
https://build.opensuse.org/request/show/262545
Comment 3 Bernhard Wiedemann 2014-11-20 23:00:55 UTC
This is an autogenerated message for OBS integration:
This bug (906488) was mentioned in
https://build.opensuse.org/request/show/262544 Factory / phpMyAdmin
Comment 4 Marcus Meissner 2014-12-05 08:39:08 UTC
re;eased
Comment 5 Swamp Workflow Management 2014-12-05 09:06:23 UTC
openSUSE-SU-2014:1561-1: An update that fixes four vulnerabilities is now available.

Category: security (moderate)
Bug References: 906485,906486,906487,906488
CVE References: CVE-2014-8958,CVE-2014-8959,CVE-2014-8960,CVE-2014-8961
Sources used:
openSUSE 13.2 (src):    phpMyAdmin-4.2.12-4.1
openSUSE 13.1 (src):    phpMyAdmin-4.1.14.7-24.1
openSUSE 12.3 (src):    phpMyAdmin-4.1.14.7-1.32.1