Bug 906485 - (CVE-2014-8958) VUL-0: CVE-2014-8958: phpMyAdmin: Multiple XSS vulnerabilities..
(CVE-2014-8958)
VUL-0: CVE-2014-8958: phpMyAdmin: Multiple XSS vulnerabilities..
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
13.2
All openSUSE 13.2
: P4 - Low : Normal (vote)
: ---
Assigned To: Security Team bot
E-mail List
http://www.phpmyadmin.net/home_page/s...
:
Depends on:
Blocks: CVE-2014-9218 CVE-2014-9219
  Show dependency treegraph
 
Reported: 2014-11-20 21:23 UTC by Andreas Stieger
Modified: 2014-12-05 09:05 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Stieger 2014-11-20 21:23:30 UTC
http://www.phpmyadmin.net/home_page/security/PMASA-2014-13.php

Announcement-ID: PMASA-2014-13

Date: 2014-11-20
Summary: Multiple XSS vulnerabilities.
Description

    With a crafted database, table or column name it is possible to trigger an XSS attack in the table browse page.
    With a crafted ENUM value it is possible to trigger XSS attacks in the table print view and zoom search pages.
    With a crafted value for font size it is possible to trigger an XSS attack in the home page.

Severity

We consider this vulnerabilities to be non critical.
Mitigation factor

These vulnerabilities can be triggered only by someone who is logged in to phpMyAdmin, as the usual token protection prevents non-logged-in users from accessing the required pages. Moreover, exploitation of the XSS vulnerability related to the font size requires forgery of the pma_fontsize cookie.
Affected Versions

Versions 4.0.x (prior to 4.0.10.6), 4.1.x (prior to 4.1.14.7) and 4.2.x (prior to 4.2.12) are affected.
Solution

Upgrade to phpMyAdmin 4.0.10.6 or newer, or 4.1.14.7 or newer, or 4.2.12 or newer, or apply the patch listed below.
References

Thanks to Johannes Dahse (https://twitter.com/FluxReiners) for reporting XSS vulnerabilities in table browse and home pages.

Assigned CVE ids: CVE-2014-8958

CWE ids: CWE-661 CWE-79
Patches

The following commits have been made to fix this issue:

    d32da348c4de2379482a48661ce968a55eebe5c4
    1bc04ec95038f2356ad33752090001bf1c047208
    2a3b7393d1d5a8ba0543699df94a08a0f5728fe0
    2ffdbf2d7daa0b92541d8b754e2afac555d3ed21

The following commits have been made on the 4.1 branch to fix this issue:

    47a6ece0427a23c47f2b1a88dfb0f46ca344aaec
    816fa880060f37932be291d2918fd5c6ac474ab5
    60c619fa1679a7c4fe09657da293e84dde02eede
    cea7c5fba8224b8380f2a83a689eb6caa6c79662

The following commits have been made on the 4.0 branch to fix this issue:

    c5783321cd387d0b65b32cf399766f08a9acad68
    42b64e12b5f596366f94ef72365fd69a019ba820
    58cdd91fc83703a1ab645764fb3708e8e0b7c4a2
    c7685e5acd3f8e722f4f374c6fa821590865b68d
Comment 1 Bernhard Wiedemann 2014-11-20 22:00:21 UTC
This is an autogenerated message for OBS integration:
This bug (906485) was mentioned in
https://build.opensuse.org/request/show/262534 Factory / phpMyAdmin
Comment 2 Andreas Stieger 2014-11-20 22:45:59 UTC
Please review maintenance request:
https://build.opensuse.org/request/show/262545
Comment 3 Bernhard Wiedemann 2014-11-20 23:00:44 UTC
This is an autogenerated message for OBS integration:
This bug (906485) was mentioned in
https://build.opensuse.org/request/show/262544 Factory / phpMyAdmin
Comment 4 Marcus Meissner 2014-12-05 08:38:47 UTC
reoeased
Comment 5 Swamp Workflow Management 2014-12-05 09:05:55 UTC
openSUSE-SU-2014:1561-1: An update that fixes four vulnerabilities is now available.

Category: security (moderate)
Bug References: 906485,906486,906487,906488
CVE References: CVE-2014-8958,CVE-2014-8959,CVE-2014-8960,CVE-2014-8961
Sources used:
openSUSE 13.2 (src):    phpMyAdmin-4.2.12-4.1
openSUSE 13.1 (src):    phpMyAdmin-4.1.14.7-24.1
openSUSE 12.3 (src):    phpMyAdmin-4.1.14.7-1.32.1