Bug 904210 - package link not shown in web UI
package link not shown in web UI
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE.org
Classification: openSUSE
Component: BuildService
unspecified
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Adrian Schröter
Adrian Schröter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-06 13:06 UTC by Nico Kruber
Modified: 2020-06-24 07:47 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nico Kruber 2014-11-06 13:06:41 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0
Build Identifier: 

if repo B is based on repo A which contains package C, then linking to B:C (without C being directly available in B) produces no UI elements to show (un)expanded sources in the web UI, neither is the link shown as such ("links to ...")

example:
https://build.opensuse.org/package/show/KDE:Extra/PackageKit
https://build.opensuse.org/package/show/KDE:Extra/PackageKit?expand=0
https://build.opensuse.org/package/show/KDE:Extra/PackageKit?expand=1

Reproducible: Always

Steps to Reproduce:
1. create link to a package in openSUSE:13.2:Update which is only available in openSUSE:13.2
2. browse to that link
Actual Results:  
the link exists but is not shown as such

Expected Results:  
same UI as if the package was linked to openSUSE:13.2 directly
Comment 1 Bernhard Wiedemann 2014-11-08 12:55:21 UTC
Probably a similar issue that I once noticed with links to a remote OBS.

https://github.com/openSUSE/open-build-service/issues/673 looks like this

and somewhat related:
https://github.com/openSUSE/open-build-service/issues/786
Comment 2 Adrian Schröter 2020-06-24 07:47:48 UTC
it is claimed to be fixed.