Bug 899819 - YaST (Qt4) loads gnome icons instead of oxygen
YaST (Qt4) loads gnome icons instead of oxygen
Status: RESOLVED WORKSFORME
: 899250 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
201409*
i586 openSUSE 13.2
: P5 - None : Minor with 5 votes (vote)
: ---
Assigned To: Martin Vidner
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-06 05:57 UTC by Quentin Denis
Modified: 2019-02-15 11:12 UTC (History)
6 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Quentin Denis 2014-10-06 05:57:50 UTC
Since a couple of weeks (on factory), YaST in Qt4 loads gnome icons instead of the default KDE ones (oxygen).

Here is the list of yast packages on my system: http://paste.opensuse.org/81871809
Comment 2 Gabriele Mohr 2014-10-08 08:17:20 UTC
*** Bug 899250 has been marked as a duplicate of this bug. ***
Comment 3 Javier Llorente 2014-10-29 15:58:03 UTC
The yast2-theme package makes a syslink to the hicolor directory instead of oxygen by default:

# let's take hicolor icons for yast
ln -s /usr/share/icons/hicolor $RPM_BUILD_ROOT%{yast_themedir}/current/icons


Furthermore, the yast2-theme version shipped on 13.2 RC1 doesn't have %posts as the version shipped on 13.1:

%post openSUSE-Oxygen
cd /usr/share/YaST2/theme
ln -snf openSUSE-Oxygen openSUSE-current
Comment 4 Javier Llorente 2014-10-29 16:12:17 UTC
So why don't we offer several packages like before (ie: yast2-theme-openSUSE-Oxygen)?
Comment 5 Stephan Kulow 2015-02-22 21:12:17 UTC
because it was unmaintainable
Comment 6 Mindaugas Baranauskas 2019-02-15 11:12:18 UTC
There is no more old GNOME icons. Breeze icons are instead.
Icon style is no longer hardcoded – it follows your desktop.
Thus Oxygen icons will be used if your (adminstrators) default desktop theme is Oxygen.
Comment 7 Mindaugas Baranauskas 2019-02-15 11:12:39 UTC
closing bug