Bug 885961 - (CVE-2014-4721) VUL-0: CVE-2014-4721: php5,php53: type confusion issue in phpinfo() leading to information leak
(CVE-2014-4721)
VUL-0: CVE-2014-4721: php5,php53: type confusion issue in phpinfo() leading t...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/103343/
maint:released:sle10-sp3:58372 maint:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-07 07:16 UTC by Victor Pereira
Modified: 2019-06-17 22:41 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Pereira 2014-07-07 07:16:14 UTC
CVE-2014-4721

The phpinfo implementation in ext/standard/info.c in PHP before 5.4.30 and 5.5.x
before 5.5.14 does not ensure use of the string data type for the PHP_AUTH_PW,
PHP_AUTH_TYPE, PHP_AUTH_USER, and PHP_SELF variables, which might allow
context-dependent attackers to obtain sensitive information from process memory
by using the integer data type with crafted values, related to a "type
confusion" vulnerability, as demonstrated by reading a private SSL key in an
Apache HTTP Server web-hosting environment with mod_ssl and a PHP 5.3.x mod_php.

References:
https://www.sektioneins.de/en/blog/14-07-04-phpinfo-infoleak.html
https://bugzilla.redhat.com/show_bug.cgi?id=1116662
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-4721
http://twitter.com/mikispag/statuses/485713462258302976
https://bugs.php.net/bug.php?id=67498
Comment 2 Swamp Workflow Management 2014-07-07 22:00:35 UTC
bugbot adjusting priority
Comment 3 Petr Gajdos 2014-07-17 12:47:42 UTC
None of php versions we maintain is checking for type of PHP_SELF, PHP_AUTH_TYPE, PHP_AUTH_USER and PHP_AUTH_PW.
Comment 6 Petr Gajdos 2014-07-18 07:59:43 UTC
php 5.5.14 not affected.
Comment 7 Petr Gajdos 2014-07-18 08:00:39 UTC
Packages submitted.
Comment 9 SMASH SMASH 2014-07-21 13:10:28 UTC
Affected packages:

SLE-11-SP3: php5, php53
Comment 10 Swamp Workflow Management 2014-07-30 10:06:10 UTC
SUSE-SU-2014:0938-1: An update that fixes 9 vulnerabilities is now available.

Category: security (moderate)
Bug References: 884986,884987,884989,884990,884991,884992,885961,886059,886060
CVE References: CVE-2014-0207,CVE-2014-3478,CVE-2014-3479,CVE-2014-3480,CVE-2014-3487,CVE-2014-3515,CVE-2014-4670,CVE-2014-4698,CVE-2014-4721
Sources used:
SUSE Linux Enterprise Software Development Kit 11 SP3 (src):    php53-5.3.17-0.27.1
SUSE Linux Enterprise Server 11 SP3 for VMware (src):    php53-5.3.17-0.27.1
SUSE Linux Enterprise Server 11 SP3 (src):    php53-5.3.17-0.27.1
Comment 11 Victor Pereira 2014-07-30 12:13:16 UTC
fixed and released
Comment 12 Swamp Workflow Management 2014-07-30 18:45:46 UTC
openSUSE-SU-2014:0945-1: An update that fixes three vulnerabilities is now available.

Category: security (moderate)
Bug References: 885961,886059,886060
CVE References: CVE-2014-4670,CVE-2014-4698,CVE-2014-4721
Sources used:
openSUSE 13.1 (src):    php5-5.4.20-21.1
openSUSE 12.3 (src):    php5-5.3.17-3.25.1
Comment 13 Bernhard Wiedemann 2014-09-17 18:01:27 UTC
This is an autogenerated message for OBS integration:
This bug (885961) was mentioned in
https://build.opensuse.org/request/show/249993 Evergreen:11.4 / php5.openSUSE_Evergreen_11.4
Comment 14 Swamp Workflow Management 2014-09-28 10:08:52 UTC
openSUSE-SU-2014:1236-1: An update that fixes 9 vulnerabilities is now available.

Category: security (moderate)
Bug References: 884986,884987,884989,884990,884991,884992,885961,886059,886060
CVE References: CVE-2014-0207,CVE-2014-3478,CVE-2014-3479,CVE-2014-3480,CVE-2014-3487,CVE-2014-3515,CVE-2014-4670,CVE-2014-4698,CVE-2014-4721
Sources used:
openSUSE Evergreen 11.4 (src):    php5-5.3.17-379.1
Comment 15 Swamp Workflow Management 2016-06-21 11:09:53 UTC
SUSE-SU-2016:1638-1: An update that fixes 85 vulnerabilities is now available.

Category: security (important)
Bug References: 884986,884987,884989,884990,884991,884992,885961,886059,886060,893849,893853,902357,902360,902368,910659,914690,917150,918768,919080,921950,922451,922452,923945,924972,925109,928506,928511,931421,931769,931772,931776,933227,935074,935224,935226,935227,935229,935232,935234,935274,935275,938719,938721,942291,942296,945412,945428,949961,968284,969821,971611,971612,971912,973351,973792,976996,976997,977003,977005,977991,977994,978827,978828,978829,978830,980366,980373,980375,981050,982010,982011,982012,982013,982162
CVE References: CVE-2004-1019,CVE-2006-7243,CVE-2014-0207,CVE-2014-3478,CVE-2014-3479,CVE-2014-3480,CVE-2014-3487,CVE-2014-3515,CVE-2014-3597,CVE-2014-3668,CVE-2014-3669,CVE-2014-3670,CVE-2014-4049,CVE-2014-4670,CVE-2014-4698,CVE-2014-4721,CVE-2014-5459,CVE-2014-8142,CVE-2014-9652,CVE-2014-9705,CVE-2014-9709,CVE-2014-9767,CVE-2015-0231,CVE-2015-0232,CVE-2015-0273,CVE-2015-1352,CVE-2015-2301,CVE-2015-2305,CVE-2015-2783,CVE-2015-2787,CVE-2015-3152,CVE-2015-3329,CVE-2015-3411,CVE-2015-3412,CVE-2015-4021,CVE-2015-4022,CVE-2015-4024,CVE-2015-4026,CVE-2015-4116,CVE-2015-4148,CVE-2015-4598,CVE-2015-4599,CVE-2015-4600,CVE-2015-4601,CVE-2015-4602,CVE-2015-4603,CVE-2015-4643,CVE-2015-4644,CVE-2015-5161,CVE-2015-5589,CVE-2015-5590,CVE-2015-6831,CVE-2015-6833,CVE-2015-6836,CVE-2015-6837,CVE-2015-6838,CVE-2015-7803,CVE-2015-8835,CVE-2015-8838,CVE-2015-8866,CVE-2015-8867,CVE-2015-8873,CVE-2015-8874,CVE-2015-8879,CVE-2016-2554,CVE-2016-3141,CVE-2016-3142,CVE-2016-3185,CVE-2016-4070,CVE-2016-4073,CVE-2016-4342,CVE-2016-4346,CVE-2016-4537,CVE-2016-4538,CVE-2016-4539,CVE-2016-4540,CVE-2016-4541,CVE-2016-4542,CVE-2016-4543,CVE-2016-4544,CVE-2016-5093,CVE-2016-5094,CVE-2016-5095,CVE-2016-5096,CVE-2016-5114
Sources used:
SUSE Linux Enterprise Server 11-SP2-LTSS (src):    php53-5.3.17-47.1