Bug 864121 - Pipelines in rygel.conf don't work with gstreamer-1.0
Pipelines in rygel.conf don't work with gstreamer-1.0
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE 13.1
Classification: openSUSE
Component: GNOME
Final
Other openSUSE 13.1
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
https://bugzilla.gnome.org/show_bug.c...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-14 20:50 UTC by Bjørn Lie
Modified: 2014-02-24 11:04 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bjørn Lie 2014-02-14 20:50:21 UTC
The GstLaunch pipelines given in rygel.conf do not work with gstreamer-1.0
because it uses ffenc* instead of avenc*.

Add patch to fix this problem and ask maintenance for update.

See also https://bugzilla.gnome.org/show_bug.cgi?id=724215
Comment 1 Bjørn Lie 2014-02-14 20:57:16 UTC
At the same time, lets update it to stable version 0.20.3

- Update to version 0.20.3:
  + Allow building against Tracker 0.18.
  + Server:
    - Add more work-arounds for Samsung TVs.
    - Add more hacks for devices doing full seek requests.
  + Bugs fixed: bgo#715089.
  + Updated translations.
Comment 2 Bjørn Lie 2014-02-14 21:05:01 UTC
https://build.opensuse.org/request/show/222400

Note that the patch is "valid" also without the version bump.
Comment 3 Benjamin Brunner 2014-02-24 10:19:09 UTC
Update released for openSUSE 13.1. Resolved fixed.
Comment 4 Swamp Workflow Management 2014-02-24 11:04:21 UTC
openSUSE-RU-2014:0279-1: An update that has one recommended fix can now be installed.

Category: recommended (low)
Bug References: 864121
CVE References: 
Sources used:
openSUSE 13.1 (src):    rygel-0.20.3-12.1