Bug 860479 - xfce4-settings-manager Preferred Applications doesn't work with custom applications
xfce4-settings-manager Preferred Applications doesn't work with custom applic...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE 13.1
Classification: openSUSE
Component: Xfce
Final
Other Other
: P5 - None : Minor (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-25 13:44 UTC by Adam Spiers
Modified: 2019-10-10 19:12 UTC (History)
0 users

See Also:
Found By: Development
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Spiers 2014-01-25 13:44:12 UTC
For example if I go to the Utilities tab, select Other under File Manager, and type dolphin, the selected application doesn't change.  This worked fine on 12.3.
Comment 1 Guido Berhoerster 2014-01-25 15:05:47 UTC
Looks like $XDG_CONFIG_HOME/xfce4/helpers.rc is not updated for custom preference files which is likely a consequence of the use-versioned-helpers-db.patch patch and thus my fault. I'll look into it later.
Comment 2 Guido Berhoerster 2014-01-25 15:40:55 UTC
This turned out as a simple typo, custom preference files are saved in $XDG_DATA_HOME/xfce4/helpers/exo-1/ instead of $XDG_DATA_HOME/xfce4/exo-1/helpers/.
Comment 3 Bernhard Wiedemann 2014-01-25 16:00:09 UTC
This is an autogenerated message for OBS integration:
This bug (860479) was mentioned in
https://build.opensuse.org/request/show/215130 Factory / exo
Comment 4 Bernhard Wiedemann 2014-01-30 12:00:13 UTC
This is an autogenerated message for OBS integration:
This bug (860479) was mentioned in
https://build.opensuse.org/request/show/215624 13.1 / exo
Comment 5 Benjamin Brunner 2014-02-07 09:44:44 UTC
Update released for openSUSE 13.1. Resolved fixed.
Comment 6 Swamp Workflow Management 2014-02-07 10:04:26 UTC
openSUSE-RU-2014:0208-1: An update that has one recommended fix can now be installed.

Category: recommended (low)
Bug References: 860479
CVE References: 
Sources used:
openSUSE 13.1 (src):    exo-0.10.2-5.4.1
Comment 7 Swamp Workflow Management 2019-08-05 10:11:49 UTC
This is an autogenerated message for OBS integration:
This bug (860479) was mentioned in
https://build.opensuse.org/request/show/720992 Backports:SLE-12-SP2 / exo+libgarcon+libxfce4ui+libxfce4util+perl-ExtUtils-Depends+perl-ExtUtils-PkgConfig+perl-Glib+thunar+xfce4-dev-tools+xfce4-panel+xfconf
Comment 8 Swamp Workflow Management 2019-10-10 19:12:19 UTC
openSUSE-RU-2019:2305-1: An update that solves one vulnerability and has 10 fixes is now available.

Category: recommended (moderate)
Bug References: 1011518,1047218,1135362,637694,687874,760492,764310,767145,829113,860479,952324
CVE References: CVE-2011-1588
Sources used:
SUSE Package Hub for SUSE Linux Enterprise 12 (src):    exo-0.12.0-2.1, libgarcon-0.6.1-2.1, libxfce4ui-4.12.1-2.1, libxfce4util-4.12.1-2.1, perl-ExtUtils-Depends-0.405-2.1, perl-ExtUtils-PkgConfig-1.160000-2.1, perl-Glib-1.326-2.1, thunar-1.6.14-2.1, xfce4-dev-tools-4.12.0-2.1, xfce4-panel-4.12.2-2.1, xfconf-4.12.1-2.1