Bug 858675 - firefox, kwallet use
firefox, kwallet use
Status: REOPENED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Firefox
Leap 15.1
x86-64 All
: P5 - None : Enhancement (vote)
: ---
Assigned To: Mozilla Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-14 11:45 UTC by Episteme PROMENEUR
Modified: 2020-07-29 07:24 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Episteme PROMENEUR 2014-01-14 11:45:50 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0

there is a useful firefox addon "KDE wallet password integration"

https://addons.mozilla.org/en-US/firefox/addon/kde-wallet-password-integratio/

but
now it's dev "Guillermo Molina" uses no more FF and seems to abandon the addon development
he says "I don't use firefox any more, but I will try to make the plugin work again"

see here
http://kde-apps.org/content/show.php?content=116886&forumpage=4

it would be a good thing opensuse continue to develop this addon
or 
as chromium integrates kwallet technology

thanks

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Episteme PROMENEUR 2018-02-06 14:06:15 UTC
it's confirmed now that dev of kwallet FF add-on no more develops this add-on. since a year. no more version.

no hope to get a web extension version.

there is no more  any source of this add-on. all links to the source are obsolete. there is nothing now at dev web site about this add-on.

happily someone save the source here. 

it's the source + a fix according the add-on is compliant with qt < 5.7 because the original source is compliant with qt >= 5.7

it is not signed.

still a few months with FF esr we can use this add-on but after with new esr it's finished.
Comment 2 Episteme PROMENEUR 2018-03-03 11:19:12 UTC
>> happily someone save the source here.

https://github.com/SicVolo/firefox-kde5-wallet

the original source get 1.3 version number
this fork gets 1.3.1
Comment 3 Tomáš Chvátal 2019-07-11 11:02:26 UTC
This is automated batch bugzilla cleanup.

The openSUSE 42.3 changed to end-of-life (EOL [1]) status. As such
it is no longer maintained, which means that it will not receive any
further security or bug fix updates.
As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
openSUSE (At this moment openSUSE Leap 15.1, 15.0 and Tumbleweed) please
feel free to reopen this bug against that version (!you must update the
"Version" component in the bug fields, do not just reopen please), or
alternatively create a new ticket.

Thank you for reporting this bug and we are sorry it could not be fixed
during the lifetime of the release.

[1] https://en.opensuse.org/Lifetime
Comment 4 Episteme PROMENEUR 2019-07-11 11:15:05 UTC
it is not specific to any version of opensuse.

It is a wish.