Bug 854784 - Zypper man page creates error when attempting to read it
Zypper man page creates error when attempting to read it
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE 13.1
Classification: openSUSE
Component: libzypp
Final
All All
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
maint:released:sle11-sp3:55605 maint...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-10 17:06 UTC by Uzair Shamim
Modified: 2014-01-19 09:33 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Uzair Shamim 2013-12-10 17:06:41 UTC
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

Summary: When attempting to read the zypper man page an error appears about the formatting of the man page itself.

The Error:
jetchisel@OSSE:~> man zypper | grep regex
<standard input>:1001: warning: numeric expression expected (got `)')
<standard input>:1003: warning: numeric expression expected (got `)')
<standard input>:1010: warning: numeric expression expected (got `)')
<standard input>:1027: warning: numeric expression expected (got `)')
<standard input>:1032: warning: numeric expression expected (got `)')
<standard input>:1036: warning: numeric expression expected (got `)')
<standard input>:1045: warning: numeric expression expected (got `)')
<standard input>:1054: warning: numeric expression expected (got `)') 

Reproducible: Always

Steps to Reproduce:
1. Open a terminal emulator
2. man zypper | grep regex
Actual Results:  
Error:
jetchisel@OSSE:~> man zypper | grep regex
<standard input>:1001: warning: numeric expression expected (got `)')
<standard input>:1003: warning: numeric expression expected (got `)')
<standard input>:1010: warning: numeric expression expected (got `)')
<standard input>:1027: warning: numeric expression expected (got `)')
<standard input>:1032: warning: numeric expression expected (got `)')
<standard input>:1036: warning: numeric expression expected (got `)')
<standard input>:1045: warning: numeric expression expected (got `)')
<standard input>:1054: warning: numeric expression expected (got `)') 


Expected Results:  
There should be no error when attempting to read the man page

Even if the term is different from regex (for example 'search'), the error will still appear. It appears to be an error with some formatting on the man page.

Please See: https://forums.opensuse.org/english/get-technical-help-here/applications/493196-use-regex-zypper.html#post2606767
Comment 1 Michael Andres 2013-12-11 10:25:51 UTC
Some .TP commands in /usr/share/man/man8/zypper.8.gz contain 
trailing garbage (a line of '='):
 .TP =====================================================
After removing the '=' the warning is gone:
 .TP

Fixed in zypper-1.9.6.
Comment 2 Swamp Workflow Management 2013-12-20 12:16:25 UTC
The SWAMPID for this issue is 55603.
This issue was rated as moderate.
Please submit fixed packages until 2014-01-03.
Also create a patchinfo file using this link:
https://swamp.suse.de/webswamp/wf/55603
Comment 3 Swamp Workflow Management 2014-01-07 11:05:33 UTC
openSUSE-RU-2014:0026-1: An update that has 6 recommended fixes can now be installed.

Category: recommended (low)
Bug References: 844373,845619,846565,850907,852943,854784
CVE References: 
Sources used:
openSUSE 12.2 (src):    libzypp-11.13.3-2.33.1, zypper-1.7.16-1.28.1
Comment 4 Swamp Workflow Management 2014-01-07 11:08:30 UTC
openSUSE-RU-2014:0032-1: An update that has 7 recommended fixes can now be installed.

Category: recommended (low)
Bug References: 756195,849251,850907,852943,853065,853167,854784
CVE References: 
Sources used:
openSUSE 13.1 (src):    libzypp-13.8.5-6.1, zypper-1.9.6-8.1
Comment 5 Swamp Workflow Management 2014-01-07 11:09:25 UTC
openSUSE-RU-2014:0036-1: An update that has two recommended fixes can now be installed.

Category: recommended (low)
Bug References: 852943,854784
CVE References: 
Sources used:
openSUSE 12.3 (src):    libzypp-12.16.3-1.29.1, zypper-1.8.20-1.22.1
Comment 6 Dario Savella 2014-01-13 15:02:51 UTC
Hi there,

online_update notified me of the new update mentioned in comment #5 above.
The description of the update is:

openSUSE-RU-2014:0036-1: Softwarestack update for openSUSE 12.2

Is that a typo? Should this update be installed on 12.3 ?

Thanks
Comment 7 Michael Andres 2014-01-14 10:56:23 UTC
This looks like a typo to me. You can also check by looking at the content:

   12_3  contains  libzypp-12.x  zypper 1.8.x
   12_2  contains  libzypp-11.x  zypper 1.7.x

Due to the lower version numbers a 'real' 12_2 patch should not be triggered on a 12.3 system. Patches won't downgrade packages.


@maint-coord: Looks there are some patches out with wrong title:

  <update from="maint-coord@suse.de" status="stable" type="recommended" version="1">
    <id>openSUSE-2014-15</id>
    <title>Softwarestack update for openSUSE 12.2</title>
    <severity>low</severity>
    <release>openSUSE 12.3 Update</release>

  Content is libzypp-12.16.3/zypper-1.8.20, so it shoiuld be for 12.3
Comment 8 Benjamin Brunner 2014-01-14 11:02:17 UTC
That was my fault, sorry for the confusion. I prepared a 12.2, 12.3 and 13.1 update and forgot to change the title. But the sources are correct, it's just the title in the updateinfo.
Comment 9 Dario Savella 2014-01-14 15:18:54 UTC
No problem. Thanks for the quick reply.
Comment 10 Swamp Workflow Management 2014-01-17 19:46:24 UTC
Update released for: libzypp, libzypp-debuginfo, libzypp-debugsource, libzypp-devel, zypper, zypper-debuginfo, zypper-debugsource, zypper-log
Products:
SLE-DEBUGINFO 11-SP2 (i386, ia64, ppc64, s390x, x86_64)
SLE-DESKTOP 11-SP2 (i386, x86_64)
SLE-SDK 11-SP2 (i386, ia64, ppc64, s390x, x86_64)
SLE-SERVER 11-SP2 (i386, ia64, ppc64, s390x, x86_64)
SLES4VMWARE 11-SP2 (i386, x86_64)
Comment 11 Swamp Workflow Management 2014-01-17 19:53:16 UTC
Update released for: libzypp, libzypp-debuginfo, libzypp-debugsource, libzypp-devel, zypper, zypper-debuginfo, zypper-debugsource, zypper-log
Products:
SLE-DEBUGINFO 11-SP3 (i386, ia64, ppc64, s390x, x86_64)
SLE-DESKTOP 11-SP3 (i386, x86_64)
SLE-SDK 11-SP3 (i386, ia64, ppc64, s390x, x86_64)
SLE-SERVER 11-SP3 (i386, ia64, ppc64, s390x, x86_64)
SLES4VMWARE 11-SP3 (i386, x86_64)
Comment 12 Swamp Workflow Management 2014-01-17 21:05:14 UTC
SUSE-YU-2014:0090-1: An update that has 5 YOU fixes can now be installed.

Category: YOU (moderate)
Bug References: 793809,846565,850907,852943,854784
CVE References: 
Sources used:
SUSE Manager Client Tools for SLE 11 SP1 (src):    libzypp-6.39.3-0.3.1, zypper-1.3.25-0.3.1
Comment 13 Swamp Workflow Management 2014-01-17 21:06:20 UTC
Update released for: libzypp, libzypp-debuginfo, libzypp-debugsource, libzypp-devel, zypper, zypper-debuginfo, zypper-debugsource
Products:
SLE-SERVER 11-SP1-CLIENT-TOOLS (i386, ia64, ppc64, s390x, x86_64)
SLE-SERVER 11-SP1-TERADATA (x86_64)
Comment 14 Swamp Workflow Management 2014-01-17 23:05:29 UTC
SUSE-YU-2014:0091-1: An update that has 7 YOU fixes can now be installed.

Category: YOU (moderate)
Bug References: 841473,844373,845619,846565,850907,852943,854784
CVE References: 
Sources used:
SUSE Linux Enterprise Software Development Kit 11 SP3 (src):    libzypp-9.37.4-0.7.2
SUSE Linux Enterprise Software Development Kit 11 SP2 (src):    libzypp-9.16.4-0.5.2
SUSE Linux Enterprise Server 11 SP3 for VMware (src):    libzypp-9.37.4-0.7.2, zypper-1.6.311-0.7.3
SUSE Linux Enterprise Server 11 SP3 (src):    libzypp-9.37.4-0.7.2, zypper-1.6.311-0.7.3
SUSE Linux Enterprise Server 11 SP2 for VMware (src):    libzypp-9.16.4-0.5.2, zypper-1.6.178-0.5.3
SUSE Linux Enterprise Server 11 SP2 (src):    libzypp-9.16.4-0.5.2, zypper-1.6.178-0.5.3
SUSE Linux Enterprise Desktop 11 SP3 (src):    libzypp-9.37.4-0.7.2, zypper-1.6.311-0.7.3
SUSE Linux Enterprise Desktop 11 SP2 (src):    libzypp-9.16.4-0.5.2, zypper-1.6.178-0.5.3