Bug 853072 - vim lost ability to use XServer clipboard (+xterm_clipboard)
vim lost ability to use XServer clipboard (+xterm_clipboard)
Status: RESOLVED FIXED
: 862343 (view as bug list)
Classification: openSUSE
Product: openSUSE 13.1
Classification: openSUSE
Component: Basesystem
Final
x86-64 openSUSE 13.1
: P5 - None : Normal (vote)
: ---
Assigned To: Ismail Dönmez
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-01 18:15 UTC by kolA flash
Modified: 2014-04-10 13:45 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
patch changing compilation flags to reenable xterm_clipboard (374 bytes, patch)
2014-01-30 11:01 UTC, Robin Roth
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description kolA flash 2013-12-01 18:15:55 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0

Until openSUSE 12.3 I used to copy stuff from vim to XServer applications. I.e. copy links from a textfile into Firefox.

1. Press v and mark some text.
2. Press "+y (one after another: " then + then y) to copy to XServer clipboard.

On openSUSE 13.1 this isn't working anymore. Looks like the +xterm_clipboard was disabled when compiling vim.

# vim --version | grep xterm_clipboard
+eval            +mouse_dec       +startuptime     -xterm_clipboard

A - tells that the option is disabled.

Please re-enable!

Reproducible: Always
Comment 1 Ismail Dönmez 2014-01-14 14:09:42 UTC
This should be fixed in openSUSE 13.1, can you please check?
Comment 2 kolA flash 2014-01-14 18:52:21 UTC
The other way around:

The problem appeared with openSUSE 13.1

In openSUSE 12.3 everything was fine.
Comment 3 Robin Roth 2014-01-30 10:29:29 UTC
As mentioned by Moritz Duge, the vim build in openSuSE 13.1 is missing the compilation option "xterm_clipboard". This breaks workflows that worked in 12.3.
Please readd a vim version with "xterm_clipboard"
Comment 4 Robin Roth 2014-01-30 11:01:33 UTC
Created attachment 576510 [details]
patch changing compilation flags to reenable xterm_clipboard

This patch of the vim.spec file removes the "--without-x" flag and thus enables xterm_clipboard again, restoring features present in previous openSuSE versions.
Comment 5 kolA flash 2014-02-05 16:49:17 UTC
Tried with

http://download.opensuse.org/source/distribution/13.1/repo/oss/suse/src/vim-7.4.052-1.1.src.rpm

and works well. Except I had to replace

BuildRequires:  krb5-mini

with

BuildRequires:  krb5

in the "vim.spec" file because of this:

====================
$ LANG=C sudo zypper in krb5-mini
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: krb5-mini-1.11.3-3.4.1.x86_64 conflicts with krb5 provided by krb5-1.11.3-3.4.1.x86_64
====================
Comment 6 Martin Liška 2014-03-24 12:17:36 UTC
When can one expect official release of the package?
Comment 7 Ismail Dönmez 2014-03-24 12:44:08 UTC
I am looking into this, sorry for the delay.
Comment 8 Martin Liška 2014-03-24 12:56:22 UTC
(In reply to comment #7)
> I am looking into this, sorry for the delay.

Thank you
Comment 9 Robin Roth 2014-03-25 08:37:55 UTC
The patch is already applied in the editors repository:
https://build.opensuse.org/package/rdiff/editors/vim?linkrev=base&rev=195
Comment 10 Ismail Dönmez 2014-04-02 13:15:21 UTC
Requesting maintenance update for 13.1, submitted SR#228749
Comment 11 Ismail Dönmez 2014-04-02 13:18:03 UTC
*** Bug 862343 has been marked as a duplicate of this bug. ***
Comment 12 Bernhard Wiedemann 2014-04-02 14:00:14 UTC
This is an autogenerated message for OBS integration:
This bug (853072) was mentioned in
https://build.opensuse.org/request/show/228749 13.1 / vim
Comment 13 Matthias Griessmeier 2014-04-03 10:40:16 UTC
Thanks for your submission. Request accepted (openSUSE:Maintenance:2708)
Comment 14 Matthias Griessmeier 2014-04-10 06:25:25 UTC
Update released for openSUSE 13.1 - resolved fixed
Comment 15 Swamp Workflow Management 2014-04-10 07:05:57 UTC
openSUSE-RU-2014:0508-1: An update that has one recommended fix can now be installed.

Category: recommended (low)
Bug References: 853072
CVE References: 
Sources used:
openSUSE 13.1 (src):    vim-7.4.052-4.1
Comment 16 kolA flash 2014-04-10 13:45:11 UTC
Tested the update and works well :-)
Thanks!