Bug 844373 - zypper remove gives wrong message when removing a versioned package
zypper remove gives wrong message when removing a versioned package
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE 12.2
Classification: openSUSE
Component: libzypp
Final
Other Other
: P3 - Medium : Enhancement (vote)
: ---
Assigned To: E-mail List
E-mail List
maint:released:sle11-sp3:55605
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 21:14 UTC by Stefan Sauer
Modified: 2014-01-19 09:33 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Sauer 2013-10-07 21:14:17 UTC
User-Agent:       Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1553.0 Safari/537.36 SUSE/30.0.1553.0

To track down a bug, I was asked to try development and upstrem kernels. In order to remove the upstream kernel again, I deactivated the repository and uninstalled the versioned package (german text ahead):

# zypper remove kernel-desktop-3.12.rc3-1.1.ge5ef0d0
Daten des Repositories laden ...
Installierte Pakete lesen ...
Paketabhängigkeiten auflösen ...

Das folgende Paket wird GELÖSCHT:
  kernel-desktop 

The issue are the last two lines saying:

The package below will be DELETED:
  kernel-desktop 

which is not true. Removing all versions of "kernel-desktop" would not be a good idea. Deleting this particullar version might be okay. The message should include the verison as well to not set the user on a false alarm. When proceding it does only delete the versioned message.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Michael Andres 2013-10-14 07:36:42 UTC
Well, the short summary always displays package names only:

    The following package is going to be REMOVED:
      test_kernel  
 
    1 package to remove.
    No additional space will be used or freed after the operation.
    Continue? [y/n/?] (y):


If you're in doubt, press '(d)etail' at the prompt and you'll get more info. This is also the default if you say 'zypper --verbose/-v':

    Continue? [y/n/?] (y): d

    The following package is going to be REMOVED:
      test_kernel  B-2  noarch  kernel_vendor_B

    1 package to remove.
    No additional space will be used or freed after the operation.


If the list gets too long, because too many packages are involved in the request (e.g on 'zypper dup'), press 'pa(g)er' for more convenient viewing.
Pressing (?) will give you an overview about all prompt options available.

I currently don't see the need to change this behavior.
Comment 2 Stefan Sauer 2013-10-14 13:57:28 UTC
???

1.) 
"Continue? [y/n/?] (y):"
no one is going to press 'd' here, right?

2.)
"The following package is going to be REMOVED:
      test_kernel  B-2  noarch  kernel_vendor_B"
Are "B-2  noarch  kernel_vendor_B" deps of "test_kernel"? Otherwise that would be confusing.

3.)
"No additional space will be used or freed after the operation."
If a package gets removed, some space will be free, right?

---

Anyway up, to you wheter you want to make this more user friendly or not. If a specific versions is given, I'd say it makes sense to also show that.
Comment 3 Michael Andres 2013-10-14 15:11:14 UTC
(In reply to comment #2)
> "Continue? [y/n/?] (y):"
> no one is going to press 'd' here, right?

And it looks like no one presses '?' either. Maybe it should be 

  "Continue? [y/n/? for more options] (y):" ?

  y - Yes, accept the summary and proceed ...
  n - No, cancel the operation.
  v - Toggle display of package versions.
  a - Toggle display of package architectures.
  r - Toggle display of repositories ...
  m - Toggle display of package vendor names.
  d - Toggle between showing all details and as few details as possible.
  g - View the summary in pager.



> "The following package is going to be REMOVED:
>      test_kernel  B-2  noarch  kernel_vendor_B"

Sorry, I should not have pasted test data. You see name, version, architecture and vendor for each package; and as the test_kernel package is a fake, it has zero size.


I'll keep it as enhancement request.
Comment 4 Stefan Sauer 2013-10-14 18:06:41 UTC
Thank you, it is appreciated. "? for more options" sounds like a good idea.
Comment 5 Michael Andres 2013-10-16 09:30:18 UTC
- The prompt was changed to "Continue? [y/n/? shows all options] (y):"

- Zypper displays the version of packages to be deleted in the 'normal' summary, IF there is actually more than one version installed. So this does not depend on any commandline args, but applies to all multi-version packages.


Fixed in Factory. 
Will be included in future updates:
   13.1       zypper 1.9.3
   12.3       zypper 1.8.18
   12.2       zypper 1.7.15
Comment 6 Ludwig Nussel 2013-10-30 07:49:19 UTC
cosmetic changes like this at this point in the release cycle can break a full night of testing a build using openqa. the image matcher was looking for the old prompt.
Comment 7 Swamp Workflow Management 2013-11-11 12:05:01 UTC
openSUSE-RU-2013:1653-1: An update that has 5 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 575096,834376,844373,845619,846565
CVE References: 
Sources used:
openSUSE 12.3 (src):    libsolv-0.3.2-2.14.1, libzypp-12.16.1-1.21.2, zypper-1.8.18-1.14.2
Comment 8 Swamp Workflow Management 2013-12-20 12:16:33 UTC
The SWAMPID for this issue is 55603.
This issue was rated as moderate.
Please submit fixed packages until 2014-01-03.
Also create a patchinfo file using this link:
https://swamp.suse.de/webswamp/wf/55603
Comment 9 Swamp Workflow Management 2014-01-07 11:04:31 UTC
openSUSE-RU-2014:0026-1: An update that has 6 recommended fixes can now be installed.

Category: recommended (low)
Bug References: 844373,845619,846565,850907,852943,854784
CVE References: 
Sources used:
openSUSE 12.2 (src):    libzypp-11.13.3-2.33.1, zypper-1.7.16-1.28.1
Comment 10 Swamp Workflow Management 2014-01-17 19:46:55 UTC
Update released for: libzypp, libzypp-debuginfo, libzypp-debugsource, libzypp-devel, zypper, zypper-debuginfo, zypper-debugsource, zypper-log
Products:
SLE-DEBUGINFO 11-SP2 (i386, ia64, ppc64, s390x, x86_64)
SLE-DESKTOP 11-SP2 (i386, x86_64)
SLE-SDK 11-SP2 (i386, ia64, ppc64, s390x, x86_64)
SLE-SERVER 11-SP2 (i386, ia64, ppc64, s390x, x86_64)
SLES4VMWARE 11-SP2 (i386, x86_64)
Comment 11 Swamp Workflow Management 2014-01-17 19:52:48 UTC
Update released for: libzypp, libzypp-debuginfo, libzypp-debugsource, libzypp-devel, zypper, zypper-debuginfo, zypper-debugsource, zypper-log
Products:
SLE-DEBUGINFO 11-SP3 (i386, ia64, ppc64, s390x, x86_64)
SLE-DESKTOP 11-SP3 (i386, x86_64)
SLE-SDK 11-SP3 (i386, ia64, ppc64, s390x, x86_64)
SLE-SERVER 11-SP3 (i386, ia64, ppc64, s390x, x86_64)
SLES4VMWARE 11-SP3 (i386, x86_64)
Comment 12 Swamp Workflow Management 2014-01-17 23:04:32 UTC
SUSE-YU-2014:0091-1: An update that has 7 YOU fixes can now be installed.

Category: YOU (moderate)
Bug References: 841473,844373,845619,846565,850907,852943,854784
CVE References: 
Sources used:
SUSE Linux Enterprise Software Development Kit 11 SP3 (src):    libzypp-9.37.4-0.7.2
SUSE Linux Enterprise Software Development Kit 11 SP2 (src):    libzypp-9.16.4-0.5.2
SUSE Linux Enterprise Server 11 SP3 for VMware (src):    libzypp-9.37.4-0.7.2, zypper-1.6.311-0.7.3
SUSE Linux Enterprise Server 11 SP3 (src):    libzypp-9.37.4-0.7.2, zypper-1.6.311-0.7.3
SUSE Linux Enterprise Server 11 SP2 for VMware (src):    libzypp-9.16.4-0.5.2, zypper-1.6.178-0.5.3
SUSE Linux Enterprise Server 11 SP2 (src):    libzypp-9.16.4-0.5.2, zypper-1.6.178-0.5.3
SUSE Linux Enterprise Desktop 11 SP3 (src):    libzypp-9.37.4-0.7.2, zypper-1.6.311-0.7.3
SUSE Linux Enterprise Desktop 11 SP2 (src):    libzypp-9.16.4-0.5.2, zypper-1.6.178-0.5.3