Bug 843573 - [13.1B1] wrong language/language mix in YaST modules
[13.1B1] wrong language/language mix in YaST modules
Status: RESOLVED DUPLICATE of bug 914081
: 856908 898827 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
13.1 Beta 1
x86-64 SUSE Other
: P5 - None : Normal (vote)
: ---
Assigned To: Ladislav Slezák
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-01 19:15 UTC by Volker Barth
Modified: 2016-10-31 21:50 UTC (History)
6 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volker Barth 2013-10-01 19:15:04 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0

Fresh installation of 13.1 Beta 1, language of the system set to German. When starting YaST, all text in the YaST control center is - as expected - German. However, most of the modules themselves are a mix of English and German.

E.g. "Date and Time" module:
 in English: heading, checkbox, descriptive text, cancel button
 in German: content of the drop-down-boxes, help button, world map picture 
            (including text therein)

Similar e.g. in the modules "Firewall", "User and Group Administration", "Printer Configurations" and probably more.

Reproducible: Always
Comment 1 Martin Vidner 2013-10-03 08:23:10 UTC
See also https://github.com/yast/yast-ruby-bindings/issues/68
Comment 2 Josef Reidinger 2013-11-18 15:07:58 UTC
Can you reproduce it with RC2? We did some fixes to properly initialize translation.
Comment 3 Volker Barth 2013-11-19 12:28:11 UTC
Yes, it's still there, language is still mixed in the modules. Packages are up-to-date according to zypper.

But I just realized I need to give some clarification on this bug.

* The installation started - as pointed out above - as a clean installation of
  13.1B1 and was upgraded using zypper resp. its KDE plasmoid. I did not change
  any settings of root user intentionally.

* Being logged in under KDE as a non-root user, opening a konsole and switching
 (su -) to root gives me:

  # locale
  LANG=POSIX
  LC_CTYPE=de_DE.UTF-8
  [...]

  Starting yast2 under these conditions produces YaST2 being completely in 
  English (both control center and submodules). However, if I do a

  # export LANG="de_DE.UTF-8"; yast2

  both control center and submodules are completely in German, as they are 
  supposed to be.

* Creating a .profile in root's home containing only 
  
  export LANG="de_DE.UTF-8

  gives me (the following being done inside a konsole started as above used
  non-root user)

  ~>su - -c yast2  //YaST2 completely in German

  ~>su -c yast2 //control center in German, submodules mixed language

  ~>kdesu -c yast2 //control center in German, submodules mixed language

  The last command is the one used for starting YaST2 using the K-menu, and
  that's the way I initially found this bug.

* For sake of completeness: as the non-root user, I get in konsole:

  ~>locale
  LANG=de_DE.UTF-8
  LC_CTYPE="de_DE.UTF-8"
  [...]
Comment 4 Josef Reidinger 2013-11-19 12:32:35 UTC
jsuchome can you check why LANG is not set properly?
Comment 5 Jiří Suchomel 2013-11-19 15:01:00 UTC
Sorry, no (it's not connected to yast2-country btw). 
It probably is connected to ruby switch.

There's also the part of starting with correct LANG variable in startup scripts set_lang_from_sysconfig function in scripts/yast2-funcs, but I thinnk this part works well. Maybe Arvin could shed some more light here?
Comment 6 Arvin Schnell 2013-11-19 15:12:28 UTC
Please provide the output of the "locale" command for the various methods
to call YaST.

Right away: Mixing POSIX and de_DE.UTF-8 in the locale settings is not
supported by POSIX.
Comment 7 Volker Barth 2013-11-19 18:58:08 UTC
As I wrote above: I did not intentionally change any settings for root. So if POSIX and de_DE.UTF-8 settings are mixed, that's done automatically.

Here are the locale outputs:

vanilla root user
(YaST completely in English):

LANG=POSIX
LC_CTYPE=de_DE.UTF-8
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=

using 
 - "export LANG="de_DE.UTF-8"; yast2" (in su environment)
 - .profile and "su - -c yast2" 
(YaST completely in German):

LANG=de_DE.UTF-8
LC_CTYPE=de_DE.UTF-8
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

using 
 - .profile and "su -c yast2"
 - .profile and "kdesu -c yast2"
(YaST shows mixed language):

LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

vanilla non-root user:

LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=
Comment 8 Steffen Winterfeldt 2013-12-02 09:58:09 UTC
Another dup of bug 801311?
Comment 9 Jiří Suchomel 2014-02-14 08:03:36 UTC
*** Bug 856908 has been marked as a duplicate of this bug. ***
Comment 10 Jiří Suchomel 2014-02-14 08:05:22 UTC
(In reply to comment #8)
> Another dup of bug 801311?

No, this one is still present. It works correctly for root, but not for non-root user.
Comment 11 Arvin Schnell 2014-09-29 07:58:22 UTC
*** Bug 898827 has been marked as a duplicate of this bug. ***
Comment 12 Troels Just 2014-11-25 21:35:49 UTC
This problem started randomly on one of my machines earlier today. I am using openSUSE 13.2
Comment 13 Ladislav Slezák 2015-02-02 16:11:30 UTC
Please, could someone try yast2-core-3.1.15 (from Tumbleweed or Factory)? I have fixed bug#914081, maybe this one is a duplicate...
Comment 14 Volker Barth 2015-02-03 19:57:41 UTC
(In reply to Ladislav Slezak from comment #13)
> yast2-core-3.1.15 (from Tumbleweed or Factory)?

Looks good. I installed 3.1.15 from YaST:Head (openSUSE 13.2) and the language was set properly in the modules I mentioned in my initial bug report for 13.1.
Comment 15 Ladislav Slezák 2016-10-31 21:50:34 UTC
Oh, I forgot to close it as a duplicate of bug 914081...

*** This bug has been marked as a duplicate of bug 914081 ***