Bug 842265 - xfce4 panel doesn't autohide after resume
xfce4 panel doesn't autohide after resume
Status: RESOLVED DUPLICATE of bug 764310
Classification: openSUSE
Product: openSUSE 12.3
Classification: openSUSE
Component: Xfce
Final
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Guido Berhoerster
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 11:35 UTC by Dejan Muhamedagic
Modified: 2013-10-02 18:39 UTC (History)
0 users

See Also:
Found By: Development
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
a tarball with various system information (11.57 KB, application/x-bzip)
2013-09-30 07:19 UTC, Dejan Muhamedagic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dejan Muhamedagic 2013-09-25 11:35:15 UTC
After some suspend/resume, unfortunately I cannot say when and how this occurs exactly, the panel at the bottom of the screen won't go away any more (it is set to autohide). It's sort of annoying, so eventually I need to logout and login again to reset it.

There doesn't seem to be anything interesting in the logs or strace output (attached).

Will finish the report later...
Comment 1 Dejan Muhamedagic 2013-09-30 07:19:39 UTC
Created attachment 560785 [details]
a tarball with various system information

The rpm version is as follows:

4.10.0-5.1.1

Please let me know if you need more information. Now I'm off to logout/login again.
Comment 2 Dejan Muhamedagic 2013-09-30 07:21:15 UTC
Assigning to the bugowner of xfce4-panel.
Comment 3 Guido Berhoerster 2013-09-30 07:58:27 UTC
Are you using the actions menu to suspend (in the default configuration the menu with you name on it in the lower right corner)? This is probably a duplicate of bug #764310.
You don't need to log out, as a workaround you can restart the panel with xfce4-panel --restart.
Comment 4 Guido Berhoerster 2013-09-30 08:33:54 UTC
Can you try whether home:gberh:branches:X11:xfce/xfce4-panel fixes the problem for you?
Comment 5 Dejan Muhamedagic 2013-09-30 10:19:02 UTC
> Are you using the actions menu to suspend (in the default configuration the
> menu with you name on it in the lower right corner)?

Yes.

> This is probably a
> duplicate of bug #764310.

Whoa! The bug's there since 12.2.

I downloaded your packages and did xfce4-panel --restart. Will report how did it fare in a few. Thanks!
Comment 6 Dejan Muhamedagic 2013-10-02 05:12:21 UTC
It looks like your package solved the issue. The panel however somehow didn't pick the current panel configuration, i.e. all the launchers vanished, but some very old ones reappeared.
Comment 7 Dejan Muhamedagic 2013-10-02 13:26:35 UTC
Is there a way to get back the previous panel configuration, i.e. a set of launchers etc? I'd really hate to have to do all that stuff again. Tried adding an existing launcher definition to the panels.xml, but no cigar :-/
Comment 8 Guido Berhoerster 2013-10-02 18:38:26 UTC
(In reply to comment #7)
> Is there a way to get back the previous panel configuration, i.e. a set of
> launchers etc? I'd really hate to have to do all that stuff again. Tried adding
> an existing launcher definition to the panels.xml, but no cigar :-/

You have probably installed xfce4-panel-branding-upstream due to the version update from xfce4-panel-4.10.0 to 4.10.1. Your customized panel configuration is like an overlay over the system configuration, if the underlying system configuration changes from xfce4-panel-branding-openSUSE to xfce4-panel-branding-upstream it will appear "messed up". This is a known problem, for details see https://bugzilla.xfce.org/show_bug.cgi?id=9229#c1
Comment 9 Guido Berhoerster 2013-10-02 18:39:30 UTC
Duplicate.

*** This bug has been marked as a duplicate of bug 764310 ***