Bug 812606 - Can't disable firewall in Yast
Can't disable firewall in Yast
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE 12.3
Classification: openSUSE
Component: YaST2
Final
i686 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Lukas Ocilka
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-30 19:07 UTC by tosiara tosiara
Modified: 2021-02-16 11:09 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
y2log Yast ncurses (41.95 KB, text/x-log)
2013-04-03 05:47 UTC, tosiara tosiara
Details
Another firewall is running (33.21 KB, text/x-log)
2013-04-03 06:04 UTC, tosiara tosiara
Details
y2log from start to finish yast-firewall (21.67 KB, application/octet-stream)
2013-04-13 22:53 UTC, Ilya Shevchenko
Details
y2log disable firewall in Yast (50.05 KB, application/x-zip)
2013-04-15 08:06 UTC, tosiara tosiara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tosiara tosiara 2013-03-30 19:07:33 UTC
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:19.0) Gecko/20100101 Firefox/19.0

Go to Yast->Firewall and select "Disable Firewall Automatic Start". Confirm changes and go to Yast->Firewall again - "Enable" is still checked. As a result  Firewall is always on after reboot

Reproducible: Always

Steps to Reproduce:
1. Disable firewall auto start
2. Reboot PC
3. Firewall starts 
Actual Results:  
Firewall auto start is always enables

Expected Results:  
SHould disable autostart
Comment 1 pier andre 2013-03-31 08:30:18 UTC
only for add me in the list :-)
Comment 2 Michal Filka 2013-04-03 04:46:26 UTC
Please attach y2log (e.g. using save_y2logs). Thanks
Comment 3 tosiara tosiara 2013-04-03 05:47:28 UTC
Created attachment 533180 [details]
y2log Yast ncurses
Comment 4 tosiara tosiara 2013-04-03 06:03:33 UTC
Strange, but after the previous log has been created the Firewall got disabled. But when I launched Yast Firewall again I got message that another firewall is active.
Comment 5 tosiara tosiara 2013-04-03 06:04:29 UTC
Created attachment 533182 [details]
Another firewall is running
Comment 6 tosiara tosiara 2013-04-03 06:11:55 UTC
Can no longer reproduce on this machine. I will take a brand new install and try reproduce there.
Comment 7 Ilya Shevchenko 2013-04-13 22:53:07 UTC
Created attachment 535092 [details]
y2log from start to finish yast-firewall
Comment 8 Ilya Shevchenko 2013-04-13 22:57:10 UTC
Comment on attachment 535092 [details]
y2log from start to finish yast-firewall

I have the same issue. It seems yast-firewall search for SuSEfirewall_setup service and cannot find it.
Comment 9 tosiara tosiara 2013-04-15 08:06:34 UTC
Created attachment 535133 [details]
y2log disable firewall in Yast
Comment 10 tosiara tosiara 2013-04-15 08:06:48 UTC
100% reproducible on freshly installed x86 and x86_64 openSUSE 12.3
Comment 11 Lukas Ocilka 2013-04-15 11:57:31 UTC
I'll have a patch soon.
Comment 12 Lukas Ocilka 2013-04-15 13:59:52 UTC
Proposed fix
https://github.com/yast/yast-firewall/pull/3
Comment 13 Bernhard Wiedemann 2013-04-16 09:00:08 UTC
This is an autogenerated message for OBS integration:
This bug (812606) was mentioned in
https://build.opensuse.org/request/show/171013 Maintenance /
Comment 14 Lukas Ocilka 2013-04-16 11:21:38 UTC
Created new package and submitted to Factory and openSUSE 12.3
Comment 15 Swamp Workflow Management 2013-06-10 09:10:36 UTC
openSUSE-RU-2013:0887-1: An update that has one recommended fix can now be installed.

Category: recommended (low)
Bug References: 812606
CVE References: 
Sources used:
openSUSE 12.3 (src):    yast2-firewall-2.21.2.1-5.4.1