Bug 755198 - systemd kills session instantly with LightDM
systemd kills session instantly with LightDM
Status: VERIFIED WONTFIX
Classification: openSUSE
Product: openSUSE 12.2
Classification: openSUSE
Component: Basesystem
Factory
Other Other
: P5 - None : Critical (vote)
: ---
Assigned To: Frederic Crozat
E-mail List
:
Depends on:
Blocks: 696902
  Show dependency treegraph
 
Reported: 2012-04-02 08:51 UTC by Guido Berhoerster
Modified: 2012-04-27 08:32 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
lightdm.log to illustrate the problem (7.32 KB, text/plain)
2012-04-02 08:51 UTC, Guido Berhoerster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guido Berhoerster 2012-04-02 08:51:53 UTC
Created attachment 484414 [details]
lightdm.log to illustrate the problem

User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0

On Factory more recent versions of systemd seem to shoot down sessions instantly when logging in, ie. it appears that systemd-logind sends a SIGTERM immediately after the session has been forked from the greeter. On earlier versions of systemd and in 12.1 this used to work and switching back to sysvinit-init makes it work again so it's clearly an issue with systemd.  I don't see anything helpful in the logs, there is just:

Apr  2 10:21:56 linux-2w68 systemd-logind[559]: Removed session 1.
Apr  2 10:21:56 linux-2w68 systemd-logind[559]: New session 2 of user gber.
Apr  2 10:21:56 linux-2w68 systemd-logind[559]: Linked /tmp/.X11-unix/X0 to /run/user/gber/X11-display.
Apr  2 10:21:56 linux-2w68 systemd-logind[559]: Removed session 2.

See also the attached lightdm.log.

This is critical since it currently prevents anyone from logging in on a Xfce default install. 

Reproducible: Always
Comment 1 Guido Berhoerster 2012-04-20 09:43:02 UTC
As of LightDM 1.2.x this problem is not triggered any more, this is a new major release and there have been vast code changes.
Comment 2 Guido Berhoerster 2012-04-27 08:32:03 UTC
Closing since systemd/lightdm 1.0.x in 12.1 work and Factory now has systemd/lightdm 1.2.x which works as well.