Bug 752796 - Kernel panic in openSUSE 12.2 M2
Kernel panic in openSUSE 12.2 M2
Status: VERIFIED FIXED
: 761221 (view as bug list)
Classification: openSUSE
Product: openSUSE 12.2
Classification: openSUSE
Component: Kernel
Factory
x86-64 Other
: P1 - Urgent : Critical (vote)
: ---
Assigned To: Michal Marek
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 08:13 UTC by Franz Bernasek
Modified: 2012-06-24 17:26 UTC (History)
7 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
aj: SHIP_STOPPER? (coolo)


Attachments
libkmod.so.2 not found - kernel panics (41.42 KB, image/png)
2012-05-22 08:31 UTC, Andreas Jaeger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Franz Bernasek 2012-03-19 08:13:29 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

after successfull install of the 258 Build (DVD) from 12.2 Milestone 2
i reboot.
the system hangs with a kernel panic a the following messages:Message:   /udevd[340] failed to execute
                 '/etc/sysconfig/network/scripts/ifup-sysctl'
/etc/sysconfig/network/scripts/ifup-sysctl lohotplu': no such file or directory

bzw:        /sbin/fsck: error while loading shared libraries: libblkid.so.1 ,
libkmod.so.2 : cannot open shared object file: no such file or directory



Reproducible: Always

Steps to Reproduce:
1. install build 258 openSUSE 12.2 M2 x86_64 also when install NET-Install 262
2. successfull
3. reboot
4. select Kernel
5. and crash Kernel Panic with following messages
Message:   /udevd[340] failed to execute
                 '/etc/sysconfig/network/scripts/ifup-sysctl'
/etc/sysconfig/network/scripts/ifup-sysctl lohotplu': no such file or directory

bzw:        /sbin/fsck: error while loading shared libraries: libblkid.so.1 ,
libkmod.so.2 : cannot open shared object file: no such file or directory


Actual Results:  
Message:   /udevd[340] failed to execute
                 '/etc/sysconfig/network/scripts/ifup-sysctl'
/etc/sysconfig/network/scripts/ifup-sysctl lohotplu': no such file or directory

bzw:        /sbin/fsck: error while loading shared libraries: libblkid.so.1 ,
libkmod.so.2 : cannot open shared object file: no such file or directory



Expected Results:  
normal using the openSUSE 12,2 M2
Comment 1 Jeff Mahoney 2012-03-19 15:26:26 UTC
I'm afraid "and crash kernel" isn't a good enough way to reproduce. Can you capture the Oops message?


This messages should probably be reported against the Installation component.
bzw:        /sbin/fsck: error while loading shared libraries: libblkid.so.1 ,
libkmod.so.2 : cannot open shared object file: no such file or directory
Comment 2 Franz Bernasek 2012-03-19 18:56:46 UTC
difficult, system hangs complete , must done a hard reset

its a real kernel panic, systemd stalled, i have the openSUSE 12.2 M2 x86_64
installed new, with a factory new harddisk, also we have done a complete hardware check, the same problem.
is its possible that the install process the needed libs done copy in a wrong
directory ?
Comment 3 Franz Bernasek 2012-03-19 21:28:25 UTC
so i have new install openSUSE 12.2 M2 x86_64 (258 Build DVD)
the same problem:

/sbin/fsck:error while loadinf shared libraries: libblkid.so.1 cannot open shared object file: no such file or directory

/sbin/init:error while loading shared libraries: libkmod.so.2 cannot open shared  object file: no such file or directory

pid:1 comm: init not tainted 3.3.0-rc6-1-desktop #1

[6.8009141] kernel panic - not syncing attemped to kill init !
Comment 4 Jeff Mahoney 2012-03-22 01:55:54 UTC
If I had to guess, I'd say that your root fs isn't getting mounted and that's where the panic is coming from and why there's no stack trace.

Can you boot with the rescue image and see if libblkid1 is installed? If so, verify that it's in the initramfs using lsinitrd.
Comment 5 Franz Bernasek 2012-03-22 12:12:36 UTC
Hi Jeff
thanks for message, okay i have boot from the openSUSE 12.2 M2 DVD
and boot with the Rescue Image.
so i have found the libblkidl  in the /lib64  /usr/lib64

but i have not found a initramfs not in /boot not in /var/run also not
in /run

but i have the openSUSE 12,2 M2 x86_64 installed on my ASUS N61jv Notebook
big surprise i works, i have done a update on the notebook with zypper,
and it works i don't know why it works on notebook normal but not on my 
workstation
Comment 6 Franz Bernasek 2012-03-22 15:36:14 UTC
(In reply to comment #5)
> Hi Jeff
> thanks for message, okay i have boot from the openSUSE 12.2 M2 DVD
> and boot with the Rescue Image.
> so i have found the libblkidl  in the /lib64  /usr/lib64
> 
> but i have not found a initramfs not in /boot not in /var/run also not
> in /run
> 
> but i have the openSUSE 12,2 M2 x86_64 installed on my ASUS N61jv Notebook
> big surprise i works, i have done a update on the notebook with zypper,
> and it works i don't know why it works on notebook normal but not on my 
> workstation

Hi Jeff i think the problem is the extra /usr partition
without this extra /usr partition the openSUSE 12.2 M2 works,
maybe a programming error of the install procedure or in the kernel 3.3 ?

greetings

Franz
Comment 7 Jeff Mahoney 2012-03-26 15:06:21 UTC
Can you update mkinitrd from http://download.opensuse.org/repositories/Base:/System/openSUSE_Factory/ and re-run mkinitrd and try to reproduce. This should have been fixed with this commit:

Thu Mar 22 10:29:58 UTC 2012 - seife+obs@b1-systems.com
- boot-udev: add blkid dependency
Comment 8 Franz Bernasek 2012-05-21 15:50:59 UTC
(In reply to comment #7)
> Can you update mkinitrd from
> http://download.opensuse.org/repositories/Base:/System/openSUSE_Factory/ and
> re-run mkinitrd and try to reproduce. This should have been fixed with this
> commit:
> 
> Thu Mar 22 10:29:58 UTC 2012 - seife+obs@b1-systems.com
> - boot-udev: add blkid dependency

Hi Jeff,

now the mkinitrd update works on M1 and M2,

but not on M3, on openSUSE 12.2 M3 x86_64 exists the same KERNEL PANIC
problem,

with 
SWAP
ext4 /boot
ext4 /
ext4 /home

openSUSE 12.2 M3 works normal

when i configure


swap
ext4 /boot
ext4 /
ext4 /usr
ext4 /var
ext4 /opt
ext4 /home
ext4 /tmp
ext4 /local

after installation , reboot , result the same KERNEL PANIC as on Releases before
no fix of the problem
Comment 9 Andreas Jaeger 2012-05-22 08:27:27 UTC
*** Bug 761221 has been marked as a duplicate of this bug. ***
Comment 10 Andreas Jaeger 2012-05-22 08:29:58 UTC
Franz, next time please click on the "This comment provides the needed information. Remove the status of NEEDINFO from this bug."

The bug is still in current build 377. I'm appending a screenshot.

To reproduce: Just install with separate /usr partition.
Comment 11 Andreas Jaeger 2012-05-22 08:31:23 UTC
Created attachment 491871 [details]
libkmod.so.2 not found - kernel panics

See screenshot for results of current status of factory
Comment 12 Andreas Jaeger 2012-05-24 15:47:13 UTC
Added to the most annoying bugs (http://en.opensuse.org/openSUSE:Most_annoying_bugs_12.2_dev)
and asking coolo to mark this as shipstopper.
Comment 13 Russ Fineman 2012-05-29 17:02:39 UTC
I have a problem which I think is the same bug:

Yesterday I tried to install openSUSE 12.2 KDE Live Cd 32-bit Build 387 on an 
old Compaq Presario with Intel Celeron CPU(32-bit),2.53 MHZ. System 
with 2GB Memory. Not sure who's MB. Appears to be Intel I845?? graphics chipset?
Cannot stop boot screen to read messages.

Just installing to do testing. Installed completely but everytime I try 
to boot it gets a kernel panic before showing on the openSUSE Splash screen bfore login screen.

Code
--------
[   3.410137]Kernel panic - not syncing: Attempted to kill init!
/Code
----------

My partition set up is:
sda                      120GB IDE Drive 
sda1 swap                 10GB
sda2 /           EXT4     25GB
sda3 /boot       EXT4      2GB
sda4 Extended            76GBB
sda5 /usr        EXT4     30GB
sda6 /home       EXT4     46GB

CD/DVD Samsung IDE

If I can provide more information please let me know.

Thanks

Russ
Comment 14 Bernhard Wiedemann 2012-06-13 09:00:08 UTC
This is an autogenerated message for OBS integration:
This bug (752796) was mentioned in
https://build.opensuse.org/request/show/124792 Factory / mkinitrd
Comment 15 Stephan Kulow 2012-06-18 07:47:51 UTC
should be fixed.
Comment 16 Nikolai Maziachvili 2012-06-18 12:30:41 UTC
Hi Stephan. You have sad that this problem should be fixed, does it means that you are working on it? 
I assumed that this was related to this: 
http://www.freedesktop.org/wiki/Software/systemd/separate-usr-is-broken
Comment 17 Andreas Jaeger 2012-06-18 12:40:45 UTC
Nikolai, this is fixed in our initial ramdisk - as the systemd docu suggests as well.

Mounting the /usr needs to be done earlier - in the ramdisk.
Comment 18 Nikolai Maziachvili 2012-06-18 14:32:53 UTC
Thnx Andreas for quick response. 
> Mounting the /usr needs to be done earlier - in the ramdisk.
This was my understanding too. But i didn't know that openSuse devs were working on this.
Andreas, document talks about two possible solutions, i was wondering if solution mentioned by you will be preferred for future. Or devs will be also working on second (more robust according to systemd devs) solution - minimizing rootfs and moving whole bunch to /usr.
Comment 19 Andreas Jaeger 2012-06-18 14:42:41 UTC
Nikolai, let's not discuss this here, this is a bug report that is fixed.

We fixed initrd now and started the move to /usr as well.
Comment 20 Bernhard Wiedemann 2012-06-24 17:26:52 UTC
added a test for separate /usr to openQA
that fails for Beta1
http://openqa.opensuse.org/results/openSUSE-DVD-i586-Build0398-splitusr
and succeeds for Beta2
http://openqa.opensuse.org/results/openSUSE-DVD-i586-Build0451-splitusr