Bug 751835 - Gnome Live CD for Build 241 missing 2 GRUB2 files
Gnome Live CD for Build 241 missing 2 GRUB2 files
Status: RESOLVED FIXED
: 753063 753130 (view as bug list)
Classification: openSUSE
Product: openSUSE 12.2
Classification: openSUSE
Component: Installation
Factory
x86-64 Other
: P5 - None : Major (vote)
: ---
Assigned To: Michael Chang
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 16:30 UTC by Larry Finger
Modified: 2012-06-19 05:27 UTC (History)
9 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Larry Finger 2012-03-12 16:30:21 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

The installation of Build 241 from the Gnome Live CD failed when installing the GRUB2 bootstrap due to two missing files. These are /usr/sbin/grub2-mkconfig and /usr/sbin/grub2-install.

Changing from GRUB2 to legacy GRUB in the installation resulted in a system that installed and booted.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Kun Kun Zhang 2012-03-13 10:11:24 UTC
Hi,thank you for your report,could you please provide y2logs according to the following URL?Thanks.
http://en.opensuse.org/openSUSE:Bugreport_YaST
Comment 2 Larry Finger 2012-03-13 14:59:28 UTC
The complete contents of the directory /var/log/YaST2 are at http://www.lwfinger.com/YaST_log.tar.gz. If you need other files from the aborted installation, please let me know. I'll leave that VM in its current state.

This Bugzilla needs the ability to upload a file such as most other Bugzilla sites have.
Comment 3 Larry Finger 2012-03-16 17:21:47 UTC
The KDE Live CD for Build 255 has the same problem.
Comment 4 Hans-Peter Holler 2012-03-20 18:57:04 UTC
*** Bug 753130 has been marked as a duplicate of this bug. ***
Comment 5 Hans-Peter Holler 2012-03-20 18:59:43 UTC
*** Bug 753063 has been marked as a duplicate of this bug. ***
Comment 6 Andreas Jaeger 2012-04-12 07:45:57 UTC
This still happens with Milestone 3. Coolo, how can we get the files on the LiveCDs?
Comment 7 dale ritchey 2012-04-12 15:56:14 UTC
I zypper install grub2 before running the live installer
the live installer then proceeded to install with grub2
the reason grub2 fails is because there is no grub2 on the media
Comment 8 David Young 2012-04-20 11:53:16 UTC

Similar problem with openSUSE-GNOME-LiveCD-Build0318-i686.iso

Kernel image:   /boot/vmlinuz-3.3.0-2-default
Initrd image:   /boot/initrd-3.3.0-2-default
Root device:	/dev/disk/by-id/ata-VBOX_HARDDISK_VB78a5ea7d-a33b37a0-part2 (/dev/sda2) (mounted on / as ext4)
Kernel Modules:	hwmon thermal_sys thermal processor fan rtc-cmos scsi_dh scsi_dh_emc scsi_dh_hp_sw scsi_dh_alua scsi_dh_rdac libata pata_ninja32 pata_it821x pdc_adma sata_via pata_hpt366 pata_marvell pata_netcell pata_sl82c105 sata_uli pata_hpt3x3 pata_cs5536 pata_optidma pata_rz1000 sata_mv pata_artop sata_svw pata_sis sata_inic162x pcmcia_core pcmcia pata_pcmcia ata_generic pata_mpiix pata_triflex pata_cs5520 pata_hpt3x2n pata_pdc2027x pata_hpt37x libahci ahci pata_atp867x pata_cmd64x sata_vsc pata_sil680 pata_amd sata_sil pata_cs5535 pata_cmd640 pata_legacy ata_piix sata_sil24 sata_sis pata_acpi pata_sch pata_ns87410 pata_oldpiix pata_rdc pata_efar pata_atiixp pata_sc1200 pata_jmicron pata_cypress pata_isapnp sata_promise pata_it8213 sata_qstor pata_ns87415 sata_sx4 pata_serverworks pata_ali sata_nv pata_pdc202xx_old pata_opti ahci_platform pata_radisys pata_via pata_cs5530 pata_arasan_cf acard-ahci pata_piccolo usb-common usbcore ohci-hcd uhci-hcd ehci-hcd hid usbhid 
Features:       acpi block usb resume.userspace resume.kernel
Bootsplash:	openSUSE (1024x768)
Perl-Bootloader: 2012-04-20 18:55:11 ERROR: Core::ReadFiles: Failed to open /boot/grub2/device.map
Perl-Bootloader: 2012-04-20 18:55:12 ERROR: Command '/usr/sbin/grub2-mkconfig -o /boot/grub2/grub.cfg >/var/log/YaST2/y2log_bootloader 2>&1' failed with code 32512 and output: sh: /usr/sbin/grub2-mkconfig: No such file or directory

There was an error generating the initrd (1)


sh: /usr/sbin/grub2-install: No such file or directory
Comment 9 Glenn Doig 2012-04-23 11:20:09 UTC
Hello,
I have a similar problem as well. with grub/grub2 not installed.
- Booted with x86-64 -12.2 milestone3 DVD
- installed default kde setup
- formatted / partition 
- software installed
- on next attempted boot, failed.
I suspect boot loader fail , missing grub or grub2 files.

commands I need to run to repair boot partition once grub or grub2 installed {not yet done}.
 
# grub
>root (hd0,2) - filesystem is type reiserfs, partition type 0x83
>setup (hd0)

> setup (hd0)
 Checking if "/boot/grub/stage1" exists... no
 Checking if "/grub/stage1" exists... no

Error 15: File not found

Question.
How can I install grub or grub2 on / partition ?, with 12.2 milestone3 live cd  or should I wait till 12.2 milestone 4?

Thanks Glenn
Comment 10 Larry Finger 2012-04-23 14:31:00 UTC
Use solution #2 from the "Most Annoying Bugs" page (http://en.opensuse.org/openSUSE:Most_annoying_bugs_12.2_dev), which tells you to boot the Live system, zypper in GRUB2, and then install.
Comment 11 Glenn Doig 2012-04-23 15:24:06 UTC
Hello
I found another solution.
It was to change bootloader from grub2 to grub in the bootloader selection option screen on milestone3 DVD.
The install completes ok. System boots ok.
I did not have to use a live system cd at all.
Cheers Glenn
Comment 12 Larry Finger 2012-04-23 16:15:57 UTC
That was option 1 on the "Most Annoying Bugs" list.
Comment 13 Graham Davis 2012-06-01 15:28:59 UTC
This bug is now also infecting Beta 1 release of DVD (x64) - build 0398. The equivalent KDE LiveCD is not affected.

Near the end of the first stage of the installation process, an error window opened with "an error occurred during initrd creation" followed by another window with "error occurred while installing GRUB2." In the messages contained in the first window was "failed to open /boot/grub2/device.map" and, in the second window, "sh: /usr/sbin/grub2-mkconfig: no such file or directory."
Comment 14 Michael Chang 2012-06-01 15:51:25 UTC
Granham.

Is fallback to use Grub1 work? Because there's another bug report and I doubt not only Grub2 package were missing?

See bnc#765003

To be honest, if I remember correctly, there should be no big commits to grub2 or yast2/perl bootloader in beta image (the console support patches are still on it's way to obs) . So I'm surprised by the regression (and scared, too ...) :(
Comment 15 Graham Davis 2012-06-01 17:41:03 UTC
Michael, on the machine I was experimenting on, I can only use GRUB2 or ELILO (thanks, Microsoft) so GRUB1 wasn't an option. 

On an older machine, I tried GRUB1 and got past the first reboot successfully but encountered other problems ("no network" warning and no KDE GUI - I'll have another look at those later). On both machines, I've successfully installed Beta1 with GRUB2 by using the KDE LiveCD.
Comment 16 Graham Davis 2012-06-01 19:41:03 UTC
Following a suggestion on newsgroup prerelease-beta, I tried installing with "install from images" disabled. Was able to complete installation successfully, boot via GRUB2 and login after a minor hiccup (had to reset session to KDE plasma).
Comment 17 Bernhard Wiedemann 2012-06-19 05:27:10 UTC
original bug was long fixed.

"install from images" bug was fixed, too after Beta1.
So we should close this bug.