Bug 735824 - Ghostscript: Package clean-up and upgrade to latest stable release
Ghostscript: Package clean-up and upgrade to latest stable release
Status: RESOLVED FIXED
: 750679 758056 (view as bug list)
Classification: openSUSE
Product: openSUSE 12.2
Classification: openSUSE
Component: Printing
Factory
All openSUSE 12.2
: P3 - Medium : Major (vote)
: Factory
Assigned To: Johannes Meixner
Johannes Meixner
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-09 08:57 UTC by Johannes Meixner
Modified: 2012-04-25 10:28 UTC (History)
9 users (show)

See Also:
Found By: Development
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
scan of the yast printer test page (445.98 KB, image/jpeg)
2011-12-13 21:17 UTC, Juergen Weigert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Meixner 2011-12-09 08:57:38 UTC
As soon as possible (but for openSUSE 12.1 I had no time)
I like to do with Ghostscript the same as I did in the past
with sane-backends, cups, gutenprint, cups-drivers,...:

  Drop all our own patches to enforce a
  reset to 100% compliance with upstream!

Plus a version upgrade to the newest stable version
which is available at Ghostscript upstream at that time.

See
https://bugzilla.novell.com/show_bug.cgi?id=724383#c2
https://bugzilla.novell.com/show_bug.cgi?id=728215#c6

FYI regarding gutenprint and cups-drivers:
https://bugzilla.novell.com/show_bug.cgi?id=514994#c7
https://bugzilla.novell.com/show_bug.cgi?id=641704#c0
Comment 1 Juergen Weigert 2011-12-13 14:40:51 UTC
See OBS home:jsmeix ghostscript for a starting point
Comment 2 Juergen Weigert 2011-12-13 21:09:54 UTC
gs-9.04 from home:jsmeix/ghostscript fixes my barcode printing issue, where pure black was sometimes rendered white.

but I have two other issues with this version:
 - firefox/okular prints are always grayscale, even if color is selected.
 - the yast printer test page is completly black, with some odd stripes.
 - a2ps output is completely black.
Comment 3 Juergen Weigert 2011-12-13 21:17:01 UTC
Created attachment 467304 [details]
scan of the yast printer test page
Comment 4 Johannes Meixner 2011-12-14 08:15:05 UTC
Juergen,
are the "other issues with this version" in comment #2
new issues (i.e. regressions compared to Ghostscript 9.00)?
Comment 5 Juergen Weigert 2011-12-14 09:02:06 UTC
Yes, regressions. color worked, a2ps & yast test page were fine with 9.00
Comment 6 Juergen Weigert 2011-12-14 09:17:51 UTC
echo >> /etc/cups/cupsd.conf RIPCache 128m
rccups restart
from bug 628233 has no effect.
Comment 8 Johannes Meixner 2012-01-11 10:57:36 UTC
Stefan Brüns,
I accepted your submitrequest 99379 "Update to GS 9.04"
for Printing:ghostscript/ghostscript-library
Many Thanks for your valuable contribution!

Now Ghostscript version 9.04 with all our patches and changes
is available in the openSUSE build service development project
"Printing:ghostscript".

I appreciate it if anyone likes to test Ghostscript 9.04
from "Printing:ghostscript" but note that packages
in development projects are only for testing, without
any guarantee or warranty, and without any support.
As an extreme example, this means if your complete
computer center crashes because of those packages,
it is only your problem.
On the other hand this does not mean that those packages
are known to be terrible broken but they are not thoroughly
tested so that any unexpected issue can happen.
Comment 9 Johannes Meixner 2012-01-11 11:10:03 UTC
FYI:
After an upgrade to Ghostscript 9.04 from "Printing:ghostscript"
one needs to do "rccups restart" so that the cupsd re-reads its
filtering rules because pdftoraster and pstoraster have been
replaced by gstoraster (accordingly /etc/cups/pdftoraster.convs and
/etc/cups/pstoraster.convs are replaced by /etc/cups/gstoraster.convs).
Comment 10 Juergen Weigert 2012-01-11 12:09:41 UTC
(In reply to comment #8)
> I appreciate it if anyone likes to test Ghostscript 9.04
> from "Printing:ghostscript" 

Printing:ghostscript currently has no packages for 12.1, could you add the target, please?
Comment 11 Johannes Meixner 2012-01-11 14:14:25 UTC
See
https://features.opensuse.org/313057
"Automatically enable new version branch as target"

Now Printing:ghostscript has packages also for openSUSE_12.1
and even for openSUSE_Tumbleweed and SLE_11_SP1.
Comment 12 Reimar Imhof 2012-01-11 21:56:23 UTC
Here I've got the same issues as described by Juergen Weigert in comment #2:
- yast test page prints black (like scan in comment #3)
- prints from libre office / okular / acroread are grayscale -> color is missing.
- didn't try a2ps
- tried cups test page -> printed black page
These are all regressions compared to gs 9.00.

Problems solved compared to gs 9.00:
- okular: Printing pdf including true type fonts (here MS Arial) now prints pdf including the ttf texts. With 9.00 the ttf text was missing.
- LibreOffice: Printing spread sheet with ttf text now prints that text.
- But - as mentioned above - print is grayscale

printer is epson stylus using "printer-escpr 1.0.3-1lsb3.2 (Seiko Epson Corporation LSB 3.2)" - driver (gpl).
system is openSuse 11.4 64 bit with ghostscript packages from http://download.opensuse.org/repositories/Printing:/ghostscript/openSUSE_11.4

Hope this helps
Comment 13 Johannes Meixner 2012-01-12 08:33:55 UTC
Reimar Imhof,
many thanks for testing it!

The YaST test page /usr/share/YaST2/data/testprint.ps
is the CUPS 1.3 test page. It is plain simple PostScript.

Juergen Weigert tested the package named "ghostscript"
from "home:jsmeix" which is plain upstream Ghostscript 9.04
without any patches or changes.

This shows that those regressions are neither caused nor fixed
by our patches but are new bugs in upstream Ghostscript 9.04.


Therefore I would really appreciate it if both of you
Reimar and Juergen coud report those issues
directly to upstream Ghostscript via

http://bugs.ghostscript.com/

Please attach the YaST test page and also the Ghostscript
command line which is run by the CUPS filtering system
so that the Ghostscript upstream authors have a chance
to reproduce the issue.

You find the Ghostscript command line which is run by
the CUPS filtering system in the CUPS debug messages, see
"Get CUPS debug messages if it does not work" in
http://en.opensuse.org/SDB:CUPS_in_a_Nutshell

When you have "LogLevel debug" in /etc/cups/cupsd.conf
you can get the Ghostscript command lines using
# grep 'sDEVICE=' /var/log/cups/error_log

Many thanks in advance for your contribution!


It seems it depends on the Ghostscript output device
whether or not those regressions happen.

For example for me the YaST test page prints well on
my HP JaserJet 1220 b/w PostScript/PCL printer using
the Ghostscript output device "ljet4" and
the HPIJS driver wich uses the Ghostscript output device "ijs" and
the HPCUPS and Gutenprint drivers wich use the Ghostscript
output device "cups".

The interesting point is that for me it works even with the
Ghostscript output device "cups" but not for Reimar and Juergen
who also use the output device "cups" for their printer drivers
so that those regressions depend on something else.

I see wrong colors in the "Color Wheel" in the YaST test page
when I show it via the various Ghostscript output devices "x11..." using
--------------------------------------------------------------------------
for d in x11 x11alpha x11cmyk x11cmyk2 x11cmyk4 x11cmyk8 \
         x11gray2 x11gray4 x11mono ; \
do echo $d ; \
   gs -sDEVICE=$d -r50x50 \
      -dBATCH /usr/share/YaST2/data/testprint.ps &>/dev/null ; \
done
--------------------------------------------------------------------------
(press [Enter] to go to the next one)

I see wrong colors in the "Color Wheel" for the Ghostscript
output devices "x11cmyk2" and "x11cmyk4".

Therefore it seems those regressions depend on the color model
which is used by the particular Ghostscript output device.

I am not at all an expert in this area so that I cannot debug
such issues in Ghostscript.
Comment 14 Reimar Imhof 2012-01-14 22:17:31 UTC
At http://bugs.ghostscript.com/show_bug.cgi?id=691922 I've seen something quite similar. That's why I tried to take latest cups/gdevcups.c from ghostscript git repo. With that file the problems I described in comment #12 are gone. But now there is a new one: After system start a first print just prints the beginning of a page. When printing a document with 2 pages I get two pages with just the beginnings.
I don't know, if I just broke something by taking the youngest gdevcups.c but keep everything else like I found it in http://download.opensuse.org/repositories/Printing:/ghostscript/openSUSE_11.4

I tried to integrate a younger complete snapshot into the ghostscript-library.rpm but didn't have any success (compile problems).
Perhaps you - Johannes - could build a new 9.0.5-pre-snapshot?
Comment 15 Reimar Imhof 2012-01-16 21:30:31 UTC
I gave it another test with the gutenprint driver.
Same result: yast test page starts printing and I get the first 10 cm. Then it stops. cups error-log says, it stopped without errors. (Could you turn that into a joke - I'd like to laugh about it...)
Same result with an totally different pdf file: I get the first 10 cm. That's it.
So it doesn't depend on the original epson driver.
I did not try to understand all the changes on the cups/gdevcups.c file. So I've got no idea which changes brake gs printing.
Comment 16 Johannes Meixner 2012-01-17 08:54:05 UTC
I am afraid I am not at all an expert in this area
so that I cannot help with such issues in Ghostscript.

Reimar Imhof,
to make sure that it is not caused by one of our many patches
in our package "ghostscript-library" you may test with my
test package "ghostscript" from "home:jsmeix" which is
plain upstream Ghostscript without any patch.

If it still happens with plain upstream Ghostscript it is a bug
in upstream Ghostscript and then please file a bug report at
upstream Ghostscript via http://bugs.ghostscript.com/
so that there is a direct contact between you who has the issue
and who can tell about it and the Ghostscript upstream authors
who have the expert knowledge to fix such issues.

For my HP JaserJet 1220 b/w PostScript/PCL printer
both "ghostscript-library" and "ghostscript" print well
using the Ghostscript output device "ljet4" and
the HPIJS driver wich uses the Ghostscript output device "ijs" and
the HPCUPS and Gutenprint drivers wich use the Ghostscript
output device "cups".

When installing "ghostscript" from "home:jsmeix"
there is currently a RPM conflict with "ghostscript-mini"
which you can ignore e.g. via:
-------------------------------------------------------------------------
# rpm -e --nodeps ghostscript-library
# rpm -Uhv --nodeps ghostscript-9.04-1.1.*.rpm
-------------------------------------------------------------------------

Please read
https://build.opensuse.org/project/show?project=home%3Ajsmeix
Comment 17 Reimar Imhof 2012-01-21 21:40:28 UTC
Now I gave your ghostscript package a try. First I tried to rebuild the package "rpmbuild -ba ghostscript.spec"
Strange: Even with that thing where I didn't apply any changes I get the print problems (comment #14 and comment #15).
So I think it's a problem with local building of the ghostscript packages (ghostscript or ghostscript-library).
Perhaps you could build the packages with the latest cups/gdevcups.c?
Comment 18 Reimar Imhof 2012-01-21 23:01:24 UTC
Now I gave it a second try - and the obs a first one... First test is looking good. When I find some time I'll try your ghostscript-library package
Comment 19 Reimar Imhof 2012-01-22 20:34:33 UTC
On https://build.opensuse.org/project/show?project=home%3Aquantentunnel you can find both ghostscript and ghostscript-library including the patched cups/gdevcups.c. At the moment I can't find any problems with these versions.
Do you plan to include the updated cups/gdevcups.c into your build?
Comment 20 Johannes Meixner 2012-01-24 09:32:55 UTC
I appreciate very much all your various testing and contributions!

FYI, see
https://bugzilla.novell.com/show_bug.cgi?id=728215#c12

The newest cups/gdevcups.c will be automatically included
when we upgrade to the newest Ghostscript stable release.

Reimar Imhof,
if you like to have it included right now, feel free
to file submitrequests with your updated cups/gdevcups.c
to "ghostscript" from "home:jsmeix"
and "ghostscript-library" from "Printing:ghostscript"
Comment 21 Johannes Meixner 2012-02-03 09:40:34 UTC
Now there is an upstream bug report:
http://bugs.ghostscript.com/show_bug.cgi?id=692831

Mark Fairbairn,
many thanks for filing it!
Comment 22 Mark Fairbairn 2012-02-05 12:28:44 UTC
Johannes Meixner
Any ideas re comment #14

http://bugs.ghostscript.com/show_bug.cgi?id=692831#c14
Comment 23 Mark Fairbairn 2012-02-06 02:37:35 UTC
and also

http://bugs.ghostscript.com/show_bug.cgi?id=692831#c18
Comment 24 Johannes Meixner 2012-02-07 08:20:38 UTC
See comment #16:
----------------------------------------------------------------------
to make sure that it is not caused by one of our many patches
in our package "ghostscript-library" you may test with my
test package "ghostscript" from "home:jsmeix" which is
plain upstream Ghostscript without any patch.
----------------------------------------------------------------------

I think the best way is to wait for Ghostscript 9.05

I recommend to continue only with plain upstream Ghostscript,
see comment #0.

I appreciate submitrequests for "ghostscript" from "home:jsmeix".
Comment 25 Johannes Meixner 2012-02-07 08:51:39 UTC
See
https://bugs.launchpad.net/hplip/+bug/924631/comments/10
---------------------------------------------------------------------
This was indeed a Ghostscript problem which is not fixed
in Ghostscript 9.04, but it is fixed in 9.05. 
---------------------------------------------------------------------
Comment 26 Mark Fairbairn 2012-02-07 13:35:02 UTC
"I think the best way is to wait for Ghostscript 9.05"

I agree.
With it "due out this week" how long do you expect before we see it in the build repo or your own repo?
Comment 27 Johannes Meixner 2012-02-07 15:07:21 UTC
As time permits...
Comment 28 Johannes Meixner 2012-02-09 15:05:35 UTC
Plain upstream Ghostscript 9.05 without any patch
is now available for testing (and only for testing)
in my openSUSE build service home project "home:jsmeix"
for various openSUSE and Suse Linux Enterprise versions
(but currently not for openSUSE_Factory)
for 32-bit i586 and 64-bit x86_64 architecture
e.g. via this direct link:
http://download.opensuse.org/repositories/home:/jsmeix/

You need only the package "ghostscript" which replaces
the packages "ghostscript-library" and "ghostscript-x11".
Do not remove installed "ghostscript-fonts-*" packages.

When installing "ghostscript" from "home:jsmeix"
there could be a RPM conflict with "ghostscript-mini"
which you can ignore e.g. via:
-------------------------------------------------------------------------
# rpm -e --nodeps ghostscript-library
# rpm -Uhv --nodeps ghostscript-9.05-*.rpm
-------------------------------------------------------------------------

Please read
https://build.opensuse.org/project/show?project=home%3Ajsmeix

For my good HP JaserJet 1220 b/w PostScript/PCL printer
plain upstream Ghostscript 9.05 print well using
the Ghostscript output device "ljet4" and
the HPIJS driver wich uses the Ghostscript output device "ijs" and
the HPCUPS driver wich use the Ghostscript output device "cups" and
the Gutenprint driver wich use the Ghostscript output device "cups".

For my dumb HP JaserJet 1020 b/w ZjStream printer
plain upstream Ghostscript 9.05 print well using
the HPIJS driver wich uses the Ghostscript output device "ijs" and
the HPCUPS driver wich use the Ghostscript output device "cups".

Many thanks in advance for testing and feedback to what extent
plain upstream Ghostscript 9.05 works for your particular printers!
Comment 29 Mark Fairbairn 2012-02-09 16:15:43 UTC
so far so good with my HP Photosmart B110a
using Ghostscript 9.05 from 
http://download.opensuse.org/repositories/home:/jsmeix/
for the first time since Ghostscript 8.72 I have colour printing with the correct colour balance.

Will report any issues should they arise.
Comment 30 Frank Stulle 2012-02-11 23:56:54 UTC
I run OS 12.1 64bit and have an Epson SX525WD. The problem was that barcodes and similar would not print at all. For a test I downloaded gs9.05 from jsmeix and installed it. A first print failed saying /usr/lib/cups/filter/pstoraster was not found. I set a symlink to gstoraster and now printing seems to work fine. I guess I will leave it like this for the moment and see if any other unexpected problem shows up.

Many thanks for solving this!

Frank
Comment 31 Frank Stulle 2012-02-12 12:16:08 UTC
And another good observation:
Before I had to set RIPCache to a rather high value to get properly printed multipage documents. RIPCache=auto would give pretty disastrous results. Now, RIPCache=auto is fine. So, for me the update has solved both printing problems I had. By the way, one of my test documents that showed them both is just a PDF containing boarding passes for flights; really not a complicated document.

Cheers
Frank
Comment 32 Reimar Imhof 2012-02-12 21:00:26 UTC
Here the new ghostscript is doing what I expect it to do. Best ghostscript that ever came to my openSuse 11.4.

Thanks!
Reimar
Comment 33 Johannes Meixner 2012-02-14 08:36:16 UTC
Regarding comment #30 "symlink to gstoraster":

This is not needed, see comment #9 above
https://bugzilla.novell.com/show_bug.cgi?id=735824#c9


FYI:
Also good news regarding bug #719532 see:
https://bugzilla.novell.com/show_bug.cgi?id=719532#c14
Comment 34 Johannes Meixner 2012-02-14 08:40:46 UTC
After the many good news I think I wait only a little bit
and then I submit the plain upstream Ghostscript 9.05
as package "ghostscript" to the OBS "Printing" project.

But I need to clean up RPM dependencies to make a smooth
upgrade possible (in particular solve the RPM conflict
with "ghostscript-mini"), see comment #28.
Comment 35 Frank Stulle 2012-02-14 09:00:14 UTC
Sorry for missing something that obvious... I will remove the symlink and see what happens.

BTW I remember that I read several forum discussions and I think also some bugs with printing problems (messed up pages (i.e. RIPCache problem), missing black areas and barcodes) which all boiled down to the fact that ghostscript was broken. So, I think your update will not only solve
https://bugzilla.novell.com/show_bug.cgi?id=719532

I will try to find them again and spread the good news.

As far as I understand you, this update will go into factory. But will there also be an official update for os12.1 and earlier that all users get automatically?

Cheers
Frank
Comment 36 Johannes Meixner 2012-02-14 09:53:13 UTC
An official update for openSUSE 12.1 requires
a Ghostscript version upgrade from 9.04 to 9.05
of our current official "ghostscript-library" package in our
current official development project "Printing:ghostscript"
but this package has very many patches which may make it
time consuming and annoying to adapt all those patches to
the new Ghostscript version.

This is what Stefan Brüns did, see comment #8.

Perhaps a version upgrade from 9.04 to 9.05 is easy
for "ghostscript-library" in "Printing:ghostscript"?

Currently (and probably never in the foreseeable future)
I do not have the time to work on overcomplicated packages
like our "ghostscript-library" with its tons of patches.

What is even more important (from my point of view):
Overcomplicated packages with tons of patches are a nightmare
to maintain and I think no volunteer would like do this
so that overcomplicated packages could be a main reason
why there are not more volunteers who contribute to openSUSE
which could be a main handicap for the whole openSUSE project.

In short:
Why wasting our own time with tons of our own patches
when the plain upstream software "just works"?

And if the plain upstream software has issues,
why not fix issues together with upstream
so that all users will get them fixed?
Comment 37 Frank Stulle 2012-02-14 12:24:52 UTC
Oh, I certainly do perfectly agree with you. And I did not mean to adapt the patches. Just to replace the current packages with the new one.
But I see that I implied that all these patches to the old packages would be useless while most certainly there is a good purpose for them. So forget my question.

Cheers
Frank
Comment 38 Johannes Meixner 2012-02-16 08:31:56 UTC
For "ghostscript" in "home:jsmeix" I split those files
which require X11 stuff into a "ghostscript-x11" sub-package
(currently only /usr/lib/ghostscript/9.05/X11.so) so that
the "ghostscript" main-package can be installed without X11
(e.g. needed on server systems which run without X11).

This means:
You need the packages "ghostscript" and "ghostscript-x11"
from "home:jsmeix" which replace the official packages
"ghostscript-library" and "ghostscript-x11", see
https://build.opensuse.org/package/show?package=ghostscript&project=home%3Ajsmeix

Juergen Weigert,
please report if ghostscript 9.05 from "home:jsmeix" sove
the printing regressions which you reported in comment #2
Comment 39 Johannes Meixner 2012-02-24 16:29:24 UTC
Submitted plain upstream Ghostscript 9.05
to the OBS project "Printing" via submitrequest 106825.

See
https://build.opensuse.org/package/show?package=ghostscript&project=Printing
Comment 40 Johannes Meixner 2012-02-28 09:17:46 UTC
The graphviz-plugins package is the only one
which "BuildRequires ghostscript-mini" but
"ghostscript-mini" is now outdated.

Therefore I filed submitreqest 107335
for graphviz-plugins in "graphics"
so that graphviz-plugins "BuildRequires ghostscript"
which is backward-compatible because ghostscript-library
also provides "ghostscript".
Comment 41 Johannes Meixner 2012-03-02 14:22:17 UTC
Juergen Weigert, a reminder:
Please test Ghostscript 9.05 from "Printing" over the weekend.
Comment 42 Juergen Weigert 2012-03-04 15:43:46 UTC
(In reply to comment #41)
> Juergen Weigert, a reminder:
> Please test Ghostscript 9.05 from "Printing" over the weekend.

ghostscript-9.05-5.1.i586 from
home:jsmeix / openSUSE_12.1

passed all my tests flawlessly today. Johannes, thank you!


* color prints have color
* yast test page is correct
* simple a2ps works as expected
* barcodes auf amazon retouren
Comment 43 Johannes Meixner 2012-03-06 08:01:06 UTC
Many thanks for your feedback!


FYI:
Here the next major step that I need to do before I can
submit plain upstream Ghostscript to openSUSE:Factory:

Have one or more new package(s) which contain fonts for Ghostscript.

Some details:

Currently "ghostscript-library.spec" contains those font sources:

ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/GPL/current/ghostscript-fonts-std-8.11.tar.bz2

ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/fonts/ghostscript-fonts-other-6.0.tar.bz2

ftp://ftp.kapella.gpi.ru/pub/cyrillic/psfonts/gs_rusfonts.tar.bz2

I like to have separated packages for separated sources - at least
separated packages for sources which come from different organizations
(in particular to be more safe against RPM "License" confusion).

I like to avoid main package names which look like sub-packages of
the "ghostscript" package - i.e. I will not use "ghostscript-fonts"
as the name of a main package (in particular to be more safe
against package name confusion when maintenance updates are
managed by our maintenance team).

I need to add appropriate RPM requirements/recommends regarding
the font packages to the "ghostscript" package.
Comment 44 Johannes Meixner 2012-03-30 12:25:48 UTC
*** Bug 750679 has been marked as a duplicate of this bug. ***
Comment 45 Johannes Meixner 2012-03-30 12:32:35 UTC
FYI:
Building xen in Virtualization fails at "ps2pdf xenapi.ps xenapi.pdf"
with ghostscript-library 9.04 but works (at least for me)
with plain upstream Ghostscript 9.05 from "Printing", see
https://bugzilla.novell.com/show_bug.cgi?id=750679#c18
Comment 46 Johannes Meixner 2012-03-30 12:57:41 UTC
Regarding fonts for Ghostscript (see comment #43):

In contrast to what I wrote in comment #43 I decided
to have in "Printing" a new package called "ghostscript-fonts"
to have its name in compliance with upstream Ghostscript, see
/usr/share/ghostscript/9.05/doc/Fonts.htm
---------------------------------------------------------------------
3 Ghostscript's free fonts
...
Unix  ghostscript-fonts-std-#.##.tar.gz    Basic 
      ghostscript-fonts-other-#.##.tar.gz  Miscellaneous
---------------------------------------------------------------------

Accordingly Ghostscript's free fonts packages should be called
"ghostscript-fonts-std" and "ghostscript-fonts-other"
(i.e. no name change in the openSUSE ghostscript font packages).

Because both sources are provided by Ghostscript upstream
I have them both as sub-packages of the new main-package
called "ghostscript-fonts" in "Printing".


Again I ask all who like to contribute to openSUSE
to test the new Ghostscript fonts packages in "Printing".

This means to remove the old installed "ghostscript-fonts-std"
and "ghostscript-fonts-other" packages and replace them with the
new "ghostscript-fonts-std" and "ghostscript-fonts-other" packages
from "Printing".

I appreciate any feedback.

Because I am not at all a font expert I appreciate in particular
explicit feedback when the new "ghostscript-fonts-std"
and "ghostscript-fonts-other" packages from "Printing"
also work o.k. for you (I didn't detect an issue but this
does not mean much because I am not at all a font expert).

What I did to test whether or not it seems to work o.k. is
according to "5 How Ghostscript gets fonts when it runs"
in /usr/share/ghostscript/9.05/doc/Fonts.htm
that I run those two commands:

for f in $( grep -o '^/[-,[:alnum:]]*' \
 /usr/share/ghostscript/9.05/Resource/Init/Fontmap.GS ) ; \
 do echo "($f\n) print $f findfont 10 scalefont setfont \
          10 100 moveto ($f) show showpage" ; \
 done | gs -dNOPAUSE &>/tmp/ghostscript-simple-testfonts.out

for f in $( grep -o '^/[-,[:alnum:]]*' \
 /usr/share/ghostscript/9.05/Resource/Init/Fontmap.GS ) ; \
 do echo "($f\n) print $f DoFont" ; \
 done | gs -dNOPAUSE /usr/share/ghostscript/9.05/lib/prfont.ps - \
           &>/tmp/ghostscript-full-testfonts.out

For me there have been no errors - i.e. all fonts were found
or at least replaced in a way which looks reasonable for me.


Currently I have no package for
ftp://ftp.kapella.gpi.ru/pub/cyrillic/psfonts/gs_rusfonts.tar.bz2
so that users who need those fonts must keep their
existing "ghostscript-fonts-rus" package installed.
Comment 47 Bernhard Wiedemann 2012-04-03 13:00:14 UTC
This is an autogenerated message for OBS integration:
This bug (735824) was mentioned in
https://build.opensuse.org/request/show/112368 Factory / ghostscript
https://build.opensuse.org/request/show/112369 Factory / ghostscript-fonts
Comment 48 Johannes Meixner 2012-04-03 13:00:49 UTC
Only for my own information:

$ osc my sr

112368  State:new    By:jsmeix       When:2012-04-03T14:52:54
        submit:      Printing/ghostscript  ->  openSUSE:Factory:Staging
        Descr: Plain upstream Ghostscript 9.05 (bnc#735824).
               For now submitted to openSUSE:Factory:Staging for testing
               if openSUSE_Factory packages still build with it.
               It contains additional ghostscript-mini.spec which
               requires a link package ghostscript-mini which points to its
               parent package ghostscript in openSUSE:Factory:Staging.
               For most packages which need to only run Ghostscript
               during build, a single BuildRequires ghostscript-mini
               should be sufficient. For most packages which need
               Ghostscript development files to build, a single
               BuildRequires ghostscript-mini-devel should be sufficient.
               The openSUSE:Factory project config contains conflicts
               regarding ghostscript-mini which are no longer needed
               and let installing the build system fail so that those
               conflicts should be either removed from the project config
               or invalidated as in the project config of the Printing
               project

112369  State:new    By:jsmeix       When:2012-04-03T14:55:15
        submit:      Printing/ghostscript-fonts  -> openSUSE:Factory:Staging
        Descr: Ghostscript free fonts for plain upstream Ghostscript 9.05
               (bnc#735824). For now submitted to openSUSE:Factory:Staging
               for testing if openSUSE_Factory packages still build with it.
               This submitrequest should be accepted or declined together
               with submitrequest 112368.
Comment 49 Johannes Meixner 2012-04-05 14:23:16 UTC
Only for my own information:

$ osc my sr
112711  State:new    By:jsmeix       When:2012-04-05T16:20:44
        submit:      Printing/ghostscript  -> openSUSE:Factory:Staging
        Descr: Removed not needed BuildRequires for docbook-toys in
               plain upstream Ghostscript 9.05 (bnc#735824).
               docbook-toys pulls in packages like texlive-bin-jadetex
               and texlive-jadetex so that witout docbook-toys it should
               avoid the current unresolvable: nothing provides
               ghostscript_x11 needed by texlive (currently only
               for x86_64 where a rebuild was triggered)
Comment 50 Bernhard Wiedemann 2012-04-05 15:00:10 UTC
This is an autogenerated message for OBS integration:
This bug (735824) was mentioned in
https://build.opensuse.org/request/show/112711 Factory / ghostscript
Comment 51 Johannes Meixner 2012-04-18 13:41:30 UTC
Only for my own information:

Submitted to openSUSE:Factory via:

Request: #114410
  submit:       Printing/ghostscript  -> openSUSE:Factory

Request: #114412
  submit:       Printing/ghostscript-fonts  -> openSUSE:Factory
Comment 52 Johannes Meixner 2012-04-18 13:52:22 UTC
Only for my own information:

Request: #114415
  delete:       openSUSE:Factory/ghostscript-library
Message:
Delete ghostscript-library from openSUSE:Factory (related to bnc#735824).
This deleterequest should be accepted or declined together with
submitrequest 114410 and submitrequest 114412. Furthermore when
submitrequest 114410 is accepted, the ghostscript-mini link package
in openSUSE:Factory must be changed to point to no longer to
ghostscript-library but to the new package ghostscript. The new
package ghostscript Provides and Obsoletes ghostscript-library.
Comment 53 Bernhard Wiedemann 2012-04-18 14:00:17 UTC
This is an autogenerated message for OBS integration:
This bug (735824) was mentioned in
https://build.opensuse.org/request/show/114410 Factory / ghostscript
https://build.opensuse.org/request/show/114411 Factory / ghostscript-fonts
https://build.opensuse.org/request/show/114412 Factory / ghostscript-fonts
Comment 54 Johannes Meixner 2012-04-18 15:11:17 UTC
Regarding comment #46
"no package for
 ftp://ftp.kapella.gpi.ru/pub/cyrillic/psfonts/gs_rusfonts.tar.bz2":

- This ftp server is no longer freely accessible
  (login required and logging in as anonymous fails).

- Our current gs_rusfonts.tar.bz2 sources in ghostscript-library in
  Printing:ghostscript does not contain any hint about the license
  of the files therein (and I do not understand Russian if there was
  something in its docs/rusps.txt source file).

- In the ghostscript-9.05 sources "grep -i 'rusfonts'" does not find
  anything, in particular /usr/share/ghostscript/9.05/doc/Fonts.htm
  does not mention it.

- Googling for "gs_rusfonts -opensuse" does not show any URL
  for a current upstream location.

Therefore (at least for now) I can no longer package gs_rusfonts
because I totally fail to find out what its license is, see
https://build.opensuse.org/project/show?project=Printing
-------------------------------------------------------------------
Of course only really free software can be
accepted in the "Printing" project.
...
We will not risk any legal issue for openSUSE
and its users and contributors when software where
the legal state is not clear would be accepted. 
-------------------------------------------------------------------

I would appreciate any legally valid information regarding
the license of gs_rusfonts which would enable me to provide
it as free software for openSUSE.
Comment 55 James Ogley 2012-04-19 15:37:38 UTC
*** Bug 758056 has been marked as a duplicate of this bug. ***
Comment 56 Johannes Meixner 2012-04-25 10:28:07 UTC
Request: #114410
  submit:       Printing/ghostscript  -> openSUSE:Factory
Request: #114412
  submit:       Printing/ghostscript-fonts  -> openSUSE:Factory
Request: #114415
  delete:       openSUSE:Factory/ghostscript-library

Those requests have been accepted so that there is now only
Plain upstream Ghostscript plus Ghostscript's free fonts
in openSUSE:Factory.

Accordingly I close the issue as "FIXED".


FYI:

Regardless whether or not the issue is closed as FIXED
does not hinder us to continue here (but it is no longer
seen as an open issue in openSUSE).

I.e. please continue to provide feedback here in case
of problems with plain upstream Ghostscript.