Bug 731187 - [Fix_Is_Ready:12.1] korganizer month view fails to show events starting previous month
[Fix_Is_Ready:12.1] korganizer month view fails to show events starting previ...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE 12.1
Classification: openSUSE
Component: KDE4 Applications
Final
64bit SUSE Other
: P3 - Medium : Major (vote)
: ---
Assigned To: Will Stephenson
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-17 21:20 UTC by Reimar Imhof
Modified: 2011-12-13 10:09 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
consider event start _and_ end in selection (984 bytes, patch)
2011-11-17 21:25 UTC, Reimar Imhof
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Reimar Imhof 2011-11-17 21:20:57 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0

Regression in korganizer / kontact 4.7.2 (coming with suse 12.1) compared to
korganizer 4.4.10 (coming with suse 11.4).
If you have an event starting in the middle of a previous month (or earlier),
that event isn't shown in this month in the korganizer month view.
-> see steps to reproduce...

Reproducible: Always

Steps to Reproduce:
1.) start korganizer (for example from openSuse 12.1 kde-live-cd or fresh 12.1
install)
2.) enter event from 2011-10-15 to 2011-11-20.
3.) go to month view
4.) select October 2011 in month view -> you see start of event
5.) select November 2011 in month view
Actual Results:  
The event lasting until 20th of November isn't shown in the month view.

Expected Results:  
The event should be visible.


This was no problem with old korganizer 4.4.10 shipped with suse 11.4.
Funny: Printing seems to be ok.

I filed this bug at bugs.kde.org : https://bugs.kde.org/show_bug.cgi?id=286876
Comment 1 Reimar Imhof 2011-11-17 21:25:08 UTC
Created attachment 462749 [details]
consider event start _and_ end in selection

This patch compares event begin _and_ end with shown month begin/end. For me it
solves the problem - I hope it's helpful!
Comment 2 Will Stephenson 2011-11-21 19:42:22 UTC
Queued in KDE:Distro:Stable for online update, using upstream's version of the fix.

Many thanks for the troubleshooting and patch!
Comment 3 Will Stephenson 2011-12-06 12:18:24 UTC
swamp id requested under 730047
Comment 4 Will Stephenson 2011-12-06 12:33:06 UTC
created request id 95566
Comment 5 Bernhard Wiedemann 2011-12-06 13:01:00 UTC
This is an autogenerated message for OBS integration:
This bug (731187) was mentioned in
https://build.opensuse.org/request/show/95566 12.1 / kdepim4
Comment 6 Benjamin Brunner 2011-12-09 12:30:29 UTC
Started an update for bugs 731268, 7300047, 731187. Thank you and a SWAMPID is not needed for 12.1 updates.
Comment 7 Will Stephenson 2011-12-13 10:09:52 UTC
Marking as resolved: fix submitted, update running.