Bug 730053 - [maintenance] AisleRiot not launching in 12.1
[maintenance] AisleRiot not launching in 12.1
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE 12.1
Classification: openSUSE
Component: GNOME
Final
All SUSE Other
: P5 - None : Major (vote)
: ---
Assigned To: Malcolm Lewis
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-13 15:24 UTC by Malcolm Lewis
Modified: 2011-12-13 11:59 UTC (History)
2 users (show)

See Also:
Found By: Community User
Services Priority:
Business Priority:
Blocker: No
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Malcolm Lewis 2011-11-13 15:24:25 UTC
A Forum user reported the following error when attempting to launch 'sol' from the command line;

http://forums.opensuse.org/showthread.php?t=467061

Throw without catch before boot:
Throw to key misc-error with args ("primitive-load-path" "Unable to find file ~S in load path" ("ice-9/boot-9") #f)Aborting.
Aborted

Another user reported that installing guile solved the issue. This was confirmed by installing/deinstalling guile.

I will assign to myself and branch the maintained version and request an online update for the missing Requires in AisleRiot
Comment 1 Malcolm Lewis 2011-11-13 18:17:27 UTC
Hi
I have branched the maintained version and request an online update for aisleriot;

http://download.opensuse.org/repositories/home:/malcolmlewis:/branches:/OBS_Maintained:/aisleriot/openSUSE_12.1_standard/

Note, not sure about the patchinfo file created, it errored on the web UI.
Comment 2 Vincent Untz 2011-11-15 07:15:47 UTC
(adding [maintenance] to summary to ease tracking on the gnome team side)
Comment 3 Benjamin Brunner 2011-11-16 13:47:46 UTC
Malcolm, could you do a submitrequest to openSUSE:12.1:Update:Test please.
The patchinfo-editor in the build-service is currently broken because of some schema-changes, but should work again soon and you don't have to add one at the moment.
Comment 4 Malcolm Lewis 2011-11-16 14:52:44 UTC
Benjamin, submitrequest 91818 created;

https://build.opensuse.org/request/show/91818
Comment 5 Benjamin Brunner 2011-11-16 15:57:13 UTC
Malcolm, you submitted accidentally the original packages from openSUSE:12.1. I will reject the request and could you submit again with your branched packages please?
Comment 6 Malcolm Lewis 2011-11-16 16:43:43 UTC
Oops, my apologies, new one here;

https://build.opensuse.org/request/show/91856
Comment 7 Benjamin Brunner 2011-11-16 16:55:43 UTC
Unfortunately the new request has the wrong package name (aisleriot.openSUSE_12.1 instead of aisleriot). Please try:
$osc sr aisleriot
in your branched project.
Sorry, I didn't see that you did an mbranch of this package.
Comment 8 Malcolm Lewis 2011-11-16 21:44:52 UTC
Hi
I rebranched so this one should work https://build.opensuse.org/request/show/91888
Comment 9 Jim Sublette 2011-11-19 22:08:16 UTC
When running sol --freecell I am unable to move cards.  I get the following error.
Aisleriot 3.2.1 scheme exception occurred
-- 8< --
Variation: freecell.scm
Scheme error:
	(#f Unbound variable: ~S ($expt) #f)
Scheme tag:
	unbound-variable

Backtrace:
In ice-9/boot-9.scm:
 170: 11 [catch #t #<catch-closure 8bfcc0> ...]
In unknown file:
   ?: 10 [catch-closure]
In ice-9/boot-9.scm:
 170: 9 [catch #t #<catch-closure 69d700> ...]
In unknown file:
   ?: 8 [catch-closure]
In ice-9/eval.scm:
 362: 7 [eval # #]
 350: 6 [eval # #]
 350: 5 [eval # #]
 349: 4 [eval # #]
 356: 3 [eval #<memoized $expt> (11 (#) 12 . #<directory # 818090>)]
In unknown file:
   ?: 2 [memoize-variable-access! #<memoized $expt> #<directory # 818090>]
In ice-9/boot-9.scm:
 115: 1 [#<procedure 6a0be0 at ice-9/boot-9.scm:110:6 (thrown-k . args)> unbound-variable ...]
In unknown file:
   ?: 0 [catch-closure unbound-variable #f "Unbound variable: ~S" ($expt) #f]


Deck State:
	Slot 0
		(Empty)
	Slot 1
		(Empty)
	Slot 2
		(Empty)
	Slot 3
		(Empty)
	Slot 4
		(Empty)
	Slot 5
		(Empty)
	Slot 6
		(Empty)
	Slot 7
		(Empty)
	Slot 8
		(0 7 #t) ,(3 5 #t) ,(3 13 #t)
 ,(0 9 #t) ,(2 2 #t) ,(2 8 #t)
	Slot 9
		(1 12 #t) ,(2 3 #t) ,(2 1 #t)
 ,(0 1 #t) ,(1 2 #t) ,(1 10 #t)
	Slot 10
		(0 5 #t) ,(2 9 #t) ,(2 4 #t)
 ,(3 1 #t) ,(2 6 #t) ,(1 5 #t)
	Slot 11
		(0 13 #t) ,(2 13 #t) ,(0 3 #t)
 ,(3 2 #t) ,(0 8 #t) ,(3 4 #t)
	Slot 12
		(0 12 #t) ,(2 12 #t) ,(0 11 #t)
 ,(0 4 #t) ,(1 11 #t)
	Slot 13
		(1 9 #t) ,(3 12 #t) ,(3 11 #t)
 ,(3 9 #t) ,(2 10 #t) ,(1 6 #t)
	Slot 14
		(3 10 #t) ,(1 8 #t) ,(1 1 #t)
 ,(1 3 #t) ,(3 8 #t) ,(3 3 #t)
	Slot 15
		(0 2 #t) ,(2 5 #t) ,(1 4 #t)
 ,(3 6 #t) ,(0 10 #t) ,(2 11 #t)

-- >8 --
Comment 10 Benjamin Brunner 2011-11-23 17:50:14 UTC
Jim did you already update aisleriot?
I tried it with the new version and it works for me.
Comment 11 Jim Sublette 2011-11-23 18:48:53 UTC
yes i updated it.  All the games seem to work except freecell.  freecell error as soon as I try to move a card.  I updated aisleriot from Malcolm's repo above.
Comment 12 Benjamin Brunner 2011-11-24 14:13:27 UTC
I'll removing needinfo, Malcolm could you have a look at this, please?
Comment 13 Jim Sublette 2011-11-24 15:55:38 UTC
I spoke with the dev on #guile and they looked at the error.  I have tested the change they recommended and it fixes the issue.  Here is the change.

diff freecell.scm /root/freecell.scm 
218c218
<               (expt 2 (max (- (empty-field-number)
---
>               ($expt 2 (max (- (empty-field-number)
linux-4ygk:/usr/share/aisleriot/games #
Comment 14 Jim Sublette 2011-11-24 16:13:09 UTC
I have found the upstream bug and provided them with this info.
https://bugzilla.gnome.org/show_bug.cgi?id=649730
Comment 15 Malcolm Lewis 2011-11-28 18:06:26 UTC
Hi Benjamin
I have branched the current 12.1 version and added the freecell patch and request an online update for aisleriot;

https://build.opensuse.org/package/show?package=aisleriot&project=home%3Amalcolmlewis%3Abranches%3AopenSUSE%3A12.1%3AUpdate
Comment 16 Benjamin Brunner 2011-12-02 11:37:15 UTC
Hi Malcolm, thank you! Could you do a submitrequest to openSUSE:12.1:Update:Test again please? We'll start an update again.
Comment 17 Malcolm Lewis 2011-12-02 13:35:48 UTC
Hi Benjamin
Submitrequest 95043 created.
https://build.opensuse.org/request/show/95043
Comment 18 Benjamin Brunner 2011-12-02 13:57:36 UTC
Started an update. Thanks.
Comment 19 Benjamin Brunner 2011-12-13 11:59:02 UTC
Update already released. Resolved fixed.