Bug 725874 - Installer Fails When Customizing Software Selection
Installer Fails When Customizing Software Selection
Status: RESOLVED DUPLICATE of bug 725722
Classification: openSUSE
Product: openSUSE 12.1
Classification: openSUSE
Component: Installation
RC 1
x86-64 SUSE Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-21 20:15 UTC by Erik Sorenson
Modified: 2011-10-22 19:48 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Sorenson 2011-10-21 20:15:34 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

Using 12.1RC1_64 DVD as installation media, into a real partition (not a VM).  Installer proceeeds well through New >KDE >partitioning (Custom) >Passwords >Installation Summary.  I modified Grub settings to put the loader in "/", then went to add a couple of things to the presented software selection.  Pressing on the Software link on that screen, I got a message in a smallish red-background box saying: "YaST2 - UI Syntax Error - Couldn't load plug-in qt_pkg - Check the log file!"

"Close" is the only option. That results in one-half of the normal (basic, I guess) Software selections screen showing (the left, green side with installation tasks/progress), but the right side is blank, and the mouse cursor is busy.  Unable to select "Back", Cancel" or "OK" options at that point.  Could not select a terminal to look at or save the log file.  Reset of PC only option.

Repeated, using same steps, and it did it again.  Then repeated, but did not choose to change the software selection offered, and the installation proceeded in normal fashion through to conclusion.

=============================================================
Gigabyte Z68X-UD3H-B3, Core i5-2500K, ATI 4770, Hitachi 7K3000 (2tb), 2x4 GB DDR3.  Stock, not overclocked.

Reproducible: Always

Steps to Reproduce:
1.As described in comments ... repeatable.
2.
3.
Actual Results:  
As described above

Expected Results:  
Selecting the link in the installation screen, to modify the proferred software choices, should have resulted in all the software groups, etc unfolding.  Instead, one receives the red Error Box, and then a non-functional, stalled screen.
Comment 1 Lee Matheson 2011-10-22 04:28:25 UTC
I obtained same "YaST2 - UI Syntax Error - Couldn't load plug-in qt_pkg - Check the log file!" on a 12.1 RC1 32 bit DVD as installation media on an athlon-1100 w/2GB RAM and nVidia FX5200.  So this problem also exists on 32-bit media.

Some details : nomodeset boot code was in use. LXDE desktop had been selected, I customized (edited) the partitioning and after that when I chose to customize the software in the "Intallation overview" display I encountered this error. Pressing CLOSE gave the same result as reported by OP.  < CTRL><ALT><F1> had at the bottom of the screen "error : can't create transaction lock on /var/lib/rpm/.rpm.lock (No such file or directory)".

So RC1 would NOT install on this PC with a custom install selected. I did not try to install without a custom software selection.
Comment 2 Peter Lusmore 2011-10-22 08:04:06 UTC
I can also reproduce this - how on earth did it get through QA?
Comment 3 Lee Matheson 2011-10-22 08:47:02 UTC
I can confirm the install proceeds ok on a 12.1 RC1 32-bit (LXDE desktop chosen) from the DVD as long as one does not choose to customize the software install.
Comment 4 Christoph Jüschke 2011-10-22 19:24:54 UTC
I observed the same with 12.1 RC1 32-bit (KDE) DVD
Comment 5 Stephan Kulow 2011-10-22 19:48:26 UTC
guess why I put it in most annoying bugs even before publishing RC1

*** This bug has been marked as a duplicate of bug 725722 ***