Bug 707110 - 12.1 M3 Live KDE CD requires nomodeset to boot
12.1 M3 Live KDE CD requires nomodeset to boot
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE 12.1
Classification: openSUSE
Component: Kernel
Factory
x86-64 Other
: P5 - None : Critical (vote)
: ---
Assigned To: Egbert Eich
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-20 18:54 UTC by Robert Davies
Modified: 2014-08-08 20:25 UTC (History)
10 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
hwinfo & boot log files of an affected machine (116.81 KB, application/zip)
2011-07-20 18:54 UTC, Robert Davies
Details
/var/log/Xorg.0.log from boot of openSUSE 12.1 M5 GNOME LiveCD on GeForce 6150SE nForce 430] (rev a2) (19.66 KB, text/x-log)
2011-09-03 03:11 UTC, M. Edward Ed Borasky
Details
"dmesg" from boot of openSUSE 12.1 M5 GNOME LiveCD on GeForce 6150SE nForce 430] (rev a2) (48.63 KB, text/plain)
2011-09-03 03:18 UTC, M. Edward Ed Borasky
Details
nvidia dmesg 1 (750 bytes, application/octet-stream)
2011-11-10 04:30 UTC, Andrew Walpole
Details
nvidia dmesg 2 (128.23 KB, application/octet-stream)
2011-11-10 04:31 UTC, Andrew Walpole
Details
nvidia dmesg 3 (28.04 KB, application/octet-stream)
2011-11-10 04:32 UTC, Andrew Walpole
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Davies 2011-07-20 18:54:01 UTC
Created attachment 441164 [details]
hwinfo & boot log files of an affected machine

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

First reported on forum in Pre-Release/Beta software section.
Have tested with NVIDIA GeForce 315 not my machine.

The first error I saw was about a memory space conflict, on pci bridge, shortly after kernel starts, very first line of text after loading.

Reproducible: Always

Steps to Reproduce:
1. Boot Live CD with affected Nvidia card
2. Note failure
3. Repeat with nomodeset, have graphics start
Actual Results:  
Booting appears to halt apparently locked up machine, without nomodeset.

Expected Results:  
Expect KMS & Nouveau driver to work and provide KDE desktop

The forum think it's likely problem with Nouveau driver.
I shall try to have those who initially found the problem join this bug, I have reproduced it, but don't normally use nvidia graphics.
Comment 1 Robert Davies 2011-07-20 18:54:52 UTC
Will try and provide more information in better circumstances!
Comment 2 Robert Davies 2011-07-20 20:37:53 UTC
GeForce7300 GT
GeForce 9400 GT
nVidia 7300LE

Are other cards with apparently same issue reported on forum.
Comment 3 Stefan Dirsch 2011-07-20 21:07:52 UTC
KMS issue.
Comment 4 Robert Davies 2011-07-20 21:45:47 UTC
This may be relevant, someone tried with Live KDE CD, failed, but "pointed last weeks Live CD" to DVD says it worked then.

http://forums.opensuse.org/english/get-technical-help-here/pre-release-beta/463068-opensuse-12-1-milestone-3-available-download.html#post2366644
Comment 5 Lee Matheson 2011-07-22 06:27:54 UTC
I have same issue with nouveau driver on nVidia GeForce FX5200 hardware not booting X with 12.1 milestone3 (neither KDE liveCD, nor Gnome liveCD nor basic install of LXDE desktop from DVD after 1st reboot). Both nomodeset (nv driver) and x11failsafe (fbdev driver) work for liveCDs and for hard drive install.  The 'nouveau' driver does work in openSUSE-11.4. I'll try to post more detail on the weekend.
Comment 6 Johannes Obermayr 2011-07-22 19:08:50 UTC
Please try drm-nouveau-kmp-{flavor} from here:
http://download.opensuse.org/repositories/home:/jobermayr/

If it is not fixed please open a bug report on bugs.freedesktop.org against:

Product: xorg
Component: Driver/nouveau
Version: git

Attach then a *full* output of dmesg.
Comment 7 Lee Matheson 2011-07-22 21:26:33 UTC
I have kernel 3.0.0-rc7-2-default installed on my 32-bit openSUSE-12.1 M3 LXDE desktop with a nVidia GeForce FX5200 (comment #5 above).  Per comment#6 I installed drm-nouveau-kmp-default-20110721.2009_k3.0.0_rc7_2-1.1.i586 from http://download.opensuse.org/repositories/home:/jobermayr/ (which gave me a dependency error and I told it to install anyway). 

A reboot resulted in run level 5 failing and being thrown back to run level 3.  That package by itself appears insufficient.

I then also installed xorg-x11-driver-video-nouveau-0.0.16.git20110719.0009-1.2.i586 from the same repository http://download.opensuse.org/repositories/home:/jobermayr/ and a reboot brought me successful to run level-5 (LXDE desktop) with the nouveau driver !  

So it appears Johannes Obermayr that those two packages address the problem with my nVidia FX5200. I need to so some more testing (such as video playback and such).

An output from a terminal in this PC with LXDE destop running:

 # lspci -nnk | grep VGA -A2
01:00.0 VGA compatible controller [0300]: nVidia Corporation NV34 [GeForce FX 5200] [10de:0322] (rev a1)
	Kernel driver in use: nouveau

What output files can I provide ?
Comment 9 Felix Miata 2011-07-24 22:12:48 UTC
(In reply to comment #6)
> Please try drm-nouveau-kmp-{flavor} from here:
> http://download.opensuse.org/repositories/home:/jobermayr/

> If it is not fixed please open a bug report on bugs.freedesktop.org against:

> Product: xorg
> Component: Driver/nouveau
> Version: git

> Attach then a *full* output of dmesg.

I tried the above without success.
https://bugs.freedesktop.org/show_bug.cgi?id=39498 seems to be upstream already
filed some hours ago.
Comment 10 Lee Matheson 2011-07-25 05:47:29 UTC
Felix Miata, note I have the 32-bit 12.1 M3 with nouveau driver working on a GeForce FX5200, but to do so I had to install BOTH drm-nouveau-kmp-default and the update to xorg-x11-driver-video-nouveau . 

Did you do both application driver installs (ie both the KMP package and the driver package) ?  Also, what versions did you try that did not work ?
Comment 11 Felix Miata 2011-07-25 06:29:41 UTC
I didn't read past comment 6, going instead to bugs.freedesktop.org to find out if someone else had filed there about this already, so never saw any suggestion that xorg-x11-driver-video-nouveau from jobermayr was also necessary. I expected anything else from the jobermayr repo that was required would have been pulled in as a dep. Now that I've "downgraded" to xorg-x11-driver-video-nouveau from jobermayr I have X working.
Comment 12 Jogchum Reitsma 2011-07-25 19:16:23 UTC
Opened bug report # 39530 on bugs.freedesktop.org
Comment 13 Jogchum Reitsma 2011-07-26 17:56:47 UTC
Indeed, after update the xorg-x11-driver-video-nouveau package with Johannes', I can boot without nomodeset.
Comment 14 Lee Matheson 2011-07-26 20:49:10 UTC
@ Jogchum , please could you post of your success on bugs.freedesktop.org:  https://bugs.freedesktop.org/show_bug.cgi?id=39530 ? 

I uploaded some of my log files there (boot.log/Xorg.0.log when nouveau failed and those when nouveau worked).

I'm going to move on to some 12.1 M3 LXDE gtk3 testing - if that trashes my system my support on this nouveau bug report will have to stop. :)
Comment 15 Jogchum Reitsma 2011-07-28 19:22:22 UTC
Done!
Comment 16 Duncan Mac-Vicar 2011-08-31 20:26:57 UTC
duplicate of bug 709067?
Comment 17 Felix Miata 2011-08-31 21:16:41 UTC
(In reply to comment #16)
> duplicate of bug 709067?

If there is duplication between the two, 709067, the newer, with less information, applicable to a single NVidia card, with fewer CCs, and a generic assignee, would be a duplicate of this, which affects more cards. To be a duplicate generally requires something be incepted subsequent to something pre-existing like it.
Comment 18 M. Edward Ed Borasky 2011-09-02 16:16:25 UTC
I have


00:0d.0 VGA compatible controller: nVidia Corporation C61 [GeForce 6150SE nForce 430] (rev a2)

nouveau driver has never worked, with or without nomodeset. I am running the proprietery NVidia driver with nomodeset. So I can test stuff - I'll try MS5 out of the box over the weekend and see what happens.
Comment 19 M. Edward Ed Borasky 2011-09-03 03:11:54 UTC
Created attachment 449100 [details]
/var/log/Xorg.0.log from boot of openSUSE 12.1 M5 GNOME LiveCD on GeForce 6150SE nForce 430] (rev a2)
Comment 20 M. Edward Ed Borasky 2011-09-03 03:15:02 UTC
First test - GNOME LiveCD 64 bit openSUSE 12.1

without nomodeset - hangs with a splash screen
with nomodeset - comes up to desktop but is only 1024x768 and is GNOME 3 fallback mode. So this is no worse than 11.4, which requires proprietary NVidia driver to get GNOME 3 non-fallback and larger than 1024x768
Comment 21 M. Edward Ed Borasky 2011-09-03 03:18:52 UTC
Created attachment 449102 [details]
"dmesg" from boot of openSUSE 12.1 M5 GNOME LiveCD on GeForce 6150SE nForce 430] (rev a2) 

Goes with previous comment and /var/log/Xorg.0.log
Comment 22 Bernhard Wiedemann 2011-09-23 10:09:52 UTC
I tried current LiveCD-Build0298 with kernel 3.1-rc6 and newer X
and it just booted on a system with NVidia graphics without nomodeset
with only some display glitches

so this bug should no more affect the upcoming 12.1-Beta
Comment 23 Stefan Dirsch 2011-09-26 10:39:12 UTC
ok. Thanks for the the update!
Comment 24 Andrew Walpole 2011-11-10 03:55:18 UTC
I'm not sure why this bug was closed.

I had the nvidia driver working fine in 12.1/Factory & RC 1, up until the latest 12.1 RC 2 release.

After a clean install of OpenSUSE 12.1 RC 2, the nvidia driver causes GDM to immediately crash again, with various gnome-* segfaults.

I removed x11-xorg-driver-video-nouveau, re-ran mkinitrd (removing nouveau), ensured /etc/X11/xorg.conf configured to "nvidia", with no nouveau loaded on boot.
-- Again GDM segfaulting like it was previously now with 12.1 RC 2.

This problem did appear to be fixed, while it has come back again.
I do not believe it is related to nomodeset/modeset, as that made no different for me.  Running a clean 12.1 RC 2, with nvidia 285 (latest).

As of now, I cannot get X/GDM to load with nvidia.
Possibly related, the nvidia installer finishes but also appears to crash, I do not know if this is related or not.

--------------

I see no NEW bug, and this bug closed.  ??  Should this be a new bug, or this bug reopened?
Comment 25 Andrew Walpole 2011-11-10 03:56:39 UTC
Bug reappearing in 12.1 RC 2.  clean install, properly configured, GNOME/GDM segfaulting once again.
Comment 26 M. Edward Ed Borasky 2011-11-10 04:21:17 UTC
I have NVidia GeForce 6150SE nForce 430, GNOME 3 desktop, NVidia latest proprietary driver working with the RC2 kernel. I do *not* need 'nomodeset' but I *did* need to set KMS_IN_INITRD to 'no' using /etc/sysconfig editor. I had to do some xorg.conf tweaking to get the display size I want, but that's because I have a bizarre monitor and not anything in openSUSE.
Comment 27 Andrew Walpole 2011-11-10 04:30:31 UTC
Created attachment 461313 [details]
nvidia dmesg 1

Tested both 285 and latest 275.36 nvidia drivers.

Howto Reproduce.

install nvidia drivers
change /etc/X11/xorg.conf from "nouveau" to "nvidia"
mkinitrd (removing nouveau, adding nvidia to image)
GNOME/GDM/X fails, with sad computer icon

I attached three dmesg clips.. containing...

[   13.748540] gnome-shell[1248]: segfault at 0 ip           (null) sp 00007fff74f62968 error 14 in gnome-shell[400000+4000]
[   14.781737] gnome-shell[1262]: segfault at 0 ip           (null) sp 00007fffd53b84e8 error 14 in gnome-shell[400000+4000]
Comment 28 Andrew Walpole 2011-11-10 04:31:43 UTC
Created attachment 461314 [details]
nvidia dmesg 2

[  298.001505] gnome-session[1858]: DEBUG(+): GdmSignalHandler: handling signal 15
[  298.001511] gnome-session[1858]: DEBUG(+): GdmSignalHandler: Found 1 callbacks
[  298.001516] gnome-session[1858]: DEBUG(+): GdmSignalHandler: running 15 handler: 0x41d2d0
[  298.001521] gnome-session[1858]: DEBUG(+): Got callback for signal 15
[  298.001526] gnome-session[1858]: DEBUG(+): GsmManager: Logout called
.......
[  319.008990] gnome-shell[2331]: segfault at 0 ip           (null) sp 00007fffadb00a18 error 14 in gnome-shell[400000+4000]
......
Comment 29 Andrew Walpole 2011-11-10 04:32:09 UTC
Created attachment 461315 [details]
nvidia dmesg 3

nvidia dmesg 3
Comment 30 Andrew Walpole 2011-11-10 04:36:09 UTC
Above three dmesg logs, after same crash with or without nomodeset.

Forgot to mention above logs were also with system booted with kernel.... nomodeset

nomodeset seems completely unrelated to crashing.

This bug had been fixed, I was running Factory / RC 1, until updates reproduced the bug.

After a clean install of OpenSUSE 12.1 RC 2.  Bug still present.

Both nvidia driver latest versions 275.36 and 285.09.05
Both with or without nomodeset

Again, both driver NVIDIA installer's finish, but finish with a bunch of garbage and appear to exit uncleanly, may or may not be related, but as I can remember the driver installer was exiting cleanly when they were working in RC 1 / Factory before RC 2.
Comment 31 Andrew Walpole 2011-11-10 04:50:23 UTC
(In reply to comment #26)
> I have NVidia GeForce 6150SE nForce 430, GNOME 3 desktop, NVidia latest
> proprietary driver working with the RC2 kernel. I do *not* need 'nomodeset' but
> I *did* need to set KMS_IN_INITRD to 'no' using /etc/sysconfig editor. I had to
> do some xorg.conf tweaking to get the display size I want, but that's because I
> have a bizarre monitor and not anything in openSUSE.

That fixed it for me.

SOLUTION/FIX:  tested using nvidia driver 275.36, booted with nomodeset (may or may not related)

/etc/sysconfig/kernel
-KMS_IN_INITRD="yes"
+KMS_IN_INITRD="no"

re-built initrd with..
mkinitrd

------------

I believe this bug may be different than previously.
While I had to change KMS_IN_INITRD with Milestone ~1-3,
I did NOT have to disable KMS_IN_INITRD in RC 1.

Disabling KMS_IN_INITRD did appear to fix the issue with X/GNOME/GDM crashing now in OpenSUSE 12.1 RC 2.

Why RC 2 required KMS_IN_INITRD="no", while RC 1 did not (worked fine with KMS_IN_INITRD="yes", is a mystery to me.
Comment 32 Jeff Mahoney 2014-08-08 20:25:27 UTC
This report is against openSUSE 12.1 which is no longer under maintenance. If
you are able to reproduce it with openSUSE 13.1 or openSUSE Factory, please
re-open and reset the the "Product" field to the appropriate release.