Bug 687781 - KDE login broken
KDE login broken
Status: RESOLVED FIXED
: 697382 (view as bug list)
Classification: openSUSE
Product: openSUSE 12.1
Classification: openSUSE
Component: KDE4 Workspace
Factory
All Other
: P5 - None : Major (vote)
: ---
Assigned To: Will Stephenson
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-15 07:14 UTC by Bernhard Wiedemann
Modified: 2011-06-28 06:13 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Wiedemann 2011-04-15 07:14:43 UTC
Factory KDE default install no more does (auto)login
e.g. see
http://openqa.opensuse.org/results/openSUSE-DVD-i586-Build0048

workaround: manually select "KDE Plasma Workspace"

first failing 2011-04-07 16:56
last working 2011-04-07 13:00

here is the log from the commit of package kdebase4-session for openSUSE:Factory
checked in at Thu Apr 7 11:01:26 CEST 2011.

+Sun Mar 13 09:57:47 UTC 2011 - wstephenson@novell.com
+
+- remove stale 'KDE' entry from X sessions list, replace with
+  'KDE Plasma Workspace'


so possibly the DEFAULT_WM value in /etc/sysconfig/windowmanager needs to be adjusted accordingly
Comment 1 Ismail Dönmez 2011-05-30 19:13:00 UTC
Awesome bisection! Should fix before M1.
Comment 2 Bernhard Wiedemann 2011-05-30 20:00:09 UTC
This is an autogenerated message for OBS integration:
This bug (687781) was mentioned in
https://build.opensuse.org/request/show/72179 Factory / aaa_base
Comment 3 Jean-Daniel Dodin 2011-05-31 07:42:28 UTC
none of the 3 kdm options (kde, kde plasma, kde failsafe) work - any gives the same loop version.
if the fix only result is to change /etc/sysconfig/windowmanager, this don't works either (changed by hand, reboot, same problem)

running startx from the root console gives
/usr/bin/startkde: line 368: 2600 Segmentation Fault kwrapper4 ksmserver $KDEWM
Comment 4 Bernhard Wiedemann 2011-05-31 08:57:41 UTC
in http://openqa.opensuse.org/opensuse/video/openSUSE-DVD-x86_64-Build0030.ogv at 0:58 logging into KDE4 works after selecting "KDE Plasma Workspace" as session type

jdd: you should trace+report the segfault as separate problem

e.g. check /var/log/Xorg.0.log
see also
http://en.opensuse.org/openSUSE:Bugreport_KDE
http://en.opensuse.org/openSUSE:Bugreport_X
Comment 5 Jean-Daniel Dodin 2011-05-31 14:23:32 UTC
reported as # 697199
Comment 6 Zhi Juan Jia 2011-06-02 09:02:52 UTC
*** Bug 697382 has been marked as a duplicate of this bug. ***
Comment 7 Bernhard Wiedemann 2011-06-28 06:13:56 UTC
This was seen back working on openQA.o.o on 2011-06-10 with Build0043 
(possibly worked earlier)