Bug 668586 - yast2-network: linux-atm-lib doesn't exist anymore
yast2-network: linux-atm-lib doesn't exist anymore
Status: VERIFIED FIXED
: 679112 695681 (view as bug list)
Classification: openSUSE
Product: openSUSE 11.4
Classification: openSUSE
Component: YaST2
Factory
Other Other
: P2 - High : Major with 10 votes (vote)
: ---
Assigned To: Martin Vidner
Jiri Srain
maint:released:11.4:41776
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-01 11:58 UTC by Ludwig Nussel
Modified: 2021-02-26 20:29 UTC (History)
6 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Patch (562 bytes, text/plain)
2011-03-12 22:53 UTC, Jan Engelhardt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ludwig Nussel 2011-02-01 11:58:24 UTC
the DSL module tries to install linux-atm-lib. linux-atm has other subpackages now. Therefore the DSL configuration cannot be finished.
Comment 2 Martin Vidner 2011-02-15 14:22:08 UTC
OK, it is libatm1.rpm now. Fixed in SVN

Ludwig, do you actually use the package, or can you test it? We don't have ATM here.
Comment 3 Ludwig Nussel 2011-02-15 14:26:57 UTC
I can't test it either. I just found the bug because yast tries to install the package for any kind of dsl connection.
Comment 4 Jan Engelhardt 2011-02-18 20:07:25 UTC
linux-atm-lib/libatm1 is not needed - at least for German DSL. As I see it, only iproute2 uses it when you want to configure the "atm" qdisc (sch_atm.ko kernel module) via tc. Since iproute2 has no BuildRequires on linux-atm-lib, tc's q_atm.so was never compiled for openSUSE, and it seems nobody missed it either.
So might as well drop libatm.
Comment 5 Raul Malea 2011-03-12 21:56:27 UTC
For East European DSL providers (pppoe connections) this files in very neccesary!
Duplicate for https://bugzilla.novell.com/show_bug.cgi?id=679112
Comment 6 Raul Malea 2011-03-12 21:57:45 UTC
Marked duplicate.

*** This bug has been marked as a duplicate of bug 679112 ***
Comment 7 Jan Engelhardt 2011-03-12 22:47:57 UTC
Other way around.
Comment 8 Jan Engelhardt 2011-03-12 22:48:15 UTC
*** Bug 679112 has been marked as a duplicate of this bug. ***
Comment 9 Jan Engelhardt 2011-03-12 22:53:49 UTC
Created attachment 418992 [details]
Patch
Comment 10 Raul Malea 2011-03-13 13:25:37 UTC
Jan, this patch is included in new DVD version by download repository?
However, linux-atm need other subpackages.
Comment 11 Jan Engelhardt 2011-03-13 14:01:57 UTC
This patch is not included anywhere yet.
libatm1 does not need any other packages besides glibc - but that's not the issue here.
Comment 12 Dieter Jurzitza 2011-05-08 18:14:05 UTC
Hi folks,
in one of the related bugs the corresponding entry in DSL.ycp has simply been removed.
Now, is libatm1 mandatory for DSL connection or not? Currently you're in an ugly chicken - egg problem when trying to install from DVD because libatm1 is _not_ part of the DVD distribution (at least not on Saturday, May 7th, 2011.

Could some kind person tell whether it should denote

    return ["smpppd", "ppp",  "pptp", "libatm1"];

in line 571 of /usr/share/YaST2/modules/DSL.ycp

or 

    return ["smpppd", "ppp",  "pptp"];

in this line? In the latter case libatm1 is not neccessary any more - would be good to  know. The current situation leaves you in some kind of chicken - egg position - no internet without libatm1 and no libatm1 without internet .....

Thank you for clarifying, in any kind, a fixed DVD would be a good idea IMHO.

Take care




Dieter Jurzitza
Comment 13 Jan Engelhardt 2011-05-12 12:16:57 UTC
Bug #679112 has provided no evidence that the package is required, so I search for myself.

smpppd: no direct dependency, nor dlopening libatm.

ppp: has a plugin called pppoatm.so, which can optionally use libatm, and if not, uses a shipped implementation. The default for the ppp project is to use the shipped implementation, and openSUSE honors that currently.

pptp: no mention of ATM.

So no, libatm does not seem to be needed.
Comment 14 Ludwig Nussel 2011-06-06 12:52:22 UTC
*** Bug 695681 has been marked as a duplicate of this bug. ***
Comment 15 Ludwig Nussel 2011-06-06 12:54:42 UTC
Can we haven an online update for this please? Surely an online update is kind of weird as you can't run online update without internet connection. People could then at least download the fixed yast2 package manually from another computer or network connection to set up DSL though.
Comment 16 Marcus Meissner 2011-06-06 15:07:33 UTC
I think we can. +1
Comment 17 Swamp Workflow Management 2011-06-07 13:08:15 UTC
The SWAMPID for this issue is 41429.
This issue was rated as low.
Please submit fixed packages until 2011-07-05.
Also create a patchinfo file using this link:
https://swamp.suse.de/webswamp/wf/41429
Comment 18 Christian Dengler 2011-06-07 13:09:48 UTC
+1, update started.
Comment 19 Juan Erbes 2011-06-12 14:09:49 UTC
A temporary solution is to install the package linux-atm-lib (from opensuse
11.3) in console by hand with the command "rpm -i linux-atm-lib*", downloaded
from the opensuse 11.3 repo.
Comment 20 Martin Vidner 2011-06-22 13:06:12 UTC
Update submitted:
https://build.opensuse.org/request/show/74311
Comment 21 Swamp Workflow Management 2011-06-30 13:46:35 UTC
Update released for: yast2-network, yast2-network-devel-doc
Products:
openSUSE 11.4 (i586, x86_64)
Comment 22 Bernhard Wiedemann 2011-07-22 17:01:19 UTC
This is an autogenerated message for OBS integration:
This bug (668586) was mentioned in
https://build.opensuse.org/request/show/76800 Factory / yast2-network