Bug 659153 - Ejecting Optical Drives Causes Immediate Re-Close of Tray and KNotify Crash
Ejecting Optical Drives Causes Immediate Re-Close of Tray and KNotify Crash
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE 12.3
Classification: openSUSE
Component: KDE4 Workspace
Final
PC openSUSE 12.3
: P5 - None : Critical (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on: 725412
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-13 17:27 UTC by Malvern Star
Modified: 2015-11-09 16:31 UTC (History)
8 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Malvern Star 2010-12-13 17:27:02 UTC
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.2.12) Gecko/20101026 SUSE/3.6.12-0.7.1 Firefox/3.6.12

If a mounted volume on optical disc is in the tray, clicking the "eject" icon in Dolphin will cause the optical drive tray to open.  However, it will immediately close again and attempt to re-mount the disc, at which point KNotify will crash.  It may be in some way related to bug 659139 here: https://bugzilla.novell.com/show_bug.cgi?id=659139

Reproducible: Always

Steps to Reproduce:
1. Insert optical disc and wait for mount
2. After disc has been mounted, attempt to eject using the "eject" icon from within Dolphin.
3. The drive will open and immediately close again.
Actual Results:  
Attempting to eject the disc will result in an immediate close of the drive tray and another attempt to re-mount the disc, at which point KNofity will crash.

Expected Results:  
The disc should be ejected and the drive tray should remain open until closed by the user.
Comment 1 Malvern Star 2010-12-30 17:51:23 UTC
Problem no longer appears to be present in 11.4 M5.  Closing as fixed.
Comment 2 Malvern Star 2011-02-01 14:01:39 UTC
This bug has re-appeared in Milestone 6, however Knotify no longer crashes (most likely due to HAL being removed).
Comment 3 Malvern Star 2011-02-20 20:17:25 UTC
This bug is still present in 11.4 RC1.  It is currently IMPOSSIBLE to properly eject optical disks from tray-based drives.

(changed during the 2011-02-20 Open-Bugs-Day about bugs for obsolete versions
of openSUSE)
Comment 4 Malvern Star 2011-02-20 20:31:08 UTC
This bug is still present in 11.4 RC1.  It is currently IMPOSSIBLE to properly eject optical disks from tray-based drives.

(changed during the 2011-02-20 Open-Bugs-Day about bugs for obsolete versions
of openSUSE)
Comment 5 Karsten König 2011-02-21 20:29:31 UTC
https://bugzilla.novell.com/show_bug.cgi?id=659139 is unrelated and was as you correctly noticed due to the dual use of udev and hal backends in solid.

This bug seems to be either in the udisks-daemon or solid, I tried finding other bugreports but it's not much =/

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=577578
hints at udisks-daemon

https://bugs.kde.org/show_bug.cgi?id=264487
hints at solid

http://lists-archives.org/kde/12270-dvd-tray-remain-not-open.html are the same symptoms as you have


I'll assign to Kay in the hope he knows something out of this head and has a good pointer for further search, if not just reassign to kde.
And Malvern please file this at the kde bugtracker to see if they have any ideas.
Comment 6 Kay Sievers 2011-02-22 00:32:19 UTC
Sorry, I don't have any way to reproduce, because I have no devices with a tray left -- only laptop-like optical drives which need a manual close.

I don't know of any recent changes or recent problems in the lower layers like the kernel or udev.

Would be nice, if you can try without a running KDE session, if the same thing happens.
Comment 7 Bernhard Wiedemann 2011-02-22 09:34:06 UTC
finally installed on a machine that can eject -t

eject button works (when CD is unmounted)
"eject" on command-line works fine
eject with nautilus works fine
but dolphin's eject causes tray to close again
It even causes tray-close, if dolphin only views the CD and I do eject with one of the other working methods.

This all points at problems with the upper layers (dophin/solid)
Comment 8 Malvern Star 2011-03-10 01:40:09 UTC
Christian Boltz is claiming that there are problems with unmounting *all* removable devices in this bug report: https://bugzilla.novell.com/show_bug.cgi?id=668039

I don't see how we can ship with this.
Comment 9 Malvern Star 2011-04-03 04:54:54 UTC
I have confirmed that this bug is still present in 11.4 final for machines with 5 1/4" full tray optical drives.  As Bernhard pointed out, pressing the eject button on the drive itself causes no problems, but using Dolphin to eject any inserted disc causes a tray re-close.  I hope this problem is able to be solved, as 11.4 is otherwise a relatively solid release.
Comment 10 Malvern Star 2011-05-03 14:29:51 UTC
Updated the bug status below to reflect its presence in final.  Using the Device Notifier to eject the disc also causes a tray re-close.
Comment 11 Malvern Star 2011-07-20 08:19:30 UTC
I have confirmed the presence of this bug in 12.1M3, except it is now worse.  After the first re-close, it is no longer possible to eject the optical disc, either through Dolphin, KDE's Device Notifier or by pressing the eject button on the drive itself.  Being able to eject optical discs is basic functionality, and should not have been broken in 11.4 final, let alone 12.1M3.

Note that "Platform" does not allow me to select openSUSE 12.1, so I have left it as openSUSE 11.4 for the time being.
Comment 12 Malvern Star 2011-07-20 08:20:34 UTC
I was also not able to set the version that this problem is in the Milestone 3 as this has not been added to Bugzilla yet, nevertheless, this bug was tested against Milestone 3.
Comment 13 Malvern Star 2011-08-21 14:52:09 UTC
I've done some further testing.  The problem appears to be related to Dolphin in some way, but the behaviour is inconsistent.  Trying to eject a disk using either device notifier or Dolphin causes a tray reclose.  Trying to eject the disk using the eject button on the drive fails to open the tray.  

I was however, also able to get the machine into a state where the output of the command "mount" still showed the optical disk as mounted, and neither Dolphin, Device Notifier or the Eject Button on the drive itself were able to persuade the tray to open at all.
Comment 14 Malvern Star 2011-08-21 14:54:32 UTC
Running the command "eject" from the command line produced the message that it "could not find or open device for: /dev/cdrom", however, the command "eject /dev/sr0" finally opened the tray.
Comment 15 Malvern Star 2011-09-15 22:41:57 UTC
This bug is still present in 12.1 Milestone 5.  Surely SuSE cannot ship yet another release with this bug...
Comment 16 Jean-Daniel Dodin 2011-10-02 14:27:03 UTC
happen very often, included in my *home desktop dvd recorder* (not a PC)

so I dont nkow is we can do something, I suspect a faulty hardware driver
Comment 17 Malvern Star 2011-10-02 16:56:55 UTC
Excuse me, but are you kidding? I can reproduce this issue on every machine I install openSuSE 12.1 Milestone 5, and openSuSE 11.4 Final on.  This is not simply a case of "faulty hardware".
Comment 18 Jean-Daniel Dodin 2011-10-02 17:03:27 UTC
no, but I can reproduce it on nearly any hardware I have here, being a PC or not (two desktop dvd readers included), so I don't know if there is anything that can be fixed (would be nice to have) - I'm still holding the device by hand.
Comment 19 Malvern Star 2011-10-08 09:20:54 UTC
As expected, this problem persists in 12.1 Beta1.  Surely this deserves a fix prior to release?!
Comment 20 Ismail Dönmez 2011-10-20 09:12:42 UTC
Confirming with latest Factory ~ 12.1 rc1
Comment 21 Ismail Dönmez 2011-10-20 09:28:14 UTC
Workaround for now is,

sudo sysctl dev.cdrom.autoclose=0
Comment 22 Malvern Star 2011-10-20 19:59:09 UTC
Thanks Ismail.  Is there any reason this setting should not be the default?  As in, does it result in any other kind of unexpected behaviour?
Comment 23 Ismail Dönmez 2011-10-20 20:06:35 UTC
Fix is simple but we are blocked by bug #725412 atm :(
Comment 24 Malvern Star 2011-10-20 20:08:50 UTC
Thanks for your prompt response and hard work!  Looking forward to seeing the matter fixed before release.
Comment 25 Malvern Star 2011-10-26 01:22:29 UTC
Bug is still present in RC1, though I understand it cannot be fixed until #725412 is sorted.
Comment 26 Dr. Werner Fink 2011-10-28 07:59:58 UTC
(In reply to comment #25)

Why?
Comment 27 Ismail Dönmez 2011-10-28 08:06:01 UTC
(In reply to comment #26)
> (In reply to comment #25)
> 
> Why?

Because the fix is https://build.opensuse.org/request/show/89545 which won't work until we fix bug #725412
Comment 28 Bernhard Wiedemann 2011-11-02 17:00:08 UTC
This is an autogenerated message for OBS integration:
This bug (659153) was mentioned in
https://build.opensuse.org/request/show/89958 Factory / procps
Comment 29 Malvern Star 2011-11-07 07:09:51 UTC
Just to provide a necessary update, this bug is still present in 12.1 RC2.  Hoping to get a fix by final.
Comment 30 Malvern Star 2011-11-16 16:18:59 UTC
Just updating this bug for 12.1 Final.  It is of course still present, however for some reason, using Dolphin still causes a "reclose", but using the device manager in the system tray simply refuses to eject the disc.
Comment 31 Malvern Star 2012-03-26 14:34:49 UTC
So now that the bug this problem depended on is fixed, can we get a fix for this?

For reference: https://bugzilla.novell.com/show_bug.cgi?id=725412
Comment 32 Malvern Star 2012-04-08 10:36:06 UTC
This bug is also present in openSuSE 12.2 Milestone 2.  Hoping for a fix for that prior to release, and to have that fix backported to 12.1
Comment 33 Malvern Star 2012-04-12 10:25:09 UTC
Fixed platform setting to 12.2
Comment 34 Ismail Dönmez 2012-04-12 10:27:23 UTC
(In reply to comment #32)
> This bug is also present in openSuSE 12.2 Milestone 2.  Hoping for a fix for
> that prior to release, and to have that fix backported to 12.1

What does the following command say:

> sysctl dev.cdrom.autoclose
Comment 35 Jean-Daniel Dodin 2012-04-12 11:06:30 UTC
on my 12.1

# sysctl dev.cdrom.autoclose
dev.cdrom.autoclose = 1
Comment 36 Ismail Dönmez 2012-04-12 11:08:36 UTC
Well the bug is only fixed for 12.2 :)
Comment 37 Malvern Star 2012-04-16 14:18:46 UTC
Ismail, the bug is NOT fixed for 12.2 and is still present in 12.2M3.  The result of > sysctl dev.cdrom.autoclose is "dev.cdrom.autoclose=1".  Could this please be fixed for the next milestone?
Comment 38 Malvern Star 2012-07-05 10:03:24 UTC
This issue appears to be resolved in 12.2 Beta 2. Closing as fixed.
Comment 39 Malvern Star 2012-07-05 10:04:13 UTC
Whoops, forgot to close on the last comment.
Comment 40 Malvern Star 2012-09-10 12:31:26 UTC
Where are all these reversions coming from?! This bug is back in 12.2 final!
Comment 41 Malvern Star 2013-01-18 20:06:54 UTC
This bug does not appear to be present in 12.3 Beta 1. Can somebody please confirm?
Comment 42 Malvern Star 2013-02-13 09:56:19 UTC
Not present in 12.3 RC1. Does this need to be closed as WONTFIX?
Comment 43 Malvern Star 2013-04-13 19:28:22 UTC
Bug is back again in 12.3 Final. Unbelievable! Can somebody PLEASE fix this?!
Comment 44 Malvern Star 2013-06-22 11:32:12 UTC
Bug does not appear present in 13.1 M2. Can anyone else confirm?
Comment 45 Malvern Star 2013-08-16 20:07:17 UTC
I cannot reproduce in 13.1 M4. I'll leave this open for 12.3.
Comment 46 Jiri Slaby 2015-11-09 09:04:35 UTC
12.3 is out of maintenance, so closing as fixed.
Comment 47 Malvern Star 2015-11-09 16:31:14 UTC
Not present in 42.1 as far as I can tell. I concur.