Bug 628233 - Various printout failures with CUPS default "RIPCache 8m"
Various printout failures with CUPS default "RIPCache 8m"
Status: RESOLVED FIXED
: 631261 639353 675076 (view as bug list)
Classification: openSUSE
Product: openSUSE 11.4
Classification: openSUSE
Component: Printing
Final
All openSUSE 11.4
: P3 - Medium : Normal with 5 votes (vote)
: ---
Assigned To: Johannes Meixner
Johannes Meixner
. maint:released:11.4:40508
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-04 08:57 UTC by Johannes Meixner
Modified: 2016-04-15 12:55 UTC (History)
11 users (show)

See Also:
Found By: Development
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
cups-1.4.4-set_default_RIPCache_128m.patch (1.60 KB, text/plain)
2010-09-15 13:29 UTC, Johannes Meixner
Details
ghostscript-library install conflict (44.69 KB, image/jpeg)
2010-10-20 19:17 UTC, endym ion
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Meixner 2010-08-04 08:57:15 UTC
By default CUPS has only 8 MB RIPCache, see "RIPCache" at
http://www.cups.org/documentation.php/doc-1.4/ref-cupsd-conf.html
--------------------------------------------------------------------
The RIPCache directive sets the size of the memory cache used
by Raster Image Processor ("RIP") filters such as imagetoraster
and pstoraster ... The default cache size is "8m", or 8 megabytes.
--------------------------------------------------------------------

This default exits since a long time and did not cause any issue.
But since a few month more and more weird issues regarding
printout failures happen because of this low default.

When RIPs need much more memory, they may simply fail so that
there is no printout at all, see bug #625611 or
https://answers.launchpad.net/hplip/+question/104395

When RIPs need a bit more memory, they may not fail but
produce broken output which is even worse because it
wastes paper and toner/ink for nonsense printouts, see
attachment #380232 [details] from
https://bugzilla.novell.com/show_bug.cgi?id=603131#c25

CUPS upstream agrees to increase the default RIPCache, see
http://www.cups.org/str.php?L3535

There is also a discussion whether or not to have a fixed
RIPCache size by default at all, see the thread about
"Sense and nonsense of RIPCache" in the cups.general newsgroup/forum on
http://www.cups.org/newsgroups.php?gcups.general+Q"Sense+and+nonsense+of+RIPCache"

For the current openSUSE 11.3 I would like to provide
a CUPS packages update where the one line
  RIPCache 128m
is added to /etc/cups/cupsd.conf (by default there is no
"RIPCache" line in /etc/cups/cupsd.conf which means
CUPS' built-in default cache size is used).

I think to make sure those line gets added in any case
to the user's /etc/cups/cupsd.conf it is best to
add it via "sed" magic via RPM post-install script
if there is not yet a "RIPCache" line in the
user's /etc/cups/cupsd.conf (e.g. when a server admin
had already specified his specific RIPCache value).

128 MB is half of the minimum required RAM (256 MB)
and a quater of the recommended RAM (512 MB)
for a system where openSUSE is to be installed
(according to what I found on a openSUSE 11.2 box)
so that "RIPCache 128m" should be a safe default
which can be set on any user's system.

Coolo,
do you agree that I do such a CUPS packages update?
Comment 1 Stephan Kulow 2010-08-04 09:37:06 UTC
please see http://en.opensuse.org/Portal:Maintenance
Comment 2 Johannes Meixner 2010-08-04 09:50:14 UTC
openSUSE maintenance team,
I would also like to know what you think
what the best way is how to insert such an additional line
into a currently used config file on an end-user's system.
A /etc/cups/cupsd.conf.rpmnew won't help our normal end-users.
I am looking for a full-automated way to solve it for
normal (i.e. unexperienced) end-users.
Is this possible or is the whole idea forbidden?
Comment 3 Dirk Mueller 2010-08-04 12:23:00 UTC
there is no other way (other than sysconfig + fillup templates) that I know of. in any case rpmnew is the usual way - rpm only creates rpmnew if the user modified the config file, and thats exactly the desired behaviour then. If the user left it at default, it will get the new default, otherwise he has to manually merge.
Comment 4 Christian Dengler 2010-08-05 10:56:22 UTC
I think we can wait until the next update and then pick up this config change. (-1)
Comment 5 Johannes Meixner 2010-08-05 12:30:18 UTC
For now it is at least described at
http://en.opensuse.org/Portal:Printing
Comment 6 Christian Dengler 2010-08-09 16:15:11 UTC
so no maintenance update here at the moment.
Comment 7 Johannes Meixner 2010-08-10 08:15:42 UTC
For now I close it a "wontfix".
I will re-open it when there is another CUPS update
and then I include a fix for this issue too.
Comment 10 Johannes Meixner 2010-08-17 08:24:06 UTC
*** Bug 631261 has been marked as a duplicate of this bug. ***
Comment 11 Andreas Jaeger 2010-09-09 14:11:55 UTC
Since this seems to hit some more people, let's open this again.

I propose a separate update for this bug unless we release another cups update in the next two weeks.
Comment 12 Andreas Jaeger 2010-09-09 14:13:17 UTC
Maintenance team, please reevaluate your decision.  Printing has to work ;)
Comment 13 Swamp Workflow Management 2010-09-14 17:38:40 UTC
The SWAMPID for this issue is 35784.
This issue was rated as low.
Please submit fixed packages until 2010-10-12.
Also create a patchinfo file using this link:
https://swamp.suse.de/webswamp/wf/35784
Comment 14 Christian Dengler 2010-09-14 17:39:15 UTC
update started ...
Comment 15 Johannes Meixner 2010-09-15 07:12:03 UTC
*** Bug 639353 has been marked as a duplicate of this bug. ***
Comment 16 Johannes Meixner 2010-09-15 13:29:29 UTC
Created attachment 389750 [details]
cups-1.4.4-set_default_RIPCache_128m.patch

cups-1.4.4-set_default_RIPCache_128m.patch enlarges
the CUPS upstream default RIPCache from 8m to 128m
to avoid various kind of printout failures.
Comment 18 Johannes Meixner 2010-09-15 13:45:17 UTC
Submitted cups with the patch in attachment #389750 [details]
to openSUSE:11.3:Update:Test via submitrequest 48209.
Comment 19 Swamp Workflow Management 2010-09-21 12:29:08 UTC
Update released for: cups, cups-client, cups-client-debuginfo, cups-ddk, cups-ddk-debuginfo, cups-debuginfo, cups-debugsource, cups-devel, cups-libs, cups-libs-debuginfo
Products:
openSUSE 11.3 (debug, i586, x86_64)
Comment 20 JEREMY BEST 2010-09-24 20:11:14 UTC
You mark this bug as 'fixed' but it is NOT fixed!  I had an update claiming to fix it, but the printing fault is not better, just different.

I have OpenSuse 11.3, Canon PIXMA 210.  Second-sheet printing is still all over the place, with printing re-starting and overprinting 17 times!

The only way I can get decent printing is to print each page separately.  

This problem never existed with 11.2 - so what's going on?
Comment 21 Roger Larsson 2010-09-25 17:52:46 UTC
I wonder if I hit some other related problem... (I have updates and RIPCache installed since some time)

When printing a JPEG I run into this (three attempts)
A cache should never change result only speed, I wonder if the increased RIPCache only did hide this problem or...

[1995070.801847] gs[27414]: segfault at 7f9a5f121a1c ip 00007f9a5b0c2662 sp 00007fff1fdd30c0 error 4 in libgs.so.8.70[7f9a5ac7e000+51d000]
[1995258.548432] gs[27986]: segfault at 7fe94a421a1c ip 00007fe9463c2662 sp 00007fff82b78420 error 4 in libgs.so.8.70[7fe945f7e000+51d000]
[1995616.796495] gs[28250]: segfault at 7f0d96316a1c ip 00007f0d922b7662 sp 00007fffbfe8c0f0 error 4 in libgs.so.8.70[7f0d91e73000+51d000]

CUPS status message is

Greta.jpg  	roger  	12821k  	Unknown  	stopped 
"/usr/lib/cups/filter/pstoraster failed"
Comment 22 Christian Dengler 2010-09-29 16:15:35 UTC
reopening it because of comment 20
Comment 23 endym ion 2010-10-19 20:40:35 UTC
The line "RIPCache 128m" did not fix the issue in my case.
I have openSUSE 11.3 (up-to-date), KDE4.5 and Canon i865.

Following the recommendation in <http://bugs.ghostscript.com/show_bug.cgi?id=691499#c15> I set RIPCache to 1024m (1/4 of my system RAM) and that works for me now!

Regards
Thomas
Comment 24 Johannes Meixner 2010-10-20 10:04:41 UTC
Unfortunately you did not provide information which
printer driver you use but "Canon i865" indicates
that you use the Gutenprint driver.

"RIPCache 1024m" matches to this mail on the gimp-print-devel list:
http://sourceforge.net/mailarchive/message.php?msg_name=79617DCE-FA3D-462C-87AA-83C5D1B6C5EB%40apple.com
--------------------------------------------------------------------------
There has been some recent discussion on this - recent versions
of Ghostscript changed the internal banding API but the
CUPS raster "device" was never updated, leading to issues
with the default RIPCache setting of 8MB.

A quick workaround is to set the cupsd.conf RIPCache value
to something larger, e.g. 1024MB:

    cupsctl RIPCache=1024MB
--------------------------------------------------------------------------

This also explains that the root cause is not in CUPS
but a non-backward-compatible change within Ghostscript.

See comment #16:
-------------------------------------------------------------------
 cups-1.4.4-set_default_RIPCache_128m.patch enlarges
 the CUPS upstream default RIPCache from 8m to 128m
 to avoid various kind of printout failures.
-------------------------------------------------------------------
i.e. the changed default RIPCache does of course
not solve any kind of printout failures but it
can avoid some printout failures.

See comment #0 what I wrote in
http://www.cups.org/str.php?L3535
------------------------------------------------------------------
 I don't like the idea to let the default RIPCache size
 depend on the amount of main memory on a particular machine
 because the RIPCache size must match to the printing requirements
 and those are independent of the main memory. (Actually it is
 the other way round: The main memory must be sufficient for
 the printing requirements.) In other words: I think that
 printing should work the same on a 256MB main memory machine
 and on a 2GB main memory machine. The 256MB main memory machine
 is probably already under full load when processing one single
 large format photo print job but for each job it should work
 the same.
------------------------------------------------------------------
and where "jimjensen" wrote on 11:48 Mar 24, 2010
------------------------------------------------------------------
 A RIPCache value of 32m is adequate for printing 13" x 19"
 (according to my test on a HP B8550),
------------------------------------------------------------------
and what I wrote directly in comment #0
----------------------------------------------------------------
 128 MB is half of the minimum required RAM (256 MB)
 and a quater of the recommended RAM (512 MB)
 for a system where openSUSE is to be installed
 (according to what I found on a openSUSE 11.2 box)
 so that "RIPCache 128m" should be a safe default
 which can be set on any user's system.
----------------------------------------------------------------

A default "RIPCache 1024m" (i.e. 1 GB!) is totally impossible.

Summary:
The issue is fixed as good as currently possible in CUPS.
In some cases the current default RIPCache value of 128m
is still insufficient (probably only when printing at
high resolution with the Gutenprint driver) so that
you may have to specify much more.

I enhanced the section about RIPCache accordingly at
http://en.opensuse.org/Portal:Printing
Comment 25 Johannes Meixner 2010-10-20 10:46:15 UTC
FYI:
If you update Ghostscript to a sufficiently new version
(i.e. where the root cause is fixed in Ghostscript)
it should work to specify in /etc/cups/cupsd.conf
  RIPCache auto
to use Ghostscript's dynamic memory allocation, see
http://bugs.ghostscript.com/show_bug.cgi?id=691499#c15
Comment 26 endym ion 2010-10-20 19:17:15 UTC
Created attachment 396070 [details]
ghostscript-library install conflict
Comment 27 endym ion 2010-10-20 19:21:00 UTC
You are right - I'm using the Gutenprint driver v5.2.4.

My installed ghostscript files:
S | Name                    | Typ   | Version     | Arch   | Repository          
--+-------------------------+-------+-------------+--------+---------------------
i | ghostscript-devel       | Patch | 2726        | noarch | openSUSE-11.3-Update
i | ghostscript-fonts-other | Paket | 8.70-15.1.1 | i586   | openSUSE-11.3-Update
i | ghostscript-fonts-std   | Paket | 8.70-15.1.1 | i586   | openSUSE-11.3-Update
i | ghostscript-library     | Paket | 8.70-15.1.1 | i586   | openSUSE-11.3-Update
i | ghostscript-x11         | Paket | 8.70-15.1.1 | i586   | openSUSE-11.3-Update

My installed cups files:
S | Name               | Typ   | Version     | Arch   | Repository          
--+--------------------+-------+-------------+--------+---------------------
i | cups               | Paket | 1.4.4-3.1.1 | i586   | openSUSE-11.3-Update
i | cups               | Patch | 3107        | noarch | openSUSE-11.3-Update
i | cups-client        | Paket | 1.4.4-3.1.1 | i586   | openSUSE-11.3-Update
i | cups-drivers       | Paket | 1.3.9-11.1  | i586   | openSUSE-11.3-Oss   
i | cups-libs          | Paket | 1.4.4-3.1.1 | i586   | openSUSE-11.3-Update
i | python-cups        | Paket | 1.9.49-1.11 | i586   | openSUSE-11.3-Oss   
i | python-cupshelpers | Paket | 1.2.0-1.14  | i586   | openSUSE-11.3-Oss

I have tried to install a newer ghostscript-library version from repo <http://download.opensuse.org/repositories/Printing:/ghostscript/openSUSE_11.3>, but I run into a conflict (see Attachment #396070 [details] above). Any hints?
Comment 28 Johannes Meixner 2010-10-21 09:10:32 UTC
First of all:
Many thanks for your feedback in comment #23.
The information that sometimes even up to 1GB RIPCache
is actually needed was new to me and helped us a lot!


Regarding your attachment #396070 [details]:

On my openSUSE 11.3 x86_64 system with Ghostscript 8.70
I can anticipate what causes your attachment #396070 [details]
(only "rpm -e --test" shows all requirements and their actual reason):
----------------------------------------------------------------------------
# rpm -e --test ghostscript-library-8.70
...
libgs.so.8()(64bit) is needed by ... libspectre1-0.2.4-3.1.x86_64
libgs.so.8()(64bit) is needed by ... foomatic-filters-4.0.1-6.1.x86_64
----------------------------------------------------------------------------

This means that libspectre1 (i.e. /usr/lib64/libspectre.so.1.1.4)
and foomatic-filters (i.e. /usr/bin/foomatic-rip) are linked
with libgs.so.8 but libgs.so.8 is not provided
by Ghostscript 9.00 so that neither /usr/bin/foomatic-rip
nor /usr/lib64/libspectre.so.1.1.4 would still work if
ghostscript-library-8.70 was replaced by ghostscript-library-9.00

As a consequence the installer would suggest
to remove libspectre1 and foomatic-filters.

But then the subsequent consequences would be:
----------------------------------------------------------------------------
# rpm -e --test libspectre1-0.2.4
...
libspectre.so.1()(64bit) is needed by ... okular-4.4.4-1.4.x86_64
----------------------------------------------------------------------------
and
----------------------------------------------------------------------------
# rpm -e --test foomatic-filters-4.0.1
...
foomatic-filters is needed by ... cups-drivers-1.3.9-35.1.x86_64
foomatic-filters is needed by ... cups-1.4.4-4.1.x86_64
----------------------------------------------------------------------------

As a final result the installer would suggest to remove
libspectre1, foomatic-filters, okular, cups-drivers, and cups.

This means that at least currently you cannot simply install
ghostscript-library-9.00 from its openSUSE development project
"Printing:ghostscript" into your usual openSUSE 11.3 system
and still have a normal usable openSUSE 11.3 system - except
you actually want to do development and you know what you do.

It is no bug when there are issues with packages from
openSUSE development projects, in particular have a look at
https://build.opensuse.org/project/show?project=Printing
-----------------------------------------------------------------------
The "Printing" project may contain new, upcoming software.
Therefore the packages in the "Printing" project
might neither be in a stable state nor fit well into
currently installed systems.
Have this in mind if you think about to install
packages from the "Printing" project into your
currently running system.
...
The packages in the "Printing" project are
only for testing, without any guarantee or warranty,
and without any support.
-----------------------------------------------------------------------

In the end:
Normal openSUSE 11.3 users should do what is described on
http://en.opensuse.org/Portal:Printing
how to work around "Current Issues".


By the way:
This bug is about the "CUPS default RIPCache".
If there are issues with Ghostscript, I suggest to file
a new separated bug report so that we could better keep
separated issues actually separated.
Comment 29 endym ion 2010-10-21 12:13:12 UTC
Thanks for your detailed answer!
I did not continuing the ghostscript-library install process, so my system is still running stable. :-)

Now I will wait for a ghostscript update in the stable repository and than try the "RIPCache auto" setting.
Comment 30 Johannes Meixner 2011-03-01 08:09:39 UTC
*** Bug 675076 has been marked as a duplicate of this bug. ***
Comment 31 Juergen Weigert 2011-04-23 10:10:00 UTC
Reopened for 11.4,
I get garbled pages again with my HP Photosmart C5280.

A simple
# echo >> /etc/cups/cupsd.conf RIPCache 128m
# rccups restart

fixes the issue again.
Comment 32 Juergen Weigert 2011-04-23 10:10:53 UTC
*** Bug 631261 has been marked as a duplicate of this bug. ***
Comment 33 Johannes Meixner 2011-04-26 12:20:34 UTC
Oops!
I thought the root cause is fixed in Ghostscript 9.00.
Unfortunately the issue still exists.

openSUSE maintenance team,
I ask for an update of the cups package only for openSUSE 11.4
which implements the same workaround as in comment #16
so that we have in openSUSE 11.4 the same workaround
which we already provide for openSUSE 11.3
Comment 34 Juergen Weigert 2011-04-26 12:43:10 UTC
The incident I had in comment#31 was with a standard 11.4 KDE new install,
using /etc/cups/ppd/Photosmart-C5200-series.ppd
...
*NickName: "HP Photosmart c5200 Series, hpcups 3.11.1.19"
...
Comment 35 Gregory Arenius 2011-04-27 09:36:42 UTC
Just to add a second confirmation, I also have the same problem on 11.4 with and HP Photosmart c4480.

I am also using hpcups 3.11.1.19

Manually setting the RIPCache to 128M does solve the problem. 

Manually setting the RIPCache to auto does NOT solve the problem the way it is theoretically supposed to.

Despite the bug report http://bugs.ghostscript.com/show_bug.cgi?id=691499#c15 being closed in Ghostscript I still feel that there is a problem on their end.  

Even if the limit is too low for large files why are small simple files no longer working correctly?  And if it is only a problem resulting from size of the file why does the size of the file or the amount of data on the first page not seem to matter?  It always starts printing gibberish on the second page.

Should I try to have this reopened upstream?
Comment 36 Christian Dengler 2011-04-27 11:34:43 UTC
For an update of the workaround we already shipped for 11.3: +1
Comment 37 Marcus Meissner 2011-04-27 13:08:46 UTC
did we ship it? but yes, if we did ... +1
Comment 38 Johannes Meixner 2011-04-27 13:48:38 UTC
Regarding comment #35:

According to the Ghostscript SVN log and the files
/usr/share/ghostscript/9.00/doc/Changes.htm
/usr/share/ghostscript/9.00/doc/Details.htm
(search "Bug 691499" therein) the Ghostscript bug
http://bugs.ghostscript.com/show_bug.cgi?id=691499
should be fixed in Ghostscript 9.00.

Currently I do not know why no "RIPCache" entry at all
or "RIPCache auto" in /etc/cups/cupsd.conf does not let
Ghostscript determine the memory buffer sizes automatically.

I also feel that there is an issue left in Ghostscript.

But I am not a sufficient Ghostscript expert to fix it
right now in Ghostscript so that I prefer to provide
our known workaround as update in CUPS to avoid the
root cause in Ghostscript for now.
Comment 39 JEREMY BEST 2011-04-27 13:55:21 UTC
(In reply to comment #31)
> Reopened for 11.4,
> I get garbled pages again with my HP Photosmart C5280.
> 
> A simple
> # echo >> /etc/cups/cupsd.conf RIPCache 128m
> # rccups restart
> 
> fixes the issue again.

This does not work for me. I get "access denied" even when I log in as root. 
Cannot access cupsd.conf in the file system either.

I have OpenSuse 11.4 and Canon Pixma MP210.  This problem has been bugging me
since OPensuse 11.3 came in and no solution has worked so far.  This seems very
strange as printing worked perfectly with 11.2.  Definitely a backward step
somewhere!

Can anyone please help with this in simple, beginners terms.

Thank you

jaybest
Comment 40 Juergen Weigert 2011-04-27 14:27:06 UTC
JB, 'access denied' means, you need to master a different issue. Followup in private mail.
Comment 41 Christian Dengler 2011-04-28 15:29:10 UTC
SwampID: 40505
Comment 42 Johannes Meixner 2011-04-28 16:14:24 UTC
Submitted cups with the patch in attachment #389750 [details]
to openSUSE:11.4:Update:Test via submitrequest 68719
(compare comment #16).
Comment 43 Johannes Meixner 2011-04-28 16:49:24 UTC
Submitted patchinfo via
https://swamp.suse.de/webswamp/wf/40505

For me the issue in now FIXED.

Nevertheless it may take a while until cups update packages
for openSUSE 11.4 really appear under openSUSE:11.4:Update.

I.e. when this bug report is set to "FIXED" it does not mean
that cups update packages are already available.

The cups update packages will have this RPM changelog entry:
--------------------------------------------------------------
- cups-1.4.4-set_default_RIPCache_128m.patch enlarges
  the CUPS upstream default RIPCache from 8m to 128m
  to avoid various kind of printout failures
  (STR #3535, and Novell/openSUSE Bugzilla bnc#628233).
--------------------------------------------------------------

Unless "rpm -q --changelog cups" does not show this entry,
you do not have this cups update packages installed.
Comment 44 Bernhard Wiedemann 2011-04-28 17:00:09 UTC
This is an autogenerated message for OBS integration:
This bug (628233) was mentioned in
https://build.opensuse.org/request/show/68719
Comment 45 Swamp Workflow Management 2011-04-28 17:27:04 UTC
The SWAMPID for this issue is 40505.
This issue was rated as low.
Please submit fixed packages until 2011-05-26.
Also create a patchinfo file using this link:
https://swamp.suse.de/webswamp/wf/40505
Comment 46 Malvern Star 2011-05-03 16:16:19 UTC
I am having this issue as well.  I am using a HP Officejet Pro L7590 with the HPLIP drivers provided by SuSE, and printing more than one page always results in the second page appearing "broken".  Since this is marked as "FIXED", should I assume that a fix is coming by say... mid May?  Also, does anyone know if this could also cause printer queues to be set to "paused" by CUPS, as I have had several customers report this issue, where their printers have mysteriously stopped printing.
Comment 47 Roger Larsson 2011-05-06 18:08:44 UTC
Epson Stylus PHOTO RX620 - removing RIPcache line (or using "auto"),
problem returns.

I am running OpenSuSE_Tubleweed

Repeating myself - a cache size should only affect speed not correctness!
Comment 48 Christian Dengler 2011-05-10 15:28:26 UTC
update released.
Comment 49 Swamp Workflow Management 2011-05-10 15:28:38 UTC
Update released for: cups, cups-client, cups-client-debuginfo, cups-ddk, cups-ddk-debuginfo, cups-debuginfo, cups-debugsource, cups-devel, cups-libs, cups-libs-debuginfo
Products:
openSUSE 11.4 (debug, i586, x86_64)
Comment 50 Malvern Star 2011-05-10 16:22:08 UTC
This fixed the issue I was having with my Officejet Pro L7590.  Thankyou.
Comment 51 JEREMY BEST 2011-05-11 09:59:55 UTC
NOT FIXED!!!

Again you mark this bug as fixed and again it is not.  I have OpenSuse 11.4 and Canon Pixma MP210.  I'm still getting defective printing - overprinting two/three times, on pages after page one.  So I still have to print each page separately - a real pain if it's a long document.

Please try this on the Canon model someone.  Or should I give up and buy a printer which does work with this OS?
Comment 52 JEREMY BEST 2011-05-11 10:02:10 UTC
Yes, I did install the update using package handler and that seemed to go without a hitch.  And I did restart my computer also.  

Is there anything else I might try?
Comment 53 Johannes Meixner 2011-05-17 11:37:47 UTC
FYI:

See
http://en.opensuse.org/Portal:Printing
-----------------------------------------------------------------------
In some cases (probably only for color printing at high resolution
with the Gutenprint driver) you may have to specify much more,
e.g. 1GB with

RIPCache 1024m

of course provided you have at least 2GB main memory in your computer.
-----------------------------------------------------------------------
Comment 54 JEREMY BEST 2011-05-30 08:43:20 UTC
Thanks to a helpful correspondent to Linux Questions, I now have an answer.  My problem was that, for some still unknown reason, I could not access cupsd.conf to change the RIPCache value.

However, I was told to do it thus:  "Another option is to use Cups web interface to edit the file. Enter "http://localhost:631" in the browser.
Select the "Administration" tab. Click the "Edit Configuration File". After making your changes, click save. You will be asked for the username and password. Enter the user "root" and the root password to save your changes."

This worked fine, I changed the value from 128m to 1280m, and my printing is now at last working properly.  

So this problem is now FIXED for me also!
Comment 55 Juergen Weigert 2011-05-30 11:15:09 UTC
Off topic:

(In reply to comment #54)
> Thanks to a helpful correspondent to Linux Questions, I now have an answer.  My
> problem was that, for some still unknown reason, I could not access cupsd.conf

Jeremy independant of this cups issue, you should have root access on your machine, if you want to be your own admin. Without root, you cannot even add security updates.
Comment 56 Malvern Star 2011-06-04 20:53:22 UTC
Juergen,

Probably he tried to open his cups configuration in KWrite as the root user, which currently does not work.
Comment 57 JEREMY BEST 2011-06-05 18:24:11 UTC
Juergen

I can in fat add security updates etc. by entering my root password when asked to authenticate.  What I don't seem to be able to do is access cupsd.conf or any of the other files marked not accessible.  I don't usually use commands so this has only been a serious problem since this CUPS business cropped up.  Trying some of the other suggestions for commands given above, even after going into root, I have just got the message 'no such file' or words to that effect.

Anyway, my printing is now working beautifully which is great.
Comment 58 Bernhard Wiedemann 2011-09-29 11:00:14 UTC
This is an autogenerated message for OBS integration:
This bug (628233) was mentioned in
https://build.opensuse.org/request/show/85413 Factory / cups
Comment 59 Bernhard Wiedemann 2011-09-29 12:00:09 UTC
This is an autogenerated message for OBS integration:
This bug (628233) was mentioned in
https://build.opensuse.org/request/show/85423 Factory / cups
Comment 60 Bernhard Wiedemann 2011-09-29 14:00:10 UTC
This is an autogenerated message for OBS integration:
This bug (628233) was mentioned in
https://build.opensuse.org/request/show/85447 Factory / cups
Comment 61 Bernhard Wiedemann 2016-04-15 12:55:09 UTC
This is an autogenerated message for OBS integration:
This bug (628233) was mentioned in
https://build.opensuse.org/request/show/48209 11.3:Test / cups