Bug 623240 - Error in: kio_sysinfo (System Information KIO-Slave, sysinfo:/), openSUSE Linux 11.3 (Final)
Error in: kio_sysinfo (System Information KIO-Slave, sysinfo:/), openSUSE Lin...
Status: RESOLVED FIXED
: 615817 619790 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Workspace (Plasma)
13.1 Milestone 1
x86-64 SUSE Other
: P5 - None : Normal (vote)
: 13.1 Milestone 1
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-17 19:58 UTC by Genix Info
Modified: 2013-01-18 11:02 UTC (History)
7 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Genix Info 2010-07-17 19:58:48 UTC
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.9.2.6) Gecko/20100626 SUSE/3.6.6-1.2 Firefox/3.6.6

The kio_sysinfo (System Information KIO-Slave sysinfo: /) contains an error, because when we will open any partition, it just does not open (the time of opening, he says he has no block device installed (inode / blockdevice) I try to install this software, but he does not install anything, and that link still appears in the middle of messages: http://help.opensuse.org/ksuseinstall/), while opens the Konqueror (or any other manager file), I open normally.


My openSUSE Linux 11.3 (Final), who is with the programs by default, the only
thing I do is to install. YMP openSUSE-Guide:
http://www.opensuse-guide.org/codecs.php, that I can watch videos and other
things on your computer.


I'm with a dual-boot setup where I have openSUSE Linux 11.3, the same computer as Windows 7.





See my Hardware below:


http://forums.opensuse.org/english/get-help-here/hardware/442138-error-kio_sysinfo-system-information-kio-slave-sysinfo-opensuse-linux-11-3-final.html


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Genix Info 2010-07-17 21:06:25 UTC
But I think that the error should be the link of the partitions, because the link from my home is like this:


file:///dev/sda7



and the right would look like:



/home/




And this problem occurs with all partitions, including stick and other removable devices.
Comment 2 Michael Jenkinson 2010-07-18 19:12:39 UTC
Agree that the links to partitions and devices no longer works like it should and it was working in OpenSUSE 11.2 where Konqueror was version 4.3.5, not the present 4.4.4 .

Actually even as long ago as OpenSUSE 11.0 references to /dev/sda from bash did not work (I have not tested yet 11.2 or 11.3) and Dolphin too is having problems with this sort of magic link although midnight commander confirms they exist.

My software is x86-64 confirming that the bug is general

As Dolphin shows the same error "There is no application installed that can open files of the type block device (inode/blockdevice). Do you want to try to install one?" when you click on the sda link in /dev/ while in 11.2 dolphin offers you an application selector box it may be a new general KDE fault.
Comment 3 Michael Jenkinson 2010-07-21 20:21:45 UTC
This error has corrected on my system. This is either because of the (optional but recommended) software update that came out yesterday (20/7/10) or because I ran the Device Notifer widget which has similar HTML link functionality but for all I know on first install/run does something that corrects the bug. If bug still exists on others system they can try this and report.

Dolphin can not access dev/sda still with same error message but who cares.

The bug is only corrected on left clicking on the link. This throws you into Dolphin. If you select a right click option like open in another window it does not work.
Comment 4 Michael Jenkinson 2010-07-21 20:32:26 UTC
That last paragraph should read...

The bug is only corrected on left clicking on the link. This throws you into
a Konquer file system display window. If you select a right click option like open in another window it does not work.
Comment 5 Christian Trippe 2010-08-22 19:19:30 UTC
*** Bug 615817 has been marked as a duplicate of this bug. ***
Comment 6 Mindaugas Baranauskas 2011-01-13 22:51:25 UTC
*** Bug 619790 has been marked as a duplicate of this bug. ***
Comment 7 Mindaugas Baranauskas 2011-01-13 23:05:06 UTC
Christian, you in this bug marked, 
that bug#623240 is dublicate of bug#615817 ,
but in bug#615817 marked as it is dubliacate of 623240...

So I would like to ignore this dublicate, because this bug is not fully fixed in openSUSE 11.4 milestone 5:
If you press right mouse and select to open in new tab or window, it still proposes to install software!
Comment 8 Rainer Hurtado Navarro 2011-02-20 07:08:49 UTC
It is right that this bug is still present under RC1.
When left clicked it is possible to enter the device rightly (except CD/DVDs), but, although the arrow to get back in the navigation is active, the user cann't navigate back to sysinfo:/.
When right clicked and chosen new window/tab, Konqueror complains that needs a plug-in.
"(changed during the 2011-02-20 Open-Bugs-Day about bugs for obsolete versions of openSUSE)"
dom feb 20 07:08:32 UTC 2011
Comment 9 Alin M Elena 2012-11-16 00:08:17 UTC
the last comment is still valid with current kde...
is sysinfo still maintianed?
Alin
Comment 10 Christian Trippe 2012-11-16 19:38:00 UTC
sysinfo was maintained by SUSE and only with KDE4 moved to official KDE repos playground where it is probably unmaintained now. Maybe we should think about dropping it...
Comment 11 Alin M Elena 2013-01-18 11:02:04 UTC
sysinfo is dead now... so there is no bug left... we replaced it by kinfocenter

Alin