Bug 621481 - Netbooks with Broadcom BCM4312 will hang on boot
Netbooks with Broadcom BCM4312 will hang on boot
Status: RESOLVED DUPLICATE of bug 617912
Classification: openSUSE
Product: openSUSE 11.3
Classification: openSUSE
Component: Network
Final
i586 openSUSE 11.3
: P5 - None : Major with 1 vote (vote)
: ---
Assigned To: Vladimir Botka
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-12 00:14 UTC by Larry Finger
Modified: 2010-07-15 12:39 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Larry Finger 2010-07-12 00:14:19 UTC
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6

On some Netbook systems with Broadcom BCM4312 wireless devices will freeze when loading the driver ssb because the SPROM is at a different location than on earlier systems found on laptop computers.

The fix is known and has been submitted to the 2.6.34 stable archive, and it will be present in future updates of the 11.3 kernel; however, the distribution media have the problem. Add Live CD, DVD and NET install CDs for i586/i686 are affected. The media for x86_64 are OK.

This bug does not log any errors - the system just freezes. The workaround is to add "brokenmodules=ssb" to the boot options line.

Once you have installed the system on the computer, a patched copy of ssb.ko for the 2.6.34-12-desktop kernel is available at html://lwfinger.net/ssb.ko.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Vladimir Botka 2010-07-15 12:39:05 UTC
(In reply to comment #0)
> The fix is known and has been submitted to the 2.6.34 stable archive, and it
> will be present in future updates of the 11.3 kernel

I've quoted your info into the bnc 617912 and duplicated as well.

*** This bug has been marked as a duplicate of bug 617912 ***