Bug 595912 - Remove menu items from application-browser duplicated in gnome-control-centre
Remove menu items from application-browser duplicated in gnome-control-centre
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE 11.3
Classification: openSUSE
Component: GNOME
Factory
All openSUSE 11.3
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-12 20:33 UTC by Atri Bhattacharya
Modified: 2010-11-30 09:42 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Atri Bhattacharya 2010-04-12 20:33:23 UTC
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.1.8) Gecko/20100204 SUSE/3.5.8-0.1.1 Firefox/3.5.8

There are a great number of items in the "System" group in the Application-browser which are duplicated in the gnome-control-centre. Indeed, almost all items that appear in the control-centre also appear in the system group on the application browser. The request is to remove all such duplicated entries from the application-browser keeping them only in the control-centre. This will reduce redundancy between the two different slabs while also significantly improving load-up times of the application-browser since there will be significantly fewer items to load.

On a related note it might also be useful to have a "control-centre" button in the application-browser instead of all these duplicated items.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Atri Bhattacharya 2010-04-12 20:41:03 UTC
Actually every item in the gnome-control-centre is duplicated in the application-browser either in the "System" group or in the "Utilities" group. All these elements must be black-listed from the application-browser. I am not sure how this can be done by default by I do is manually using the main-menu configurator alacarte.
Comment 2 Rastislav Krupansky 2010-04-13 05:24:14 UTC
Yes, you are absolutely right.
I´d prefer remove all of items in "System" group and have only Control Center. It would be well-arranged. Or possibility to edit which items user wants in "System" group.
As an exmaple let´s try to take a look Ubuntu's Menu Bar. It´s pretty clean. And it gives possibility to change which one items user can set in "System" group.
Whether Preferences, Administration or Control Center. I like this idea. 
http://ubuntuguide.net/enable-ubuntu-control-center-windows-control-panel-like-interface
And openSUSE could add also YaST in "System" group.
Honestly, Menu Bar and Traditional Gnome Main Menu are big mess in openSUSE.
Comment 3 Atri Bhattacharya 2010-05-06 09:48:52 UTC
Can this be done for Milestone 7 [May 21]. Please let me know if there is something I can do to help with this. Much needed organisation for the application-browser with the potential to reduce its load-up times too.
Comment 4 Rastislav Krupansky 2010-05-26 19:27:36 UTC
Still no progress here in Milestone7 :-(
Comment 6 Vincent Untz 2010-11-30 09:42:52 UTC
Unfixable for 11.3, and fixed in Factory a while ago :-)