Bug 1203207 - Docking station disrupts ethernet when laptop is put on suspend
Docking station disrupts ethernet when laptop is put on suspend
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-09-07 11:18 UTC by Frederic Crozat
Modified: 2022-09-08 06:55 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
supportconfig output (1.21 MB, application/x-xz-compressed-tar)
2022-09-07 12:05 UTC, Frederic Crozat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Crozat 2022-09-07 11:18:15 UTC
Some Lenovo Docking station misbehaves when laptop pluged is put to suspend, creating a ethernet packet storm on the dock ethernet port which can bring down some ethernet switches.

This is a know bug, fixed in upstream kernel (see https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/drivers/net/usb/r8152.c?h=v6.0-rc4&id=cb82a54904a99df9e8f9e9d282046055dae5a730 )
but the fix needs to be applied per Docking station and my docking station is not listed there.

Would it be possible to add it to the list (and enable also the MAC spoofing feature see https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/drivers/net/usb/r8152.c?h=v6.0-rc4&id=1bd3a383075c64d638e65d263c9267b08ee7733c ) ?

I'm not sure which usbid are the one used to detect the docking station.

Possible values are :
Bus 003 Device 038: ID 17ef:30b9 Lenovo USB2.0 Hub             
Bus 003 Device 036: ID 17ef:30b7 Lenovo USB2.0 Hub             
Bus 003 Device 035: ID 17ef:30b5 Lenovo 40B0
Bus 003 Device 042: ID 17ef:30b4 Lenovo ThinkPad Thunderbolt 4 Dock MCU Contoller
Bus 003 Device 034: ID 17ef:30ba Lenovo V1003

Docking station is a ThinkPad Thunderbolt 4 WorkStation Dock : https://support.lenovo.com/us/en/accessories/pd500533-thinkpad-thunderbolt-4-workstation-dock-overview-and-service-parts

I'll be happy to test any kernel with the proper id applied.
Comment 1 Takashi Iwai 2022-09-07 11:24:54 UTC
Could you give hwinfo output?  Or supportconfig output would be even better.
Comment 2 Frederic Crozat 2022-09-07 12:05:32 UTC
Created attachment 861351 [details]
supportconfig output
Comment 3 Takashi Iwai 2022-09-07 12:23:50 UTC
Hmm, the network is already with r8152 driver with the standard Realtek USB ID.
So the existing list can't be applied easily.  I can try to patch to forcibly apply the Lenovo macpassthru workaround, but it's really a blind shot.
Comment 4 Takashi Iwai 2022-09-07 12:36:01 UTC
And I guess it's rather the same problem as reported in kernel bugzilla:
  https://bugzilla.kernel.org/show_bug.cgi?id=216333

If so, the fix should have been included in 6.0-rc3 as well as 5.19.6.
Could you try the latest kernel in OBS Kernel:stable repo?
Comment 5 Frederic Crozat 2022-09-07 12:46:21 UTC
I was on 5.19.5 from stable yesterday. I'm on TW kernel (5.19.7) today. I will test suspending my laptop to check if it brings network down or not.
Comment 6 Frederic Crozat 2022-09-08 06:55:23 UTC
I can confirm the issue is fixed with kernel 5.19.7 from Factory