Bug 1202849 - [Build 20220827] usr_sbin_dnsmasq: there are errors in audit.log
[Build 20220827] usr_sbin_dnsmasq: there are errors in audit.log
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: AppArmor
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Christian Boltz
E-mail List
https://openqa.opensuse.org/tests/257...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-08-28 09:29 UTC by Dominique Leuenberger
Modified: 2022-08-28 12:40 UTC (History)
0 users

See Also:
Found By: openQA
Services Priority:
Business Priority:
Blocker: Yes
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2022-08-28 09:29:37 UTC
## Observation

Not much changed in this snapshot from what I can see.

There was an apparmor update, but the patch added was touching php-fpm per changelog

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-apparmor_profile_dnsmasq@64bit fails in
[usr_sbin_dnsmasq](https://openqa.opensuse.org/tests/2571698/modules/usr_sbin_dnsmasq/steps/63)

## Test suite description
Maintainer: llzhao@suse.com


## Reproducible

Fails since (at least) Build [20220827](https://openqa.opensuse.org/tests/2568759)


## Expected result

Last good: [20220826](https://openqa.opensuse.org/tests/2560700) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=DVD&machine=64bit&test=apparmor_profile_dnsmasq&version=Tumbleweed)
Comment 1 Christian Boltz 2022-08-28 11:07:58 UTC
For the records: The denial is:

type=AVC msg=audit(1661676998.485:1765): apparmor="DENIED" operation="open" profile="dnsmasq//libvirt_leaseshelper" name="/sys/devices/system/cpu/possible" pid=9060 comm="libvirt_leasesh" requested_mask="r" denied_mask="r" fsuid=0 ouid=0

Submitted upstream as https://gitlab.com/apparmor/apparmor/-/merge_requests/917

Submitted to Factory as SR 999638 (including a minor version update)
Comment 2 OBSbugzilla Bot 2022-08-28 12:40:02 UTC
This is an autogenerated message for OBS integration:
This bug (1202849) was mentioned in
https://build.opensuse.org/request/show/999638 Factory / apparmor