Bug 1202463 - mount error(40): Too many levels of symbolic links
mount error(40): Too many levels of symbolic links
Status: RESOLVED DUPLICATE of bug 1198753
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Kernel
Leap 15.4
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: openSUSE Kernel Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-08-16 23:07 UTC by Ben Walter
Modified: 2022-08-17 20:37 UTC (History)
4 users (show)

See Also:
Found By: Community User
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Packet traces (17.32 MB, application/x-zip-compressed)
2022-08-17 20:37 UTC, Ben Walter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Walter 2022-08-16 23:07:21 UTC
On updating kernel versions (as below) and trying to mount CIFS shares from Synology (where Aggregation Portal is enabled) results in "mount error(40): Too many levels of symbolic links".

    5.3.18-150300.59.76 => 5.3.18-150300.59.87 (+)
    5.14.21-150400.22 => 5.14.21-150400.24.11 (+) 


Disabling Aggregation Portal allows the mount to succeed.

I raised a case with Synology and they have said this is a SUSE Kernel issue.

"When your client device sends a create request with DFS operation enabled, file path will ends up with \0, which will cause a mismatch with the Blob Length after the \0 has been ignored, and leads to a OBJECT_NAME_INVALID / Too many levels of symbolic links error.

We have also reproduce the issue with original samba 4.15.9 package as a SMB server. And the mount.cifs version will have different behaviors between under DFS and non-DFS operation (no extra \0 under non-DFS operation), and that is why the issue disappears after MSDFS option is disabled."
Comment 1 Ben Walter 2022-08-16 23:10:08 UTC
Synology Ticket #3139054
Comment 2 Enzo Matsumiya 2022-08-17 13:39:09 UTC
Hi Ben. This is already known to us (bug 1198753).

Can you share the pcap (network trace) of the failing mount operation please?

The user from that other bug still couldn't provide us with that, and we don't have such Synology setup to reproduce.

Their description is already a good hint of what's happening, so we can start working on it right away, as soon as a pcap is provided.
Comment 3 Enzo Matsumiya 2022-08-17 13:39:53 UTC
Closing this one as a duplicate, please provide the logs + pcap in the other bug.

*** This bug has been marked as a duplicate of bug 1198753 ***
Comment 4 Ben Walter 2022-08-17 20:37:06 UTC
Created attachment 860864 [details]
Packet traces

ds1517 is the Synology device tracing. mag01 is the SUSE OS tracing (I don't have captures specifically for openSUSE).