Bug 1202161 - [Build 20220804] dns/libvirt denied messages in log
[Build 20220804] dns/libvirt denied messages in log
Status: VERIFIED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: AppArmor
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Christian Boltz
E-mail List
https://openqa.opensuse.org/tests/249...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-08-05 07:47 UTC by Dominique Leuenberger
Modified: 2022-08-11 10:05 UTC (History)
0 users

See Also:
Found By: openQA
Services Priority:
Business Priority:
Blocker: Yes
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2022-08-05 07:47:36 UTC
## Observation


type=AVC msg=audit(1659682891.314:1744): apparmor="DENIED" operation="file_mmap" profile="dnsmasq//libvirt_leaseshelper" name="/usr/libexec/libvirt_leaseshelper" pid=9065 comm="libvirt_leasesh" requested_mask="r" denied_mask="r" fsuid=0 ouid=0


openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-apparmor_profile_dnsmasq@64bit fails in
[usr_sbin_dnsmasq](https://openqa.opensuse.org/tests/2498064/modules/usr_sbin_dnsmasq/steps/63)

## Test suite description
Maintainer: llzhao@suse.com


## Reproducible

Fails since (at least) Build [20220804](https://openqa.opensuse.org/tests/2497577)


## Expected result

Last good: [20220803](https://openqa.opensuse.org/tests/2496445) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=DVD&machine=64bit&test=apparmor_profile_dnsmasq&version=Tumbleweed)
Comment 1 Dominique Leuenberger 2022-08-05 07:49:35 UTC
The chain was introduced with

https://build.opensuse.org/request/show/992407

58-%attr(0755, root, root) %{_libdir}/%{name}/libvirt_leaseshelper
59+%attr(0755, root, root) %{_libexecdir}/libvirt_leaseshelper

This, and some other files, were moved from /usr/lib64 to /usr/libexec
Comment 2 Christian Boltz 2022-08-08 19:16:52 UTC
SR 993844 sent to Factory.

Side note: I'm quite sure this is unrelated to the path change - the old and new path had the same permissions.
Comment 3 OBSbugzilla Bot 2022-08-08 20:40:05 UTC
This is an autogenerated message for OBS integration:
This bug (1202161) was mentioned in
https://build.opensuse.org/request/show/993844 Factory / apparmor
Comment 4 Dominique Leuenberger 2022-08-11 10:05:06 UTC
(In reply to OBSbugzilla Bot from comment #3)
> This is an autogenerated message for OBS integration:
> This bug (1202161) was mentioned in
> https://build.opensuse.org/request/show/993844 Factory / apparmor

Fix confirmed by openQA: https://openqa.opensuse.org/tests/2506493