Bug 1200139 - Cannot run any Chromium-based browser with gtk4.
Cannot run any Chromium-based browser with gtk4.
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Usability
Current
x86-64 openSUSE Tumbleweed
: P5 - None : Enhancement (vote)
: ---
Assigned To: Callum Farmer
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-06-02 02:40 UTC by Howard Cheung
Modified: 2022-06-15 19:20 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Howard Cheung 2022-06-02 02:40:30 UTC
Chromium has gtk4 support, and can be enabled by --gtk-version=4. This is needed for IME support on wayland. However, in openSUSE, it always uses gtk3. It seems that the browser failed with gtk4 and then fallbacks to gtk3 automatically.
Comment 1 Andreas Stieger 2022-06-10 15:32:30 UTC
https://build.opensuse.org/request/show/981322
Comment 2 OBSbugzilla Bot 2022-06-10 18:40:04 UTC
This is an autogenerated message for OBS integration:
This bug (1200139) was mentioned in
https://build.opensuse.org/request/show/982061 Backports:SLE-15-SP3 / chromium
https://build.opensuse.org/request/show/982062 Backports:SLE-15-SP4 / chromium
Comment 3 Swamp Workflow Management 2022-06-15 13:17:51 UTC
openSUSE-SU-2022:10009-1: An update that fixes 28 vulnerabilities is now available.

Category: security (critical)
Bug References: 1199893,1200139,1200423
CVE References: CVE-2022-1853,CVE-2022-1854,CVE-2022-1855,CVE-2022-1856,CVE-2022-1857,CVE-2022-1858,CVE-2022-1859,CVE-2022-1860,CVE-2022-1861,CVE-2022-1862,CVE-2022-1863,CVE-2022-1864,CVE-2022-1865,CVE-2022-1866,CVE-2022-1867,CVE-2022-1868,CVE-2022-1869,CVE-2022-1870,CVE-2022-1871,CVE-2022-1872,CVE-2022-1873,CVE-2022-1874,CVE-2022-1875,CVE-2022-1876,CVE-2022-2007,CVE-2022-2008,CVE-2022-2010,CVE-2022-2011
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP3 (src):    chromium-102.0.5005.115-bp153.2.101.1
Comment 4 Swamp Workflow Management 2022-06-15 19:20:12 UTC
openSUSE-SU-2022:10010-1: An update that fixes four vulnerabilities is now available.

Category: security (critical)
Bug References: 1200139,1200423
CVE References: CVE-2022-2007,CVE-2022-2008,CVE-2022-2010,CVE-2022-2011
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP4 (src):    chromium-102.0.5005.115-bp154.2.8.1