Bug 1199931 - Spectacle aborts on start
Spectacle aborts on start
Status: RESOLVED FIXED
: 1200004 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Applications
Current
x86-64 openSUSE Tumbleweed
: P5 - None : Normal with 15 votes (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-05-26 06:53 UTC by Oliver Schwabedissen
Modified: 2022-05-29 23:04 UTC (History)
8 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Schwabedissen 2022-05-26 06:53:23 UTC
When trying to start Spectacle (KDE screen shot tool) it aborts with the following message:

> spectacle 
spectacle: symbol lookup error: /lib64/libkImageAnnotator.so.0: undefined symbol: _ZN12kColorPicker12KColorPickerC1Ev
Comment 1 Christophe Giboudeaux 2022-05-26 09:58:36 UTC
That's a sign incompatible packages are used.

Please add the `zypper lr -d` and `rpm -qi spectacle libkImageAnnotator0` output to the report
Comment 2 Penala 2022-05-26 10:07:52 UTC
I can confirm the issue. Both packages are from OS official repos:                   | 


linux@linux-pc:~> rpm -qi spectacle libkImageAnnotator0
Name        : spectacle
Version     : 22.04.1
Release     : 1.1
Architecture: x86_64
Install Date: to 26. toukokuuta 2022 12.13.30
Group       : Productivity/Graphics/Other
Size        : 764586
License     : LGPL-2.0-or-later AND GPL-2.0-or-later
Signature   : RSA/SHA256, su 15. toukokuuta 2022 01.10.10, Key ID b88b2fd43dbdc284
Source RPM  : spectacle-22.04.1-1.1.src.rpm
Build Date  : su 15. toukokuuta 2022 01.09.00
Build Host  : lamb12
Packager    : https://bugs.opensuse.org
Vendor      : openSUSE
URL         : https://apps.kde.org/spectacle
Summary     : Screen Capture Program
Description :
Spectactle is a screenshot-taking program made by KDE. It allows taking screenshots
of screens, windows, regions of the screen, and to export them to files or other
online services.
Distribution: openSUSE Tumbleweed
Name        : libkImageAnnotator0
Version     : 0.5.3
Release     : 1.3
Architecture: x86_64
Install Date: to 26. toukokuuta 2022 12.13.23
Group       : System/Libraries
Size        : 1194251
License     : GPL-2.0-or-later
Signature   : RSA/SHA256, ke 11. toukokuuta 2022 06.06.27, Key ID b88b2fd43dbdc284
Source RPM  : kImageAnnotator-0.5.3-1.3.src.rpm
Build Date  : ke 11. toukokuuta 2022 06.04.45
Build Host  : lamb20
Packager    : https://bugs.opensuse.org
Vendor      : openSUSE
URL         : https://github.com/ksnip/kImageAnnotator
Summary     : Tool for annotating images
Description :
kImageAnnotator is a tool for annotating images.
Distribution: openSUSE Tumbleweed
Comment 3 Eugene Popov 2022-05-26 10:37:41 UTC
The libkColorPicker0 package was updated (0.1.6-1.5 => 0.2.0-1.1) with the last update, maybe that's the reason.
Comment 4 Christophe Giboudeaux 2022-05-26 10:49:56 UTC
(In reply to Eugene Popov from comment #3)
> The libkColorPicker0 package was updated (0.1.6-1.5 => 0.2.0-1.1) with the
> last update, maybe that's the reason.

Yes. kImageAnnotator in openSUSE:Factory wasn't rebuild with the new version

[   10s] [274/284] cumulate libkColorPicker0-0.1.6-1.5
Comment 5 Christophe Giboudeaux 2022-05-27 06:54:31 UTC
kImageAnnotator was rebuilt in openSUSE:Factory after https://build.opensuse.org/request/show/979187.

The issue will be  gone in one of the next Tumbleweed snapshots.
Comment 6 Jan Engelhardt 2022-05-27 08:04:34 UTC
Well, that's a sign that libkColorPicker0 does not have symbol versions when it ought to have - or failed to bump the SO number.
Comment 7 Christophe Giboudeaux 2022-05-29 19:16:57 UTC
*** Bug 1200004 has been marked as a duplicate of this bug. ***
Comment 8 Christopher Yeleighton 2022-05-29 23:04:00 UTC
(In reply to Christophe Giboudeaux from comment #5)
> kImageAnnotator was rebuilt in openSUSE:Factory after
> https://build.opensuse.org/request/show/979187.
> 
> The issue will be  gone in one of the next Tumbleweed snapshots.

I installed from <URL:
https://build.opensuse.org/package/binaries/openSUSE:Factory/kImageAnnotator/standard > and it works.