Bug 1195072 - python3-magic-wormhole missing dependencies
python3-magic-wormhole missing dependencies
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Other
Leap 15.3
x86-64 openSUSE Leap 15.3
: P5 - None : Normal (vote)
: ---
Assigned To: Matej Cepl
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-01-24 19:37 UTC by Klaus Vink Slott
Modified: 2022-03-07 17:17 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Klaus Vink Slott 2022-01-24 19:37:31 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Firefox/91.0
Build Identifier: 

Installed including recommends, crashes on startup. Seems to be missing ipaddress tinguie.

Reproducible: Always

Steps to Reproduce:
1. sudo zypper install --recommends python3-magic-wormhole
2. wormhole send ink_cat.jpg

Actual Results:  
klaus@raagi:~> wormhole send ink_cat.jpg
Traceback (most recent call last):
  File "/usr/bin/wormhole", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3123, in <module>
    @_call_aside
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3107, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3136, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 578, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 895, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 781, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'ipaddress' distribution was not found and is required by magic-wormhole



Information for package python3-magic-wormhole:
-----------------------------------------------
Repository     : Hovedsoftwarekilde
Name           : python3-magic-wormhole
Version        : 0.10.5-bp153.1.17
Arch           : noarch
Vendor         : openSUSE
Installed Size : 1.5 MiB
Installed      : Yes
Status         : up-to-date
Source package : python-magic-wormhole-0.10.5-bp153.1.17.src
Summary        : Securely transfer data between computers
Description    : 
    This package provides a library and a command-line tool...
Comment 1 Matej Cepl 2022-03-03 06:52:51 UTC
https://build.opensuse.org/request/show/958589
Comment 2 OBSbugzilla Bot 2022-03-07 11:10:03 UTC
This is an autogenerated message for OBS integration:
This bug (1195072) was mentioned in
https://build.opensuse.org/request/show/959831 Backports:SLE-15-SP3 / python-magic-wormhole
Comment 3 Swamp Workflow Management 2022-03-07 14:17:49 UTC
openSUSE-RU-2022:0076-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1195072
CVE References: 
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP3 (src):    python-magic-wormhole-0.10.5-bp153.2.3.1
Comment 4 Klaus Vink Slott 2022-03-07 17:17:26 UTC
Just installed the new version. Problem solved :-) Thanks!