Bug 1191697 - network:cluster/singularity: Bug missing BuildRequires: libseccomp-devel
network:cluster/singularity: Bug missing BuildRequires: libseccomp-devel
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE.org
Classification: openSUSE
Component: 3rd party software
unspecified
x86-64 openSUSE Tumbleweed
: P5 - None : Normal (vote)
: ---
Assigned To: Tobias Burnus
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-10-15 11:30 UTC by Stefan Kluth
Modified: 2021-11-08 14:37 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Kluth 2021-10-15 11:30:25 UTC
singularity needs seccomp support to make --fakeroot options in various subcommands (e.g. build) work properly. 

I forked to https://build.opensuse.org/package/show/home:skluth/singularity and added BuildRequires:  libseccomp-devel to the spec file. 

We downloaded the resulting package and tried on my t-weed system, the seccomp related warning messages disappeared and a yum based bootstrap for a centos container worked.

The full yum bootstrapped container build fails later for another reason.
Comment 1 Christian Goll 2021-10-15 12:59:15 UTC
Fixed package is underway to factory. Thanks for pointing this out.
Comment 2 OBSbugzilla Bot 2021-10-15 14:40:06 UTC
This is an autogenerated message for OBS integration:
This bug (1191697) was mentioned in
https://build.opensuse.org/request/show/925433 Factory / singularity
Comment 3 OBSbugzilla Bot 2021-10-26 10:40:16 UTC
This is an autogenerated message for OBS integration:
This bug (1191697) was mentioned in
https://build.opensuse.org/request/show/927451 15.3 / singularity
Comment 4 Swamp Workflow Management 2021-10-29 19:20:09 UTC
openSUSE-RU-2021:1394-1: An update that has one recommended fix can now be installed.

Category: recommended (low)
Bug References: 1191697
CVE References: 
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP3 (src):    singularity-3.8.3-bp153.2.6.1